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Chapter 1  
Introducing FileMaker Pro

FileMaker® Pro is the leading workgroup database software for quickly creating and sharing 
solutions adapted to your business needs. Powerful features, broad platform support, and an 
easy-to-use interface make FileMaker Pro indispensable for anyone in business, government, 
and education who needs to effortlessly manage all their information on iPad, iPhone, Windows, 
OS X, and the web.

About this guide
This User’s Guide contains an introduction to FileMaker Pro features and provides step-by-step 
instructions on the most common FileMaker Pro tasks. You may need to refer to FileMaker Pro 
Help for detailed information on more advanced product features.
To send your feedback on this guide, see 
http://www.filemaker.com/company/documentation_feedback.html.

Using FileMaker Pro documentation
The FileMaker Pro documentation provides a learning path to productivity, installation instructions, 
online Help, and more. 

The following manuals are included:
1 FileMaker Pro User’s Guide (this manual): contains key concepts and basic procedures
1 Installation and New Features Guide for FileMaker Pro and FileMaker Pro Advanced: contains 

installation instructions and a list of the new features in the current version
1 FileMaker ODBC and JDBC Guide: describes how you can use FileMaker software as an 

ODBC client application and as a data source for ODBC and JDBC applications
1 FileMaker SQL Reference: describes the SQL statements, expressions, and functions 

supported by FileMaker
1 FileMaker WebDirect™ Guide: describes how to make FileMaker Pro layouts hosted by 

FileMaker Server accessible to web browser users over an intranet or the Internet

Where to find PDF documentation
To access PDFs of FileMaker documentation:
1 In FileMaker Pro, choose Help menu > Product Documentation.
1 Visit http://www.filemaker.com/documentation for additional documentation.

FileMaker Pro Help 
FileMaker Pro Help provides comprehensive step-by-step instructions on FileMaker Pro features. 
You can open Help from the Help menu in FileMaker Pro. 

There are three ways to access Help:
1 Browse the Help table of contents to locate topics by subject.
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1 Search for particular topics by entering keywords.
1 Get information about the currently displayed dialog box by pressing F1 (Windows) or 

Command-? (OS X). Some dialog boxes display a  (Windows) or  (OS X) button or a 
Learn More link, which you can also use for getting information about the dialog box.

Getting Started tour
You can explore FileMaker Pro through the interactive Getting Started tour. Practice creating, 
modifying, and deleting records; and learn about searching for data values and sorting records, 
displaying data in charts and reports, and importing and exporting data between files. You'll also 
get to know the rich features FileMaker Pro provides for creating your own custom solutions. 
To access the tour, choose Help menu > Product Documentation > Getting Started Tour. Or, 
use FileMaker Quick Start (see “Opening files” on page 16).

Starter Solutions
FileMaker Pro includes Starter Solutions (database template files) that you can use to quickly get 
started designing your FileMaker Pro database solutions. Starter Solutions take advantage of the 
best new FileMaker Pro features. Whenever you start creating databases, check the list of Starter 
Solutions to see if one is available that suits your needs.
You can access Starter Solutions when you open files (see “Opening files” on page 16).
You can find more information, tips, and database ideas on the FileMaker website at  
http://www.filemaker.com.

Suggested reading
Here are some suggestions for using the documentation to help you learn how to do specific tasks 
in FileMaker Pro.

Note   If your database was developed using FileMaker Pro Advanced, you may see customized 
menus or tooltips for layout objects. For an overview of these features, see Help.

Type of user Suggested reading 
Data entry person Chapter 2, “Using databases,” in this guide

Small business owner or educator 
who creates a basic database to 
start, then improves it over time

Chapter 3, “Creating databases,” in this guide. As features are added to the 
database, refer to Help 

Database administrator 1 All chapters in this guide
1 Help, for information on advanced topics
1 FileMaker ODBC and JDBC Guide and FileMaker SQL Reference

New FileMaker Pro user 1 Installation and New Features Guide for FileMaker Pro and FileMaker Pro 
Advanced

1 All chapters in this guide

User upgrading from a previous 
version

1 Installation and New Features Guide for FileMaker Pro and FileMaker Pro 
Advanced

1 Chapter 7, “Converting databases from FileMaker Pro 11 and earlier,” in this 
guide
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FileMaker Pro overview
Here is an overview of the capabilities of FileMaker Pro.

Creating simple or complex database solutions
With FileMaker Pro you can create simple database solutions (database files) consisting of just 
one database table, such as for customer information, or you can create a complex database with 
relationships and multiple database tables. For example, you can create a complex database that 
relates two tables based on a single common value, such as a serial number or an ID number.
 

You can organize your databases as a single table in a single file, as multiple tables in a single file, 
or as multiple tables in multiple files.
FileMaker Pro provides Starter Solutions designed for business, education, and personal 
purposes. The templates can be quickly customized to suit your needs.
For more information, see chapter 3, “Creating databases.”

Using layouts to display, enter, and print data
FileMaker Pro layouts determine how information is organized for viewing, printing, reporting, 
finding, and entering data. Layouts do not store your data—they just display it.
Database files can have many different layouts, which display data in a variety of ways. Within one 
database file you can design separate layouts for entering data, reporting summaries, printing 
mailing labels, displaying data graphically in charts, working with a database in a web browser or 
on a touch device, and so on. You can change a layout’s design without affecting the data or other 
layouts in the file. When you change the data in a field, the changes are reflected in the same field 
on all the layouts in the database.

A database consisting of one table

A database consisting of multiple tables, with a 
portal to display records from a related table

Portal
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In a layout, you choose, arrange, and modify fields and field labels, create reports, add buttons to 
initiate scripts, add graphics and text, and specify printing options. 
Not all information needs to be stored in your FileMaker Pro database. For example, you can add 
a web viewer to display a web page on a layout. There are some restrictions for displaying web 
content in FileMaker Pro. 
Choose different layout types in the New Layout/Report assistant. Use these different layout types 
for various purposes, like displaying a data entry screen on a computer or an iPad, or printing a 
totaled sales report or formatting data as mailing labels. You can customize each layout further by 
using the design tools that are available in Layout mode. 

For more information, see “Creating layouts and reports” on page 73.

Finding, sorting, and replacing data
Features for finding, sorting, and replacing data allow you to manipulate your data in many ways.
You can find records that meet criteria you specify, such as records entered on a certain date or 
addresses in a particular city. You can open another window in order to perform different searches 
on the same data.
You can rearrange records in order to view or print them in a different sequence. For example, you 
can sort fields alphabetically, numerically, by date, or by a custom sort order.
 

Steve Williams
789 Ninth Avenue
New York, NY 10001

The same data can be arranged differently with multiple layouts

Juanita Alvarez 555-1234
Michelle Cannon 555-1234
Andre Common 555-1234
Marie Durand 555-1234
Jean Durand 555-1234
William Johnson 555-1234
John Lee 555-1234
Patrick Murphy 555-1234
Le Nguyen 555-1234
Kentaro Ogawa 555-1234
Mary Smith 555-1234
John Smith 555-1234
Sophie Tang 555-1234
Steve Williams 555-1234
Betty Wilson 555-1234

Contacts

Dear Sophie,

Thank you for ordering with us. We value 
your business and appreciate the 
opportunity to serve you.

If you have any questions about your order, 
please call us—we want you to be satisfied 
with your purchase.

Sincerely,
John Lee

Customer records sorted by last name
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You can search for and replace data across multiple fields, similar to the way you find and replace 
data in word processing applications. You can also save a found set of records as a snapshot link 
and send the link to another person.
For more information, see “Finding records” on page 31, “Sorting records” on page 43, and 
“Finding and replacing data” on page 42.

Protecting databases
You can restrict what users see and do in a database file by defining accounts and privilege sets. 
Accounts authenticate users who are attempting to open a protected file. Each account specifies 
an account name and (usually) a password. Any user that cannot specify valid account information 
won’t be able to open a protected file. A privilege set specifies a level of access to a database file. 
Each account is assigned a privilege set, which determines the level of access when someone 
opens a file using that account.
Extended privileges determine the data sharing options that are permitted by a privilege set, such 
as whether a privilege set permits users to open a shared file or view a database in a web browser.
You can further protect a file by authorizing other FileMaker Pro files to create references to the 
schema (tables, layouts, scripts, and value lists) in that file, and by preventing a file from being 
opened with a version of FileMaker Pro, FileMaker Go®, or FileMaker Server that's earlier than the 
specified version. 
For more information about FileMaker Pro database security, see chapter 6, “Protecting 
databases.”

Creating scripts to automate tasks
Scripts can do simple tasks like setting print orientation, or complex tasks like preparing a 
customized mailing to customers. 
For example, you could define a script that creates a thank you letter to customers in your 
database who have made a purchase in the last week. The script composes a letter customized 
to each customer. The script then switches to Preview mode and pauses so that you can see what 
the letter looks like before it prints. The whole task is started by clicking a button on a layout.
You can build scripts by selecting from a list of FileMaker Pro script steps, specifying options, and 
arranging the steps in the correct order to perform the task. FileMaker Pro makes it easy to 
manage and maintain scripts, even for complex databases. You can simultaneously view, edit, and 
manage scripts from different databases. For more information about scripts, see “Automating 
tasks with scripts” on page 49.
You can also set up script triggers to specify that scripts run when particular events occur. For 
more information, see Help. 

Sharing and exchanging data
A benefit of storing data in FileMaker Pro is sharing your data with others. You can share your data 
with other FileMaker Pro or FileMaker Go users on a network, or import or export data from 
another file. In addition, you can use ODBC (Open Database Connectivity) and JDBC (Java 
Database Connectivity) to share FileMaker Pro files with ODBC- and JDBC-compliant 
applications, or you can access data from external data sources. If you have FileMaker Server, 
you can use FileMaker WebDirect to publish databases hosted by FileMaker Server to share data 
over the web, and you can upload files to FileMaker Server.
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If your computer is connected to a network, you and other FileMaker Pro or FileMaker Go users 
can use the same FileMaker Pro database file simultaneously. FileMaker Pro Network sharing 
supports the sharing of files with up to 5 concurrent users. 

Note   To support more users and web publishing technologies such as XML, PHP, and 
FileMaker WebDirect, FileMaker recommends the use of FileMaker Server.

You can set up a FileMaker Pro file to automatically update data imported from another application 
such as Microsoft Excel. Recurring import occurs automatically the first time you view the layout 
containing the data from the external file. Later, you can run a script to update data. For more 
information about recurring import, see “Setting up recurring imports” on page 130.
For more information about sharing and exchanging data, see chapter 5, “Sharing and 
exchanging data.”

Saving and sending data in other formats
FileMaker Pro lets you save data in different file formats, such as Microsoft Excel worksheets and 
Adobe PDF files, so you can give the files to users who do not have FileMaker Pro. You can 
automatically email the files after saving them. For more information, see “Saving and sending 
data in other formats” on page 130.



Chapter 2  
Using databases

This chapter explains the basics of how to:
1 open, close, and save files
1 create records in a database
1 add and edit data in fields
1 find records using different criteria
1 omit records from the found set
1 find and replace data
1 sort data
1 print data, scripts, table and field information, and the relationships graph
1 use scripts

See Help for detailed, comprehensive information and step-by-step procedures about using 
FileMaker Pro.

Note   Some procedures refer to using a shortcut menu. To display a shortcut menu (context 
menu), right-click or Control-click an object or area to see a list of commands. You can use the 
Control Panel (Windows) or System Preferences (OS X) to configure your mouse, trackpad, or 
input device. For example, you can set up a secondary button on a mouse.

About database fields and records
A database is a collection of information, or data, that you can organize, update, sort, search 
through, and print as needed. Unlike an electronic spreadsheet, which is used to tabulate and 
calculate data stored in the cells of a rectangular table, a database is a collection of knowledge 
tied together by a schema that describes the organization of database tables, their fields, and the 
relationships between the fields and tables.
Certain tasks are better suited to each of these important business productivity tools. 
Spreadsheets are best used for tasks such as maintaining a business ledger, where data needs 
to be recorded and calculated, but not presented or analyzed in multiple formats. Databases are 
best for tasks such as inventory control, where you need to track consumption and losses and 
generate reports on inventory status over time. An inventory database can sort and report on 
inventory information in many ways, allowing you to analyze data by item type, by sales figures, 
by monthly consumption, and so on.
Your own address book or filing cabinet is an example of a simple database. With the address 
book and filing cabinet, you store similar pieces of information organized for easy retrieval. With 
a filing cabinet, you must choose a way to sort your data, for example, alphabetically by last name 
or by region. By storing contacts and addresses in FileMaker Pro, you can organize your 
information in many ways. You can sort your information by country, city, last name, or even sort 
by all three of these fields.
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An invoicing system is an example of a more complex database, with multiple related tables, 
multiple layouts, and calculated fields.
You can also view a subset of your data; for example, view only invoices for a particular month. A 
database doesn’t just hold information—you use a database to organize and analyze information 
so that you understand its significance.
Fields are the basis of a database table. Fields are used to store, calculate, and display the data 
you enter into a record. Each piece of information in a record—like name, ID number, and 
telephone number—is stored in a field.
A database table contains one or more fields that hold similar information about one subject or 
activity. For example, the fields on a record in the Customers table contain address information for 
one customer. Tables also define the organization of records based on that table.
A database can consist of one file with one table, which might hold the names, addresses, and 
telephone and fax numbers of all your customers. A database can also consist of several files, 
each of which can contain one or more tables that, together, contain all the information about 
related topics (sometimes called a database system). Using the relational capabilities of 
FileMaker Pro, you can join information between files and tables to create a relational database. 
For example, one table can show you which customers bought a particular item and a related table 
can show how much they paid.

B C

Michelle Cannon
123 4th St. SW
Edmonton
(717) 555-0011

CAN N4V 1LN

Records

Fields

Your address book is like a database

Invoices table

002Customer ID

Andre CommonCustomer Name

818-555-1234Phone 

Product ID Product
FB3

Price
Baguette $3.95

FB14 Croissants $9.95

12345Invoice ID

FB3Product ID

BaguetteProduct

$3.95Price

002Customer ID

Andre CommonName

818-555-1234Phone

Products tableCustomers table

34Stock
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To enter data in a database table, you make a new record and enter values into the fields that 
belong to that record. Values can be typed into a field, imported from another application, or 
entered in a number of other ways.
FileMaker Pro also allows you to access and view data that is stored in non-FileMaker Pro files. 
For example, if you have access to data stored in a SQL database, you can display information 
from the external database and work with that data in your FileMaker Pro file.

Opening files

To open a file if FileMaker Pro isn’t running

Choose one of the following methods:
1 Double-click the FileMaker Pro file. 
1 Drag the file onto the FileMaker Pro application icon.
1 Double-click the FileMaker Pro application icon and choose the file you want to open. If you see the 

Quick Start Screen, see “To open a file using FileMaker Quick Start,” below, for more information.

To open a file if FileMaker Pro is already running

1. Choose File menu > Open. 

Tip   You can also choose File menu > Open Recent or File menu > Open Favorite.

2. In the Open File dialog box, select the filename and click Open.

3. If you’re asked for an account name and password, type them in the Password dialog box, then 
click OK.

To open a file using FileMaker Quick Start

1. To have the Quick Start Screen appear, do one of the following.
1 Start FileMaker Pro.
1 If FileMaker Pro is running or if you start FileMaker Pro and you don’t see the FileMaker 

Quick Start Screen, choose Help menu > Quick Start Screen.

FileMaker Quick Start Screen (OS X)
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2. When the FileMaker Quick Start Screen appears, do one of the following.

3. Double-click a file to open it. 

The FileMaker Quick Start Screen provides a central place where you can do several tasks in a 
variety of ways. In addition to opening files, you can:
1 Create and design a new empty FileMaker Pro file. See “Creating a FileMaker Pro file” on page 55.
1 Convert a file of a different format (such as Microsoft Excel) that already contains data. See 

“Converting a data file to a new FileMaker Pro file” on page 134.
1 Create files using empty predesigned Starter Solutions provided by FileMaker, Inc. See 

“Creating a FileMaker Pro file” on page 55.
1 Work with the Getting Started tour. See “Getting Started tour” on page 9.

For more information about using FileMaker Quick Start, see Help.

To open a file that is being shared over a network

1. Choose File menu > Open Remote.

2. In the Open Remote File dialog box, select View for a list of hosts.

3. To see the available files from a host, select the host. In the Available Files list, select the file 
you want to open.
Or, for Network File Path, type the network path (for example, 
fmnet:/hostIPaddress/fileName).

4. Click Open.
Windows: Depending on how FileMaker Network sharing is configured on the host, you might 
be required to enter an account name, password, and domain name.

Do this To
Click Recent Files in the box at 
the center of the Quick Start 
Screen

Display a list of FileMaker Pro files that you have recently opened. If no recent 
files are listed, choose Edit menu > Preferences (Windows) or FileMaker Pro 
menu > Preferences (OS X), select Show recently opened files, enter a 
value from 1 to 30 indicating the number of recent files you want to display in 
the list, then click OK. (To remove the list of recently opened files, choose File 
menu > Open Recent > Clear Recent Files.)

Click Favorite Files in the box 
at the center of the Quick Start 
Screen

Display a list of FileMaker Pro files that you have marked as favorite. 

Click the host name or IP 
address of a remote computer

Display a list of FileMaker Pro files stored on a remote computer.

Click Browse Locate the local or remote files that you want to open.

Choose To display
Favorite Hosts Hosts you previously added as favorites

Local Hosts FileMaker Pro hosts on your TCP/IP subnet

Hosts Listed by LDAP FileMaker Pro hosts available through the specified LDAP server



Chapter 2  |  Using databases 18

Keep the following points in mind:
1 If Show recently opened files is selected in the General preferences, files you have recently 

accessed appear in the list of recently opened files (by choosing File menu Open Recent or by 
clicking Recent Files in the FileMaker Quick Start Screen). See Help for information about 
adding local or remote files to the Favorite Files list in the FileMaker Quick Start Screen. 

1 To open and share a file, see “Enabling file sharing and hosting files” on page 125.
1 You can open FileMaker Pro files created in Windows on a computer running OS X, and vice 

versa. If you intend to move files across platforms, it’s best to include the .fmp12 extension in 
the filename. If you add or remove filename extensions, you must redefine the FileMaker data 
sources for related files and for files with external scripts.

1 You can set a default account name and password for a file in the Open tab of the File Options 
dialog box. When you do so, users automatically log in using a specific account and password 
(if specified) when they open a database. For more information, see Help.

1 When a file you are opening is hosted, you may see an icon in the lower-left corner of the 
FileMaker Pro window. This icon indicates the security level of the connection to the host. A  
icon means the connection is encrypted (SSL). A  icon means the connection is encrypted 
(SSL) and verified with a certificate. For more information, see your database administrator. 
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Opening multiple windows per file
You can open more than one window per file. This allows you to view the same layout in separate 
windows, or simultaneously view different layouts in the same file. You can perform find or sort 
operations independently in the different windows.
To open an additional window, choose Window menu > New Window. Another window appears. 
Initially, the window displays the same layout, sort order, and found set as the previously active window. 

To view a different layout in the new window, choose a layout from the Layout pop-up menu in the 
layout bar, or choose View menu > Go to Layout. For information on finding records, see “Finding 
records” on page 31. For information on sorting records, see “Sorting records” on page 43. For 
more information about opening multiple windows, see Help. 

The original database 
window, in Browse mode, 
in which you can view the 
records

A second window, in 
Find mode, in which you 
can perform a different 
search on the same 
found set
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Closing windows and files
You can close FileMaker Pro windows and files as you would in most Windows and OS X 
applications.

To close a window, do one of the following:
1 Windows: Double-click the document icon in the upper-left corner of the document window.
1 Windows: Click the close box in the upper-right corner of the document window.
1 OS X: Click the red close button in the upper-left corner of the document window.
1 Choose File menu > Close.

To close a file, use the procedures above to close all the open windows for a file.

Note   Even if you close a file, it may remain open as a hidden file if the window of any other file 
is displaying data from that file. (For example, another window may be displaying related data from 
the file you attempted to close.) FileMaker Pro will close the file when you close all the dependent 
windows. 

Saving files 
By default, FileMaker Pro automatically saves changes to your data as you work, so there is no Save 
command. If you want more control over when record data is saved, you can clear the Save record 
changes automatically option (in the Layout Setup dialog box) individually for each layout. For 
more information, see Help.
You can save a copy of your file as a backup or save a clone of your file with no data. To save a copy 
of your file in a non-FileMaker format, see “Saving and sending data in other formats” on page 130.

Important   Always save a copy of a file before you make extensive changes. You can’t restore 
data after you delete a field from the Manage Database dialog box (or the Field Picker dialog box) 
or remove records using the Delete Record or Delete All commands.

To save a copy of your file:

1. Make the file you want to save the active file, and choose File menu > Save a Copy As.

2. Navigate to where you want to save the copy on your hard disk.

3. For File name (Windows) or Save As (OS X), type a filename.

4. Windows: For Save as type, choose FileMaker Files.
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5. For Save a (Windows) or Type (OS X), choose one of the following options:

Note   To have a copy of a file that includes container data that's stored externally, choose self-
contained copy. The copy of current file and compacted copy options do not copy 
externally stored data. To use either of those options, you'll need to embed data in the container 
fields first. For more information, see Help.

6. Click Save.

What FileMaker Pro doesn’t save
FileMaker Pro doesn't save changes to the state of a file, if they are the only changes you make 
while the file is open. For example, here are some changes that are not saved:
1 Displaying a different record or layout
1 Sorting records or modifying a sort order
1 Performing find operations such as Find, Show All Records, Omit Record, or modifying a find 

request
1 Changing the position and size of windows or opening a new window
1 Showing or hiding the status toolbar
1 Changing ruler display settings
1 Changing the unit of measure

For example, if you open a file, sort records, and then close the file, FileMaker Pro does not save 
the sort order. However, if you open a file, add a new record, sort the records, and then close the 
file, FileMaker Pro saves the sort order as well as the new record.
For more information about saving files, see Help.

Choose To
Copy of current file Duplicate the entire file, including the tables, field definitions, layouts, scripts, page 

setup options, and data. Duplicating a file is useful before you make extensive 
changes to the file. 

Compacted copy 
(smaller)

Compact the entire file into less disk space by reclaiming unused space in the file. 
Saving a compacted copy is useful if you edit many records frequently.

Clone (no records) Save a file’s tables, field definitions, layouts, scripts, and page setup options, 
without the data. Make a clone when you want a template of the file schemas. 

Self-contained copy 
(single file)

Create a copy of the current file with all container data that is stored as a file 
reference or stored externally (by both open and secure storage) embedded in the 
file’s container fields.
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About modes
You work with data in FileMaker Pro in Browse, Find, Layout, or Preview mode. You can choose a 
mode from the View menu or from the mode pop-up menu at the bottom of the document window.

Using the status toolbar
The status toolbar provides quick access to many FileMaker Pro menu commands. In all modes, 
it includes navigation tools, customizable buttons, and a layout bar for working with layouts. In 
Layout mode, it includes layout tools. Move the pointer over a button to see its description. You 
can also switch modes by clicking buttons in the status toolbar. The buttons in the status toolbar 
vary depending on which mode you’re in. 

In Layout mode, you can also use the Inspector when you format and edit objects on a layout. For 
more information, see “Using the Inspector to format objects” on page 83. 
For more information about using the status toolbar, see Help.

Viewing records 
FileMaker Pro provides three views of each layout: form, list, and table. When you change views, 
you temporarily change the way records display or print.

Use this mode To
Browse mode Work with the data in a file. You can add, view, change, sort, omit (hide), and delete records. 

Browse mode is where you’ll do most of your work, such as data entry. 

Find mode Search for particular records that match a set of criteria. You can then work with this subset 
of your records, called the found set. After you find a group of records, FileMaker Pro returns 
to Browse mode so you can begin working with them. 

Layout mode Determine how information is presented on your screen or in printed reports, labels, and 
forms. Design layouts for specific tasks, like data entry or printing invoices or envelopes. 
Select and arrange fields and other objects to modify an existing layout or create new layouts.

Preview mode See how data in forms or reports will look before you print. Preview mode is especially useful 
for viewing layouts with multiple columns (like mailing labels) and reports with summaries.

Mode pop-up menu

Status toolbar Layout bar
Formatting bar

To view records Do this in Browse mode or Find mode
Individually Choose View menu > View as Form, or click Form View  in the layout bar.

In a list Choose View menu > View as List, or click List View  in the layout bar.

In a spreadsheet-like table Choose View menu > View as Table, or click Table View  in the layout bar. 
Each row displays a record, and each column displays a field.
For information about working with data in a spreadsheet-like table, see “Working 
with data in Table View” on page 29.
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The following illustration shows the same layout in three views.

Form View

List View

Table View

Current record

A row is one record

Field labels

Field labels

Field labels

Current record

Current record
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Selecting the current record
In Browse mode, a table has one current (active or selected) record at a time for each window. For 
more information about moving through records, see “Moving through records” on page 24.

To select a related record in a portal, select the portal row (click inside the row but outside any 
fields in the row).

For information about related records and portals, see chapter 4, “Working with related 
tables and files.”

Moving through records
To move from one record to another, use the book in the status toolbar.

In this view The current record is
Form View The record that you’re displaying. To select another record and make it the current record, 

move to the other record. 

List View The record that has a different fill from the other records. To select another record and 
make it the current record, click that record or use controls in the status toolbar. 
The current record can also be indicated by a solid vertical bar along the left side.

Table View The record that’s highlighted in the record margin at the left of the record. To select 
another record and make it the current record, click that record or use controls in the 
status toolbar. 

Click inside the portal row to 
select a related record

Portal

Slider

Current record 
number Number of records in the tableBook 

Type search words 
for quick finds
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You can also use a mouse scroll wheel to move through records. For more information about 
viewing records, see Help.

Adding and duplicating records
When you add or duplicate records, FileMaker Pro stores new records at the end of the current 
table. In Browse mode, you see the new record after the current record, or after the last record in 
the found set (the set of records made active by a find request).
1 If records are sorted, by default the new record appears in the correct position in the sort order 

when you commit the record. For information about changing this setting, see Help.
1 If records are unsorted, the new record appears after the last record in the found set. For more 

information, see “Sorting records” on page 43.

Note   If a file is locked or write-protected, or if you don’t have access privileges to create records, 
FileMaker Pro will not add or duplicate records.

If the field is defined to automatically enter field values, you see those values entered in the new 
record. See “Defining automatic data entry” on page 68.
To enter or change values in the new record, see “Entering and changing data in fields” on page 28.

To move Do this
To the next record in the current 
table 

Click the right page of the book or choose Records menu > Go to Record > 
Next.

To the previous record in the 
current table 

Click the left page of the book or choose Records menu > Go to Record > 
Previous.

Quickly to a specific record 1 Click the current record number, type the record number you want, then press 
Enter (Windows) or Return (OS X).

1 With the current record selected, press Esc, type the record number, then 
press Enter or Return.

1 Choose Records menu > Go to Record > Go To, then type the number of 
the record.

Quickly through records Drag the slider right or left to move forward or backward.

Through records in List View or  
Table View

Use the scroll bar on the right side of the window.

To a record with a unique value 
that you know

See “Finding records” on page 31.

To Do this in Browse mode
Add a new blank record In Browse mode, click New Record in the status toolbar. You see a blank 

record with one field selected. 

Quickly add a record with the same or 
similar data as an existing record

Select the record to duplicate. Then, choose Records menu > Duplicate 
Record. 

Add or duplicate related records See “Adding and duplicating related records” on page 26.
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Adding and duplicating related records
If you’re working with records in related tables, you can add records to a related table when you 
enter data in a record in the current table.

Note   You can only add related records from the current table if the relationship is defined to allow 
the creation of related records. If a related table is in a write-protected file, or if you don’t have 
access privileges to create records, FileMaker Pro will not add or duplicate records. For more 
information, see “Creating relationships” on page 118. 

For more information about adding and duplicating records, see Help

To Do this in Browse mode
Create a record in the current 
table

Click New Record in the status toolbar.

Add a record to a related table 1 If the related field is in a portal, type data into the field in the last (empty) row 
of the portal, then commit the record (for example, by clicking anywhere 
outside the record or selecting another record).

1 If the related field isn’t in a portal, type data into the field, then commit the 
record (for example, by clicking anywhere outside the record or selecting 
another record).

Duplicate a record that is 
displaying related data

Be sure no records in a portal are selected, then choose Records menu > 
Duplicate Record. 
Note   Records in related tables are not duplicated.

Duplicate a related record in a 
portal

Select the record in the portal, then choose Records menu > Duplicate 
Record.

Portal with related 
records from Line 

Items table
Type in the last row of 
the portal to add a 
related record to the 
Line Items table
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Deleting records
When you delete a record, you permanently discard the data in all the fields in that record. 

Important   You can’t retrieve deleted data, and you can’t undo the action of deleting records. 
Before you delete records, consider making a backup copy of your file.

If you’re working in a relational database and the option to delete related records is selected in the 
Edit Relationship dialog box, FileMaker Pro deletes related records when you delete a record. 

Entering data
Note   If a file is locked or write-protected, or if you don’t have privileges to edit certain records or 
fields, you may not be able to modify data. 

Selecting a field

To delete Do this in Browse mode
One record Select the record to delete. In the status toolbar, click Delete Record, then click Delete.

A related record Select a portal row in the current table by clicking inside the row but outside any fields in 
the row. In the status toolbar, click Delete Record, then click Delete.
Note   To delete related records, Allow deletion of portal records must be selected in 
the Portal Setup dialog box.

A group of records Make sure the found set contains only the records you want to delete. (See “Finding records” 
on page 31.) Choose Records menu > Delete Found Records, then click Delete All.

All records in a table Click Show All in the status toolbar, or choose Records menu > Show All Records. 
Choose Records menu > Delete All Records, then click Delete All.

All records in a 
database

Create a clone of the database with no records. See “Saving files” on page 20.

To Do this in Browse or Find mode
Select a field Click in the field.

Select the contents of a field Select the field, then choose Edit menu > Select All.

Move to the next field in the tab 
order

Press Tab.
Note   To set the Return or Enter key(s) to move to the next field, in Layout mode, 
select the fields. Click Inspector  in the layout bar, then click Data. In the 
Behavior area, for Go to next object using, select the keys you want to use for 
exiting fields.
Buttons, popover buttons, tab controls, and slide controls can be included in the 
tab order. Fields on tab panels or slide panels that are not on the front-most panel 
are skipped.

Move to the previous field in the 
tab order

Press Shift-Tab (or Shift-Return or Shift-Enter, if enabled).

Move to items in a value list Press the arrow keys.
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Entering and changing data in fields
You can enter or import data up to the character limit for the field type. You can view and print only 
the data that fits within the field boundaries.

Note   For information about how FileMaker Pro uses system formats to display and sort dates, 
times, and numbers, see Help.

To Click in the field in Browse mode, then
Enter data in a text field Type the text. 

Note   In a field set up to auto-complete, you see suggestions based on what you 
type.

Enter data in a number field Type the values (from 10400 to 10-400).

Enter data in a date field Type one date on one line in the field. Type the day, month, and year as numbers 
(for example, 3/3/2014), separated by a nonnumeric character like – (minus) or / 
(forward slash). 
Note   You cannot use a : (colon) as a date separator.
Important   If you enter dates with two-digit years, FileMaker Pro converts them 
to four-digit year dates using a conversion method described in Help. To avoid 
misinterpretations during conversion, always enter dates with four-digit years.

Enter the current date in a date, 
number, or text field

Choose Insert menu > Current Date.
Select the date using the drop-down calendar, if available.

Enter data in a time field Type the time of day (or time duration) as:
1 hours
1 hours and minutes
1 hours, minutes, and seconds
1 hours, minutes, seconds, and fractional seconds
Separate hours, minutes, and seconds by a nonnumeric character like : (colon). 
Separate fractional seconds by a . (period).
Type the time of day in 24- or 12-hour format, with or without AM or PM. (AM is 
assumed for a time less than 12:00.)

Enter the current time in a time, 
number, or text field

Choose Insert menu > Current Time.

Enter data in a timestamp field Type the date and time (for example, 10/10/2014 3:15:05 PM). Type the day, 
month, and four-digit year as numbers, separated by a nonnumeric character like 
– (minus) or / (forward slash).
Note   You cannot use a : (colon) as a date separator.
Then type the time of day as:
1 hours and minutes 
1 hours, minutes, and seconds
1 hours, minutes, seconds, and fractional seconds
1 Type AM or PM if the time is not in 24-hour format
Separate hours, minutes, and seconds by a nonnumeric character like : (colon). 

Enter the current date and time 
in a timestamp field

Choose Insert menu > Current Time.
Select the date using the drop-down calendar, if available.

Insert a tab character in a field Click where you want to insert the tab. Press Ctrl+Tab (Windows) or Option-Tab 
(OS X).

Delete data from a field Select the data, then press Backspace or Delete.
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Working with data in Table View
You can work with data in Table View to quickly create and change field definitions; add, modify, 
and delete records; sort records; create dynamic reports; and create quick charts. FileMaker Pro 
displays each record in a separate row, and each field in a separate column.

To work with data in Table View, click Table View  in the layout bar when you’re working in 
Browse mode. 

Displaying data in Table View
You can change the display settings in Table View. 

Insert an audio, video, image, 
PDF, or other type of file in a 
container field

For information, see Help.

Add data to value lists (fields 
formatted as radio or option 
buttons, checkboxes, lists, or 
menus)

For information, see “Setting up checkbox sets and other controls on a layout” on 
page 91. 

Edit, format, or check the 
spelling of text in a field or edit 
dictionaries

For information, see Help. 

To Click in the field in Browse mode, then

To Do this
Reorder columns Click a column heading and drag it to a new location. 

Resize a column Move the pointer to the edge of the column heading. When the pointer changes to a 
double arrow ( ), drag it to the desired size.

Set a precise column width Select one or more columns, then right-click and choose Table View > Set Column 
Width from the shortcut menu. In the dialog box, type a width, choose units from the 
list, then click OK.

Change the color of the 
background

Right-click the left or right margin of a record, choose Part Color from the shortcut 
menu, then choose a color. The color of the row for adding new records and the 
column for adding new fields will be slightly darker than the main background color.

Column headings. Each 
column displays one field 

from the current layout. 

Active 
record

Record margin
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Working with records in Table View
When you view records in a table, FileMaker Pro displays data in rows and columns. Each row 
displays a record, and each column displays a field.

Note   You can set field options such as validation or indexing when you define a field, or at a later 
time. See “Setting options for fields” on page 67.

For more information about working with data in Table View, see Help

Display a different 
background color for 
alternating records

Right-click the left or right margin of a record, then choose a color from the Alternate 
Color shortcut menu.

Restore the default display 
settings

Right-click a column heading and choose Table View > Reset from the shortcut menu.
Note   Resetting Table View doesn’t delete the fields and records.

To Do this in Browse mode
Add a new record Click + in the left margin at the bottom of the table. A new row is added to 

the end of the table if the records have not been sorted or if Keep records 
in sorted order is cleared in the Sort Records dialog box.

Enter data in fields Click in the field, and enter data in the field. See “Entering and changing 
data in fields” on page 28.
Note   FileMaker Pro saves changes to your data as you work. To see how 
your data looks in other views, click Form View  or List View  in 
the layout bar.

Duplicate a record Right-click the left or right margin of the record that you want to duplicate, 
then choose Duplicate Record from the shortcut menu.

Delete a record Right-click the left or right margin of the record that you want to delete, then 
choose Delete Record from the shortcut menu.

Copy the data in a record Right-click the left or right margin of the record that you want to copy, then 
choose Copy Record from the shortcut menu. You can paste the copied, 
tab-separated data into a field or into Microsoft Excel.

Sort records by one or more fields Select a column heading and optionally Shift-click additional headings. 
Right-click one of the selected column headings and choose Sort 
Ascending or Sort Descending. A sort icon appears on the column 
headings indicating the sort setting (ascending or descending). If you 
selected multiple columns, the order in which columns were selected 
determines the sort order.
You can also choose Sort By Value List and then select a value list from 
the submenu.
For more information, see “Sorting records” on page 43.

Create a dynamic report For information, see Help. For example, you can create a quick report to 
group your data by a field, display subtotals for a field, or create subtotals 
for each group of data. 

Create a quick chart For information, see Help. For example, you can quickly create a chart from 
Table View based on the data in the current field. 

Save data as a Microsoft Excel file or 
Adobe PDF file, or save the current 
found set of records as a snapshot link

Right-click the left or right margin, then choose an option from the 
Save/Send Records As shortcut menu.

Send email messages based on 
record data

Right-click the left or right margin of the record, then choose Send Mail 
from the shortcut menu. 

To Do this
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Finding records 
To find particular records in your database, you can:
1 perform a quick find in Browse mode (see “Performing quick finds in Browse mode” on page 31)
1 make a find request in Find mode (see “Making find requests in Find mode” on page 32)

Performing quick finds in Browse mode
If a layout is enabled for quick find in Browse mode, you can use the search box in Browse mode 
to search for data across multiple fields on the layout. Quick find is helpful if the data you are 
looking for might be in multiple fields or if you don’t know which field contains the data. 
When a layout is enabled for quick find, all fields that are supported for quick find (including merge 
fields) are set to be included in the search. Quick find does not search summary, container, or 
global fields. (To enable a layout for quick find, see “To configure and enable quick find” on 
page 32.)

Note   While quick finds are an easy way to search for data, they can work slowly depending on 
the type of data in the database. For example, unstored calculations or related or remote data can 
slow progress, compared with data that's local or stored.

To perform a quick find

1. In Browse mode, type one or more words in the search box in the upper-right corner of the 
status toolbar.

2. Press Enter (Windows) or Return (OS X).
The search includes all the fields that are enabled for quick find on the layout. Your find request 
returns a found set of records. The light green area of the pie chart  in the status toolbar 
indicates the portion of the total records displayed.

Keep the following points in mind:
1 The only find operator supported by quick find is the match phrase operator, double quotation 

marks (" ").
1 If you type more than one word in the search box, FileMaker Pro searches for records that have 

all of the words you typed.

To view a list of recent quick finds

1. In Browse mode, click the down arrow in the search box.

2. Do one of the following:
1 Choose a search term from the search history list to perform a quick find for the term.
1 Choose Clear Recent Searches to remove the search history.

Note   The list of recent quick finds is available only until you close the file.



Chapter 2  |  Using databases 32

To configure and enable quick find

If the selected layout doesn’t show the quick find badges for supported fields in Layout mode, use 
the following steps.

1. In Layout mode, choose View menu > Show > Quick Find.
A small badge next to each field shows if the field has been enabled for quick find. If there is no 
quick find badge next to a field, the field is not searchable, either because it is not supported for 
quick find or because it is not set to be included in the search. A gray badge  indicates that 
the layout is disabled for quick find. A green badge  indicates that the field is searchable. A 
yellow badge  indicates that the field is searchable, but the search might take longer than 
fields with the green badge.

2. Select one or more fields.

3. Click Inspector  in the layout bar, then click Data.

4. In the Behavior area, select Include field for Quick Find.

5. To enable quick find, click Layout Setup  in the layout bar. In the Layout Setup dialog box, 
select Enable Quick Find, then click OK.

For more information about quick finds, see Help.

Making find requests in Find mode
When you perform a find in Find mode, you type criteria (the value or values to find) into fields in 
a find request, which looks like a blank record. FileMaker Pro searches through all the records in 
a table, comparing the criteria you specify with the data in the table. 
Records with data matching the criteria become the found set, which is the subset of records being 
browsed. Records that don’t match are omitted. You can constrain (narrow) or extend (broaden) 
the found set in Find mode.
You can work with just the records in the found set. For example, you can view, edit, calculate 
summaries for, sort, print, delete, export, or replace data in these records. You can also open a 
new window in order to perform different find requests on the same data.
You can save the found set of records and email it as a snapshot link. (For more information, see 
Help.)
You cannot perform a find in summary fields, container fields, or fields defined with the global 
storage option.

Note   In Find mode, a badge  indicates a searchable field.
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To make a find request

1. In Find mode, from the Layout pop-up menu, select a layout that includes the fields that contain 
the data you want to search.
If necessary, you can change layouts and enter criteria on more than one layout.

2. In the find request, select a text, number, date, time, timestamp, or calculation field to use for 
finding, and then type a value in the field. 
You can use the Insert Operators list in the layout bar to help you enter criteria. You can click 
Omit to exclude records matching a specific set of criteria.

3. Click Perform Find.
Your find request returns a found set of records. The light green area of the pie chart in the 
status toolbar indicates the portion of the total records displayed.

Choose a layout 
with fields you 

want to search on

Type find criteria in fields

Click to see 
operators

A badge indicates you 
can search on the field
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You can do one or more of the following during or after performing a find request:

Finding text and characters
Search for text in text fields, or in calculation fields that return a text result.
Unless you search for phrases and exact matches, the field can contain other values in addition 
to the one(s) you specify, and the values can be in any order. For example, typing hotel in a 
field named Accommodation finds records for Hotel, Discount Hotel, and Hotel, Luxury. 

To Do this
Cancel a find operation before it is finished and 
leave the previous found set unchanged

Press Esc (Windows) or 2-period (OS X).

Change or refine criteria after performing a find 
request

See “Viewing, repeating, or changing the last find” on page 41.

Narrow an existing found set See “Constraining (narrowing) a found set” on page 39.

Broaden an existing found set See “Extending (broadening) a found set” on page 40.

Show all records again In Browse mode, choose Records menu > Show All Records.
In Find mode, choose Requests menu > Show All Records.
You don’t need to choose Show All Records before performing 
finds. FileMaker Pro always searches all records in the tables you 
specify unless you have narrowed the existing found set.

Open another window in order to perform 
different find requests on the same data

Choose Window menu > New Window.

To find Type this in the field Examples
Words that start with specific Roman 
characters (works with fields that use 
any language except Japanese)

The characters Chris Smith finds Chris Smith, 
Smith Chris, Chris Smithson, and 
Smith Christenson

Words that start with Japanese 
Hiragana, Katakana, or Kanji 
characters

The characters between = and * =ᑠ⏣* finds ᑠ⏣, ᑠ⏣ᒣ, and ᑠ⏣ᕝ

A phrase or sequence of characters 
that match when they are the first 
characters in a word (match phrase 
from word start)

The literal text (characters), 
including spaces and 
punctuation, between double 
quotation marks (")

"Marten and Jones Interiors" 
finds Marten and Jones Interiors but 
not Jones and Marten Interiors
", Ltd." finds all companies with 
", Ltd." in the name, but not those 
without the comma
“Spring” finds Springville but not 
ColdSpring Harbor or HotSpring

Words with one or more unknown or 
variable characters (any one 
character)

One wildcard character (@) for 
each unknown character

Gr@y finds Gray and Grey 
@on finds Don and Ron but not Bron

Invalid characters in a text field ? Invalid characters display as blank 
characters
Note   To find the ? character, search 
for "?"

Digits in a text field (any one digit) A # character for each digit # finds 3 but not 30
## finds 30 but not 3 or 300
#3 finds 53 and 43 but not 3
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Words with zero or more unknown or 
variable text characters in a row (zero 
or more characters)

 * for all unknown characters Jo*n finds Jon and John
J*r finds Jr. and Junior
*phan* finds Phan and Stephanie

Operators or other non-alphanumeric 
characters, such as punctuation or 
spaces 

The literal text (characters), 
including spaces and 
punctuation, between double 
quotation marks (")

"@" finds @ (or an email address, for 
example)
"," finds records containing a comma
"   " finds three spaces in a row

A character with special meaning, 
such as the find operators recognized 
by FileMaker Pro: @, *, #, ?, !, =, <, >, 
" (escape next character)

\ followed by the special 
character

\"Joey\" finds "Joey"
joey\@abc.net finds the email 
address joey@abc.net

Words with accented characters The literal text (characters), 
including spaces and 
punctuation, between double 
quotation marks (")

"òpera" finds òpera but not opera
(òpera without quotation marks finds 
both òpera and opera)

Partial phrases, a sequence of words 
or characters (match phrase from 
anywhere)

Characters, punctuation, and 
spaces between double quotation 
marks ("); use * to find this text in 
the middle of a longer text string

*"son & Phillips" finds Johnson 
& Phillips and Paulson & Phillips

Exact matches of the text you specify 
(match entire field)

== (two equal signs) for a field 
content match

==John finds John but not John 
Smith
==John Smith finds John Smith but 
not Smith, John or John Smithers

Exact matches of whole words you 
specify (match whole word)

= =Market finds Market, Market 
Services, and Ongoing Market 
Research but not Marketing or 
Supermarket
=Chris =Smith finds Chris Smith 
or Smith Chris but not Chris or 
Christopher Smithson

Words that contain Japanese 
Hiragana, Katakana, and Kanji 
characters (Japanese-indexed fields 
only)

The characters ி㒔�finds ி㒔 , ᮾி㒔 , and ி㒔ᗓ

Kana characters in a Japanese-
indexed field without differentiating 
between Hiragana/Katakana, 
Voiced/Semi-Voiced/Unvoiced Kana, 
Small/Regular Kana, and Kana 
Voiced/Unvoiced Iteration Marks

~ (tilde) and the character, to do a 
relaxed search

~ ࡣ�finds ࡣ ࡤ�, ࡥ�, ࣁ�, ࣂ , , and ࣃ

Ranges of information See “Finding ranges of 
information” on page 37.

Case-sensitive text Change the default language for 
indexing the field to Unicode.
Note   This procedure will 
change the order in which 
records sort. For more 
information, see Help.

fred finds fred but not Fred

To find Type this in the field Examples
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Finding numbers, dates, times, and timestamps
When you enter criteria in a find request, numbers, dates, times, and timestamps should be 
entered in the corresponding field types (or calculation fields returning the corresponding field 
type) to ensure correct behavior when finding them. See “About choosing a field type” on page 58. 

Important   To avoid confusion when working with dates, always use four-digit years. For more 
information, see the Help topic “Conversion of dates with two-digit years.” 

To find Type this in the field Examples
A number in a number field or in a 
calculation field that produces a 
numeric result

The number .50 finds .5, .50, and $.50

A Boolean number in a number field or 
in a calculation field that produces a 
Boolean result

1 to find True values
0 to find False values

1 finds 1
0 finds 0

A date in a date field or in a calculation 
field that produces a date result

The date as digits, separated by a 
valid date separator character 
(such as a slash or hyphen)

3/3/2014 finds 3/3/2014, March 3, 
2014, and 3-3-2014

Today’s date in a date field or in a 
calculation field that produces a date 
result

// // finds April 4, 2014 (when the 
current date is 4/4/2014)

A time in a time field or in a calculation 
field that produces a time result

The time as digits, separated by 
colons

12:53:09 finds 12:53:09

A timestamp in a timestamp field or in 
a calculation field that produces a 
timestamp result

The date as digits, separated by a 
valid date separator character, 
then the time as digits, separated 
by colons

3/3/2014 12:53:09 PM finds 
3/3/2014 12:53:09 PM

Invalid dates, times, timestamps, or 
calculated date or time results 

? ? finds Next Tuesday or 2/33/2014 in 
a date field, or midnight in a time field

Invalid data (fields containing no 
numbers) in a number field or 
calculation field that produces a 
numeric result

? ? finds twelve but not 12 or twelve30

Dates on a day of the week in a date 
or timestamp field

The day of the week
Note   Full or short day names 
(for example, Friday or Fri) are 
acceptable in day of week 
searches.

Tuesday finds all dates that occur on 
a Tuesday
=Thu finds all dates that occur on a 
Thursday

Any valid value for a date or time 
component in a date, time, or 
timestamp field

* or leave component unspecified, 
while specifying the other 
components you want to find

3/3/* finds the 3rd day of March in 
any year
*:15 finds times that are 15 minutes 
after any hour
1/1/* 7 PM finds timestamps in the 
7 o’clock hour on January 1st in any 
year
Note   When the year is unspecified, 
the current year is assumed. 3/3 finds 
the 3rd day of March in the current 
year

Ranges of information See the next section, “Finding 
ranges of information.”
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Finding ranges of information

To find values that are Use this operator Examples
Less than a specified value < <40 

<9/7/2014 
<M

Less than or equal to a specified value <= 
or ≤ (OS X)

<=95129 
≤05:00:00 
<=M

Greater than a specified value > >95129 
>9/7/2014 
>M

Greater than or equal to a specified value >= 
or ≥ (OS X)

>=100 
>=9/7/2014 
≥8:00 
≥M

Within the range you specify. A range is different based on 
the data type: 
1 Numbers: least to greatest 
1 Dates and times: earliest to latest
1 Text: first to last word, based on the index order of words 

(not the sort order)

.. or ... (two or three 
periods)

12:30...17:30 
1/1/2014..6/6/201
5 
A...M

To find dates Type this in the field
In June 2014 6/2014

From July 2014 through October 2015 7/2014...10/2015

That occur on a Friday =Friday

From the 10th through the 16th of October or November 2014  
(if the date format is MM/DD/YYYY)

{10..11}/{10..16}/2014

That occur on March 1st between 1868 and 1912 in the 
Japanese Emperor Year era of Meiji

m*/3/1

That occur on December 31st between 1930 and 1940 in the 
Japanese Emperor Year era of Showa

S{5..15}+12+31

To find times Type this in the field
In the 3 o’clock hour, not including 4:00 PM 3 PM

Between 8:00 AM and 8:59:59 PM 8 AM..8 PM

In the morning AM

Any of the times 4:30, 5:30, 6:30 PM {4..6}:30 PM

To find timestamps Type this in the field
In the 3 o’clock hour today // 3 PM

In the 7 o’clock hour in May 2014 5/2014 7 PM
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Finding data in related fields
You can enter find criteria in related fields that are displayed in a portal or directly on a layout. 
When you perform a find in a related field, FileMaker Pro displays all the records that have a 
related record matching the criteria you enter. For example, suppose you have an invoice file that 
displays line items as related records in a portal. To find all invoices listing a computer, type 
Computer in the Item field in the portal. For information about related fields, see chapter 4, 
“Working with related tables and files.” 

For information about omitting related records, see “Finding records except those matching 
criteria” on page 40.

Finding empty or non-empty fields

That occur on a Monday in 2015 =Mon 2015

From the 10th through the 16th of November 2015 and from 
3:00 PM to less than 6:00 PM (if the date format is 
MM/DD/YYYY)

11/{10..16}/2015 {3..5} PM

To find fields that are Type this in the field
Not empty (fields that have data) *

Empty =

To find timestamps Type this in the field

E154Invoice ID

AlvarezName

Item ID Item
I100 Computer
I202 Desk
I153 Lamp
I229 Bookcase
I448 Chair

Find request

E153Invoice ID

TangName

Item ID Item
I202 Desk
I443 Long table
I153 Lamp
I288 Round table
I100 Computer

Invoice ID

Name

Item ID Item
Computer

E152Invoice ID

DurandName

Item ID Item
I384 Swivel chair
I554 Panels
I288 Round table
I100 Computer
I448 Chair

Records in table
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Finding duplicate values
You can find all records for which one or more fields contain duplicate values. For example, you 
might want to find all records that aren’t unique, then examine them to decide which records to 
use or delete.
To find all duplicate records, in Find mode, type ! in the field.

Finding records that match multiple criteria
You can narrow or broaden your search by using more than one criterion.

Logical AND search

To narrow your search, enter criteria in as many fields as needed to make your request specific, 
then click Perform Find.

Constraining (narrowing) a found set

You can narrow find results incrementally, looking for more specific detail as you search your 
database.

For example, after searching for all of the employees who work in Sales, you can narrow the 
search to find all of the employees in Sales named Alvarez:

1. Perform a find to find all of the employees who work in Sales.
FileMaker Pro displays the found set in Browse mode.

2. Click Find and type the criteria to narrow the search (type Alvarez in the Last Name field).

3. Choose Requests menu > Constrain Found Set.
The found set now consists of employees in Sales named Alvarez.

Note   To quickly constrain the found set in Browse mode, use the shortcut menu. Click in the field 
(or select a partial value in the field), then right-click, and choose Constrain Found Set.

Logical OR search 

To widen your search, enter criteria in the first request. Click New Request. Enter the second (set 
of) criteria. Continue adding requests for each (set of) criteria, then click Perform Find.
You can navigate among multiple requests using Go to Request on the Requests menu or 
clicking the book in Find mode.

Examples:
1 To include customers in New York and customers in Paris in the found set, type New York in 

the City field in the first request, then type Paris in the City field in the second request. 
1 To include companies with more than 100 employees and companies with more than $100 

million in assets, type >100 in Number of Employees in the first request, then type 
>100,000,000 in Capitalization in the second request.

1 To include 6th grade students who are in Algebra and 7th grade students who are in Geometry, 
type 6 in Level and Algebra in Course in the first request, then type 7 in Level and 
Geometry in Course in the second request. 
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Extending (broadening) a found set

You can broaden a found set to expand your search to include additional applicable records 
without starting over.

For example, after searching for customers in New York, you can broaden the search to also find 
customers in Hong Kong:

1. Perform a find to find customers in New York.
FileMaker Pro displays the found set in Browse mode.

2. Click Find and type the criteria to broaden the search (type Hong Kong in the City field).

3. Choose Requests menu > Extend Found Set.
The found set now consists of customers in New York and Hong Kong.

Note   To quickly extend the found set in Browse mode, use the shortcut menu. Click in the field 
(or select a partial value in the field), then right-click, and choose Extend Found Set.

Records that match one set of criteria but not another

To narrow your search by excluding records that meet specified criteria (for example, to find 
vendors in New York state that are not in New York City), see “Finding some records while omitting 
others,” below.

Finding records except those matching criteria
You can exclude (omit) records while performing a find. In other words, you can find information 
in your database that “does not equal” your specified criteria. For example, you can find all 
invoices except those created in the past 30 days. 

Finding records that don’t match criteria 

1. In Find mode, type criteria for the records to omit. 

2. Click Omit in the layout bar.
 

3. Click Perform Find.

Finding some records while omitting others

For example, to find vendors in the state of New York except those in New York City:

1. In Find mode, type the criteria for the records to find (type New York in the State field).

2. Click New Request.

3. Type criteria for the records to exclude (type New York in the City field).

Click Omit to exclude records 
that match the request
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4. Click Omit.

5. Click Perform Find.

Keep the following points in mind:
1 You can have omit criteria in more than one request.
1 FileMaker Pro works through the requests in the order you create them. For example, in a 

Customers database with customers in the US and France:
1 If the first request finds all customers in Paris and the second request omits all customers in 

the US, the found set contains all customers in Paris, France, but none in Paris, Texas, or 
anywhere else in the US.

1 If the order of the requests is reversed (the first request omits all customers in the US and 
the second request finds all customers in Paris), the found set includes all customers in 
France, and in Paris, Texas, but no records for customers elsewhere in the US.

1 To omit a related record from a portal row (or set of related records), you must change the 
relationship or the value in at least one of the match fields so that the record is no longer related. 
For information about related fields, see chapter 4, “Working with related tables and files.”

1 You can open another window in order to perform different find requests on the same data. See 
“Opening multiple windows per file” on page 19.

1 To omit records from a found set after performing a find, see “Hiding records from a found set 
and viewing hidden records” on page 42. 

Viewing, repeating, or changing the last find
To view the most recent find criteria, choose Records menu > Modify Last Find. Then, to return 
to the found set, switch to Browse mode. To repeat the find, click Find. Or you can modify the find 
criteria, then click Perform Find.

Saving find requests
When you have a complex find request that you want to use regularly, you can save the request 
and retrieve it when you need it later. You can save and retrieve find requests without having to 
go to Find mode. FileMaker Pro automatically saves the last five finds you have performed so you 
can access them again. Once a find is saved, the saved find is also available to any network clients 
that share the account. For more information about saving find requests, see Help.

Deleting and reverting requests
To delete a request, go to the request you want to delete, then click Delete Request.
To restore a request to the way it was when you last committed it, choose Requests menu > 
Revert Request. Requests are committed, for example, when you click out of all fields, go to a 
different layout or request, or perform a find. 
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Hiding records from a found set and viewing hidden records
All records that are not in the found set are omitted, or hidden. You can omit additional records 
from the found set without doing a new find. 

Important   Omitted records are temporarily excluded from the found set. They still exist in the 
database.

Finding and replacing data
As in a word processing application, you can find and replace data across multiple fields (including 
related fields) in a record or in a find request, across a found set of records or find requests, or 
across text objects in a layout. You can search for data in any type of field except container fields 
and fields that are not modifiable.

1. In Browse, Find, or Layout mode, choose Edit menu > Find/Replace > Find/Replace.

2. In the Find what box, type the data you want to search for. In the Replace with box, type the 
replacement data.
You can’t replace data in fields that are formatted as pop-up menus, radio buttons, or checkboxes. 
These fields will be counted and reported as skipped at the end of a Replace all operation.

3. Set the search options you want to use.

To Do this
Omit a specific record Display or select the record to omit, then choose Records menu > Omit.

Omit a series of records Display or select the first record in a number of consecutive records to omit, then 
choose Records menu > Omit Multiple. In the Omit Multiple dialog box, type the 
number of records to omit, then click Omit.

View the omitted set Choose Records menu > Show Omitted Only.

Bring back all the records in 
the file

Choose Records menu (Browse mode) or Requests menu (Find mode) > Show 
All Records.

Select To
An option from the 
Direction list

Choose the search direction: Forward, Backward, or All.

Match case Search for only those occurrences in which the capitalization matches the data 
you specified in the Find what box.
Note   In files that contain Japanese data, a find with the Match case option 
cleared does not simultaneously find both the half-width and full-width version of 
the same character. To comprehensively find and replace both characters, make 
sure you perform separate finds for both the half-width and full-width character.

Match whole words only Search for only those occurrences that are whole words or are bounded by spaces 
and/or punctuation characters.

An option in Search across In Browse mode, search across all records in the current layout or just in the 
current record.
In Find mode, search across all find requests in the current layout or just in the 
current find request.
Note   In Layout mode, FileMaker Pro searches just in the current layout.

An option in Search within In Browse and Find modes, search within all fields in the current layout or just in 
the current field.
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4. Click one of the buttons to perform the type of find/replace operation you want.

Keep the following points in mind:
1 If you have added a tab control or slide control to a layout, when you find and replace data in 

Browse and Find modes, FileMaker Pro only finds and replaces data in fields on the front-most 
panel. In Layout mode, FileMaker Pro finds and replaces text on all panels. 

1 Performing a find and replace that includes fields on a popover opens the popover.

For more information about finding and replacing data, see Help.

Sorting records
FileMaker Pro stores records in the order they were added to the file. Sorting temporarily 
rearranges records, so you can view, update, or print them in a different sequence.
You choose the fields whose contents you want to sort by. The first sort field arranges the records 
based on the field’s contents. The second sort field arranges records when two or more records 
have the same value in the first sort field, and so on. You can sort records in ascending order, 
descending order, or in a custom order.
By default, the records remain sorted until you perform a find or sort records by different criteria. 
When you add or change a record in a sorted found set, the record appears in the correct position 
in the sort order after you commit the record. 

To sort the records in the current found set:

1. In Browse mode, click Sort in the status toolbar.

Note   To sort records in Table View in Browse mode, see “Working with records in Table View” 
on page 30.

2. In the Sort Records dialog box, choose fields for sorting, in the order you want them sorted by, 
and sort options.
To choose a sort field visible on the current layout, no matter what table it is in, choose Current 
Layout (LayoutName) from the table list, then double-click a field in the list.
To choose a sort field that is in the current layout’s table, whether or not it is on the current layout, 
choose Current Table (TableName) from the table list, then double-click a field in the list.
For information about sort options, see Help.

Click To
Find Next Search for and select the next occurrence of the Find what data.

Replace & Find If there is selected data that matches the Find what data: Replace the Find what data 
with the Replace with data, search for and select the next occurrence.
If there is no selected data that matches the Find what data: Search for and select the 
first occurrence of the Find what data.

Replace Replace the Find what data with the Replace with data.

Replace All Replace all occurrences of the Find what data with the Replace with data.
At the end of the Replace All operation, you see a summary of the number of 
occurrences found and replaced.
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3. Click Sort. 
To cancel before sorting is finished, press Esc (Windows) or 2-period (OS X).

Note   You can sort records on one field without opening the Sort dialog box by using the field’s 
shortcut menu.

For information about how FileMaker Pro uses system formats to sort and display dates, times, 
and numbers, see Help.

Previewing and printing databases
With FileMaker Pro, you can print:
1 all the records in the database, a subset of the records, or only the current record
1 a blank record to create a paper form
1 definitions of scripts, fields, tables, and relationships to see the structure of your database
1 data saved as a PDF file

FileMaker Pro prints records using the current layout. You can create layouts to print the same 
data in different ways. For example, you can print records one by one, in a columnar list, or in a 
complex sorted report with totals, headers, and footers. You can also create layouts for mailing 
labels or envelopes.
The New Layout/Report assistant (in Layout mode) makes it easy to create such layouts and 
reports. See “Creating layouts and reports” on page 73. 

You can control page margins, remove blank space, and keep specified objects from printing.

Print Phone List

Go to Layout [Contacts]
Sort [Sort Order: Last name (Ascending) ]

[Restore sort order, No Dialog]
Enter Preview Mode

[Pause]
Print

[no dialog]
Enter Browse Mode

Name Phone
Juanita Alvarez 408-555-1234
Michelle Cannon 213-555-2345
Andre Common 714-555-3456
Marie Durand 619-555-4567
Jean Durand 408-555-5678
William Johnson 408-555-6789

Contacts

Records being browsed

Field Name Field Type
Formula/Entry Options

First Name Text
Last Name Text
Address1 Text

Name Phone
Juanita Alvarez 408-555-1234

Contacts

Current record

Script
Table and field 
definitions

Blank record

You can print data based on the current layout or print information about the 
structure of the database

Relationships graph

Name Phone

Contacts
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Previewing data on a layout 
When you switch to Preview mode, you see the layout as it appears on the printed page. You can’t 
enter or edit information in fields in Preview mode.

In Preview mode, you see:
1 how many records fit on a printed page
1 how the pagination settings you choose affect page breaks
1 subsummary parts with calculated summary fields
1 variable information supplied by FileMaker Pro, like page numbers, the current date, and so on
1 the page margins you define
1 how fields set with sliding options close up blank space 
1 records arranged in columns if the Layout Setup dialog box is defined to print in columns
1 the front-most tab panel or slide panel if the page contains panel controls
1 popover buttons, but not their associated popovers or the contents of popovers

To preview data on a layout, you follow the same preliminary steps that you perform when you 
print, including specifying a printer and printing options and verifying that the found set contains 
the records you want to preview (see steps 1 through 4 in the next section, “Printing records”). 
Then, switch to Preview mode.

Printing records
You can print information from your database, or you can print a blank record in order to print a 
blank “form.” 

To print records:

1. If you have more than one printer, specify which one you want to use.

2. Confirm printing options by choosing File menu > Print Setup (Windows) or File menu > Page 
Setup (OS X), then click OK.
If you’re in Preview mode, you can also click Print Setup (Windows) or Page Setup (OS X) in 
the status toolbar.
For information about printer options, refer to your printer and system documentation.

3. Switch to the layout you want to use. 

4. Make sure the found set is the way you want it by:
1 using Find mode and commands on the Records menu to change the found set 
1 sorting the records 

5. Switch to Preview mode to see exactly how your paper copy will look. 
If a record contains tab controls or slide controls, only the front-most panel is printed.

6. Choose File menu > Print.
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7. In the Print dialog box:
1 Windows: For Print, choose an option for the data you want to print.
1 OS X: Choose FileMaker Pro from the pop-up menu, then choose an option for the data you 

want to print. If you don’t see the options, click Show Details. 

8. Select the print range, number of copies and other printing settings, then click OK (Windows) 
or Print (OS X).

Printing labels and envelopes
You can create layouts for formatting and printing data onto mailing labels and envelopes. The 
process for printing envelopes is similar to that for printing labels.
You use the New Layout/Report assistant to create a Labels layout or a Vertical Labels layout that 
includes data from the fields you choose, arranged to print on many types of label stock (for 
example, Avery 4014). FileMaker Pro provides the dimensions of numerous standard label types 
and their codes. If the label type you want isn't available, you can specify custom label dimensions.

To print Choose
All records (or only records in the found set) Records being browsed

Only the record currently selected in Browse 
mode

Current record

A blank record using the current layout (use 
this option to print a blank “form”)

Blank record, showing fields, then choose a formatting option 

Choose the 
data to print

Click to change the page orientation 
(vertical or horizontal), scaling, and 
other printing options

Print dialog box (Windows)

Choose the data to print

Print dialog box (OS X)

Choose FileMaker Pro from the 
list
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Labels layouts and Envelopes layouts use merge fields, which are placeholder fields for displaying 
and printing only; you can’t enter data into merge fields. Merge fields expand and contract to fit 
the data in the field as needed, and close up space if the field is empty.

Creating a layout for labels, vertical labels, or envelopes

1. In Layout mode, click New Layout/Report.
The New Layout/Report assistant appears. For onscreen help as you use the assistant, press 
F1 (Windows) or 2-? (OS X) in each panel.

2. For Show records from, choose the table that contains the records you want to use. 

3. For Layout Name, type a name for the layout.

4. Choose Printer, then choose either Labels (for data that reads top to bottom horizontally) or 
Vertical Labels (for data that reads right to left vertically). 
For an Envelopes layout, choose Envelopes and click Continue. Then skip to “Choosing and 
formatting the merge fields.”

5. Click Continue.

6. In the Specify Label Layout panel, specify the measurements of your mailing labels:
1 To choose a predefined measurement based on common label types, for the Use label 

measurements for list, choose the code that matches your labels. (You see this information 
on the package your labels came in.) FileMaker Pro creates a Labels layout that uses the 
exact dimensions of the label stock code you choose.

1 To specify a custom measurement, choose Use custom measurements, and enter values 
for Labels across the page, Width, and Height. Measure the unused margins on the label 
stock. Then select Fixed page margins and enter values for Top, Bottom, Left, and Right.

7. Click Next.

Choosing and formatting the merge fields

1. In the next panel, for the Available fields list, double-click the first field whose data you want 
on the labels or envelope.
<<field name>> appears in the Label contents or the Envelope contents area. Angle 
brackets indicate that this is a merge field, and field data will display in and print on the labels 
or envelope.
To include fields from related tables, choose the table from Available fields.

2. Continue selecting the fields you want on the labels or envelope.

3. Include all punctuation, blank spaces, and line breaks (to place a merge field on the next line) 
that you want printed. 

4. Click Finish.
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Printing labels

1. To print the labels, load the labels into your printer according to the instructions that came with 
your labels and your printer. To print the envelope, load the envelope into your printer according 
to the instructions that came with your printer.

2. Choose File menu > Print, choose the printer and any additional options, and click Print.

Keep the following points in mind:
1 To choose options for how you want labels printed on the page, choose Layouts menu > 

Layout Setup, and click the Printing tab. Then choose the number of columns (labels) across 
and the direction in which you want the labels printed, and set custom page margins, if needed.

1 You may need to adjust your printer settings to print the labels correctly. Choose File menu > 
Print Setup (Windows) or Page Setup (OS X).

For more information about creating a layout for labels or envelopes, choosing printing and layout 
setup options, and additional considerations when you create a Labels or Envelope layout, see 
Help.

Printing scripts
You can print a list of all script steps for one or more scripts in a file.

1. Choose Scripts menu > Manage Scripts, or choose File menu > Manage > Scripts.

2. In the Manage Scripts dialog box, select the script or scripts you want to print.
To select more than one contiguous script in the list, Shift-click the scripts. To select more than 
one noncontiguous script, Ctrl-click (Windows) or 2-click (OS X) the scripts.

3. Click  at the bottom of the dialog box.

4. Click OK (Windows) or Print (OS X).
The selected script steps and options are printed.

Printing table and field information
You can print table or field information.

1. Choose File menu > Manage > Database, then click the Tables or Fields tab.

2. Select the table(s) or field(s) you want to print.
To select more than one contiguous table or field in the list, Shift-click the tables or fields. To 
select more than one noncontiguous table or field, Ctrl-click (Windows) or 2-click (OS X) the 
tables or fields.

3. Click Print.

4. Click OK (Windows) or Print (OS X).
The field names, field types, and formulas or data entry options are printed for each selected table.
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Printing the relationships graph
You can print a graphical representation of your database by printing the relationships graph.

1. Choose File menu > Manage > Database, then click the Relationships tab.

2. Click  to display page breaks in the relationships graph. 

3. Click   to display the Print Setup (Windows) or Page Setup (OS X) dialog box.

4. Change or accept the settings, then click OK.

5. Click Print.

6. In the Printing Options dialog box, choose an option.
1 Choose Print graph on multiple pages to print the graph on more than one page. 
1 Choose Print graph on one page to resize the graph to fit on one page.

7. Click Continue.

8. Click OK (Windows) or Print (OS X).

For more information about previewing and printing databases, see Help.

Automating tasks with scripts
Scripts can do simple tasks like setting print orientation or complex tasks like preparing a 
customized mailing to customers. Scripts can incorporate conditional decisions (if-else 
statements) and perform repetitive tasks (loop statements).
You can build scripts in the Edit Script dialog box by selecting from a list of FileMaker Pro script 
steps, specifying options, and arranging the steps in the correct order to perform the task.

Use scripts to combine and automate tasks like:
1 switching to another layout or mode
1 finding, sorting, and printing records
1 importing data from the same source

FileMaker Pro makes it easy for you to manage scripts. You can display a default script to use as a 
template when writing your own scripts. You can open several scripts at once to compare them. You 
can copy and paste entire scripts between files. You can copy and paste script steps from one script 
to another script in the same file or to a script in a different file. You can assign scripts to groups to 
make it easy to find scripts of a specific type (for example, copy an entire group of scripts to another 
file or delete an entire group of scripts). And you can design scripts to run when a particular event 
occurs (such as when users enter a field, press a key, or add a new record to the database).
Procedures for creating and managing scripts and a reference to all FileMaker Pro script steps 
(organized alphabetically or by category) are available in Help. 
In addition, you can set up script triggers to specify that scripts run when particular events occur. 
For more information, see Help.



Chapter 2  |  Using databases 50

Backing up database files
Routine backups are strongly recommended for any document stored on a computer. It is easier 
to restore a backed up database than it is to re-create it. How often you should back up depends 
on the amount of data you are adding to your databases, and how difficult it would be to re-create 
your files if they become corrupt. 
For very important files, it’s a good idea to routinely store backups at an offsite location. 
For file backup recommendations, see “Backing up databases and other important files” on 
page 151. For an example of a backup script, see Help.

Setting preferences
You can customize the appearance and behavior of FileMaker Pro to suit the way you work by 
changing standard settings called preferences. Preferences affect the behavior of the application 
and are not specific to any file.
Settings in the File Options dialog box affect the current file’s default layout, opening and closing 
scripts, login information, and spelling.

To set application preferences:

1. Windows: Choose Edit menu > Preferences.
OS X: Choose FileMaker Pro menu > Preferences.

2. In the Preferences dialog box, click a tab, then set the options you want to use.

To set file preferences:

1. Choose File menu > File Options.

2. In the File Options dialog box, click a tab, then set the options you want to use.

For more information about setting application and file preferences, see Help.
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This chapter explains the basics of how to:
1 plan a database
1 define and modify fields
1 define tables
1 create layouts
1 work with fields, objects, and parts on a layout

Note   See Help for detailed, comprehensive information and step-by-step procedures about 
using FileMaker Pro.

Planning a database 
A well-designed database promotes consistent data entry and retrieval, and reduces the existence 
of duplicate data among the database tables. Relational database tables work together to ensure 
that the correct data is available when you need it. It’s a good idea to plan a database on paper first. 

Follow these general steps to plan a database:

1. Determine the purpose for your database, or the problem you want to solve. For example, “to 
keep a list of my customers,” “to manage my inventory,” or “to grade my students.”
If other people will use the database, be sure to talk with them about the data they will need.

2. Consider the information you will store in your database. Typically, information falls into broad 
categories. Accurately identifying these categories is critical to designing an efficient database, 
because you will store different types and amounts of data in each category. For example, a 
database intended to track sales has categories such as “customers,” “products,” and 
“invoices.” A database that records student grades has categories such as “students,” 
“classes,” and “assignments.”

3. After you’ve determined the broad categories, consider how these categories are related. This 
can be done by writing simple sentences that describe how the categories interact, such as, 
“customers order products” and “invoices record customers’ orders.” Each of these pairs 
suggests a relationship between the data in one category and the data in the other category.



Chapter 3  |  Creating databases 52

4. After you’ve identified your categories of information, you are ready to organize your database.
In database terminology, these categories of information are referred to as tables. Tables are 
used to group data containing a common element or purpose. For example, you might use one 
table to store names and addresses, while you use another table to store transaction details, 
such as date of sale, item number, unit price, and so on.
Typically, databases are organized in one of three ways:
1 A single table in a single file. Use a single table if you need to track data in one category only, 

such as names and addresses.
1 Multiple tables in a single file. Use multiple tables if your data is more complex, such as 

students, classes, and grades.
1 Multiple tables in multiple files. Use multiple files if you need to share the same data among 

several different database solutions. For example, you can store your tax rates or shipping 
information in a separate file if you plan to use that information in more than one solution.

Note   Use relationships to share data between tables in the same file or with tables in external 
files. Other database elements, such as scripts and access privileges, are stored at the file 
level; therefore, some complex solutions will benefit from using multiple files.

5. Determine the database tables and the data they will include, and, in turn, which fields you will need.

Tip   To make it easy to search and sort records, create separate fields for first and last name, 
titles, (like Mr. or Dr.), and items in addresses (city, state or province, country, and postal code). 
Separating your data into multiple fields at the time of data entry can make it easier to generate 
future reports. For example, using separate fields to capture transaction details such as the 
date, item number, quantity, and unit price of each transaction makes it easier to compile 
summary and subsummary reports at the end of a week, month, or year.

6. Decide which fields will contain common data among the tables.
For example, a database for a bakery business might include these tables: a Customers table, 
which stores customer information; a Products table, which stores product information; and an 
Invoices table, which stores order information.
Each table has only one subject, and all fields in a table describe only that subject. For example, 
the fields in one record of the Customers table together store all the information about one 
customer. For the same reason, you might assign each customer a unique, identifying number. 
You wouldn’t enter a customer identification number into the table unless you had a new 
customer to add, so the existence of a customer number determines the existence of a record. 
A Customers table might also have fields for the customer’s name, address and phone number. 
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A Products table might have fields for a product identification number, the unit price for each 
product, and the quantity in stock. A Line Items table might have fields for product and invoice 
identification numbers, the name, unit price, quantity, and total price of each product sold. An 
Invoices table might have fields for an invoice identification number, order date, and salesperson.

7. Determine the match fields for each table, and circle each one in your plan.
For more information, see “About match fields for relationships” on page 112.
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8. For each table, decide which fields will store data, and which ones will be used from other 
(related) tables. 
Based on a table’s subject, you can see where it makes sense to store the data and where to 
use data from a related table. Other than match fields, all fields should appear only once in your 
database. Cross out occurrences of fields that don’t pertain to the table’s subject. 

9. Determine the relationships between the tables. In your plan, draw a line from each match field 
in a table to the corresponding match field in the related table.
What establishes a relationship between tables is that their match fields contain matching data. 

Relationships also make it possible to group your data to resolve complex queries. For 
example, relationships can be used to determine current inventory levels, sales projections, 
and other tasks where it is necessary to query data across multiple tables. For more information 
about relationships, see chapter 4, “Working with related tables and files.”

10. Determine whether you need to share your database with other users, and how they will 
access the file.
For more information about sharing databases, see “Sharing databases on a network” on 
page 124.

11. If you’re designing the database for other people to use, show them your paper plan and ask 
them to review it and suggest any changes.
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12. Consider who will use the database and whether you want to restrict access to it. When you 
create the database, assign access privileges as needed.
For more information about accounts and privilege sets, see chapter 6, “Protecting databases.”

13. Decide what layouts you need, and plan a separate layout for each  task.
For example, create separate layouts for printing labels or envelopes.
For more information about creating layouts, see “Creating layouts and reports” on page 73.

14. Create a form such as the one shown below to list the files and tables you need and the fields 
for each table. Also list the forms and reports you will generate from each table.

15. Create your database. 

16. If you’ve designed the database for others to use, ask a few people to test it. Then, fix any 
problems they found before you make the database available for everyone to use.

Creating a FileMaker Pro file
You can create a file from a FileMaker Pro Starter Solution (template)—a predefined database file 
that you can modify to suit your needs. Or, you can create a file without using a template.
You can also create a file by making a copy of an existing FileMaker Pro file. See “Saving files” on 
page 20.

Creating a file using a Starter Solution
1. Choose File menu > New From Starter Solution.

You can also use the FileMaker Quick Start Screen to create files. Choose Help menu > Quick 
Start Screen, then click Use a Starter Solution.

2. Select All Solutions to view a list of all available solution files, or choose a solution category to 
narrow the list of choices.
If the FileMaker Quick Start Screen appears but there are no FileMaker Pro Starter Solutions 
displayed in it, the Starter Solutions weren’t installed. For more information, see Help.

Sample Database Design Form

Project Name

Purpose of this database

Filename for this database

Table name
Field name Field type Comments

Layouts

Table name
Field name Field type Comments

Name Purpose                                  Screen    Print      Web
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3. Select a solution from the list (Windows) or the group of thumbnails (OS X), then click Choose.

4. Type a name for the file (choose a different folder, if needed), then click Save.
Windows: For Save as type, select FileMaker Files. 
FileMaker Pro creates the file on your disk and opens the file. You can modify fields and layouts 
in Starter Solutions. For more information, see the remaining sections in this chapter.

Creating a new file
1. Choose File menu > New Database.

You can use the FileMaker Quick Start Screen to create new files. Choose Help menu > Quick 
Start Screen, click Create a New Database, and continue with step 2.

2. Type a name for the file (choose a different folder, if needed), then click Save.
Windows: For Save as type, select FileMaker Files. If you don't type a file extension, 
FileMaker Pro adds .fmp12 to the filename. (For information about viewing file extensions in 
Windows, see Windows Help and Support.)
FileMaker Pro creates the file, displays a blank, empty file in Layout mode, and displays the 
Field Picker dialog box, which you use to define fields for the database and add them to the 
layout. 
To have fields automatically placed on the layout, select Add newly defined fields to current 
layout in the Layout tab of the Preferences dialog box before you define the fields.

3. Define the fields, drag them to the layout, then close the Field Picker dialog box.
For details about defining fields using the Field Picker dialog box, see “Creating and changing 
fields in the Field Picker dialog box” on page 59.
You can set field options such as validation or indexing when you define a field, or at a later 
time. For more information, see “Setting options for fields” on page 67.

4. Add objects and other embellishments to the layout. 
For more information, see “Working with objects on a layout” on page 81.

5. Save the layout by pressing Ctrl+S (Windows) or 2-S (OS X), then exit the layout (click 
 in the layout bar).

Keep the following points in mind:
1 For information about entering data in fields in Browse mode, see “Adding and duplicating 

records” on page 25.
1 By default, choosing File menu > New Database displays an empty database in Layout mode 

and the Field Picker dialog box. To display the Manage Database dialog box whenever you 
create a new database, choose Edit menu > Preferences (Windows) or FileMaker Pro 
menu > Preferences (OS X). In the Preferences dialog box, click the General tab, then select 
Use Manage Database dialog to create files. 

1 To change the layout theme, see “Working with layout themes” on page 78.
1 You can change the width of a layout to accommodate more (or fewer) objects. Making a layout 

wider helps you see the edge of the layout without resizing the window. To change the width of 
a layout, drag the gray line on the right side of the layout.
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Creating and changing fields
To define a new field in the database, you give it a name and select a field type. Then you select 
options that determine how the field interprets, enters, calculates, stores, and displays data. These 
characteristics make up the field definition.

See “Formatting field data on a layout” on page 93 for information about setting options for field 
formats, which control how data appears on a layout.

About naming fields
Follow these guidelines when naming fields:
1 Field names must be unique. They can contain up to 100 characters. 
1 Use descriptive names that clearly identify the contents of the field. Avoid abbreviations, 

acronyms, or other terms that may cause confusion.
1 Don’t use any of the following symbols or words in the field name:

1 , (comma) + – * / ^ & = ≠ > < ≥ ≤ ( ) [ ] } " ; (semicolon) : (colon) :: (relational indicator) 
$ (variable indicator)

1 AND, OR, XOR, NOT, or the name of any FileMaker Pro function 
1 Don’t begin a field name to be used in a calculation formula with a space, period (.), or number.
1 Use _ (underscore) in place of a space to avoid restrictions in ODBC (Open Database 

Connectivity) or JDBC (Java Database Connectivity), exporting, web publishing, and other 
operations.

1 If you’re exchanging data with another application, check the field naming restrictions in the file 
formats supported by the other application. 

1 If you’re using ODBC or JDBC to share FileMaker Pro data, avoid using SQL keywords in field 
names. 

This field stores only numbers
This field calculates a value based on 
another value in the record 
(“Discount” is 20% of “Unit Price”)

This field stores multiple values

FB11Product ID

FocacciaProduct Name

BreadsCategory

PlainFlavor

$6.95Unit Price

$1.39Discount

Herb

These fields store text
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About choosing a field type
When you define a field, you select a field type based on the kind of information the field will 
contain. The field type determines what kind of data can be entered and what kinds of operations 
FileMaker Pro can perform with the data. FileMaker Pro uses the field type to interpret the data for 
tasks like sorting records and performing calculations.

Select this  
field type

 
If the field data will be

Text Letters, symbols, and/or numbers used as text per field repetition, limited by available RAM and 
disk space. Indexes nominally based on the first 100 characters of each word or value. Text 
fields may contain carriage returns.

Number Values up to 800 digits or other characters, and the negative values of the same range. Number 
fields can also contain Boolean values (0 or 1), to indicate, for example, true, false, yes, and no. 
Number fields can’t contain carriage returns.

Date Dates only. Uses the Gregorian calendar with a range of 1/1/0001...12/31/4000. Month, day, 
and year order is based on system settings when the file is created.

Time Times only. A time field can contain the hours, minutes, and seconds portion of a time. A time 
field can contain a negative time duration, for example, -08:40:00.

Timestamp Dates and times to reference a fixed point in calendar time. For example, 10/25/2014 2:39:46 AM

Container A file of any type, such as a picture, a PDF, or a multimedia file. You can set up storage and 
display options for the field. You can reference container fields in calculations and summary 
fields. You can't find or sort records based on container fields, but you can define text fields to 
describe or identify them. Then, you can find or sort records based on the description or 
identifying number in the text field. Files in container fields can be embedded, stored as a 
reference, or stored externally. 

Calculation The result of a calculation formula that uses field values from the current record or related 
records. The formula can use values of all field types. The result can be one of these types of 
data: text, number, date, time, timestamp, or container.

Summary A value that’s produced by summarizing field values from more than one record in the same table. 
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Keep the following points in mind:
1 Any field type except summary can store a global value. For more information, see “About 

indexing and storage options” on page 71.
1 Be sure to use a date field (instead of a text or number field) to store dates. To avoid confusion 

when using dates, always use four-digit years. 
1 Use text fields instead of number fields to store postal codes, phone numbers, and other values 

with leading zeroes or characters like hyphens or parentheses.
1 Although you can’t find or sort records based on a container field, you can define a text field to 

describe or identify the contents of the container. Then, you can find or sort records based on 
the data in that text field.

To change the way data is displayed in text, number, date, time, and timestamp fields, see 
“Formatting field data on a layout” on page 93.

Creating and changing fields in the Field Picker dialog box
When you create a new database, FileMaker Pro opens the file in Layout mode, and displays a 
blank layout and the Field Picker dialog box. Use the Field Picker dialog box to define fields for 
the database, and to add or change fields for an existing layout. 

Note   Fields are not automatically added to the layout when you define them in the Field Picker 
dialog box. To have fields placed on a layout when you define them, select Add newly defined 
fields to current layout in the Layout tab of the Preferences dialog box before you define the 
fields. 

1. If the Field Picker dialog box is not open, in Layout mode, click  in the layout bar.

Summary fields produce results 
from values in multiple records

Salesperson Item Qty Extended Price

David Michaels FB3 1 $3.95
David Michaels FB4 1 $17.50
David Michaels FB1 2 $19.90
David Michaels FB5 3 $52.50

Total $93.85

Sophie Tang FB6 2 $39.00
Sophie Tang FB7 5 $77.50
Sophie Tang FB2 2 $45.00

Total $161.50

Grand Total $255.35

Sales Report

Calculation fields produce results from values in 
the current record or related records

Favorite Bakery Confidential June 2014
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2. In the Field Picker dialog box, add, delete, or change fields.

3. Repeat step 2 to continue defining fields.

To Do this
Add a field Click New Field. A placeholder Field is created in the fields list, with a field 

type assigned. With the field selected, type a new name for the field. See 
“About naming fields” on page 57.

Change the field type Click the field type and choose a new field type from the list. See “About 
choosing a field type” on page 58.
Important   Changing the field type can permanently and irretrievably 
erase data.

Set options for the field Right-click the field and choose Field Options. See “Setting options for 
fields” on page 67.

Delete a field Right-click the field and choose Delete Field. 
To delete multiple fields at a time, select the fields, then right-click and 
choose Delete Field. 
Important   Before you delete a field, confirm that you don’t need any of 
the data it contains.

Change a field’s name Windows: Double-click the field, then type a new field name.
OS X: Select the field, then click the field name and type a new field name. 

Sort fields in the list Click , then choose how you want to sort the fields.

Locate a field in a long list Type the field name in the search box near the top of the Field Picker 
dialog box.

Display the Manage 
Database dialog box

Click to add a field to 
the database

Fields appear here 
as you add them

Specify settings for position 
and labels of fields dragged 
to the layout

Search for fields Sort fields
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4. When you drag fields to the layout, by default the fields are placed vertically on the layout, with 
field labels to the left of the fields. To change these settings, click Drag Options before you 
drag the fields to the layout. 
1 To change the position (horizontal or vertical) in which fields are placed on the layout, for 

Field Placement, click a choice. 
1 To specify the position of field labels, for Labels, click a choice.
Subsequent fields that are added to the Field Picker dialog box use the current drag settings.

Note   Changes to the drag settings have no effect on fields that are already on the layout.

5. Select the fields you want to place on the layout, then drag them to the layout.

6. Close the Field Picker dialog box by clicking the close button or pressing Esc.

Creating and changing fields in the Manage Database dialog box
1. With the database open, choose File menu > Manage > Database.

2. In the Manage Database dialog box, click the Fields tab.

3. If your file contains more than one table, select the appropriate table from the Table list.
You see tables from the current file and any related external files.

4. For Field Name, type a name for the field. 
Or, to change a field’s name, select the field in the list, then type a new name in the Field Name box.
See “About naming fields” on page 57.

Field names 
and definitions 

Type a name for 
a new field Select a 

field type

Click after you type 
a field name and 

select a field type

Choose the way 
fields are listed in 
the dialog boxClick to sort by field 

name or type
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5. For Type, select a field type.

Important   Changing the field type can permanently and irretrievably erase data.

See “About choosing a field type” on page 58.
You can enter a description of the field in the Comment box.
For more information about creating calculation fields, see “Creating calculation fields” on 
page 63. For more information about creating summary fields, see “Creating summary fields” 
on page 65. For more information about creating container fields, see Help.

6. Click Create if you’re creating a new field. If you’re changing the field, click Change.

7. To delete a field, select one or more fields that you want to delete, click Delete, then click Delete 
again.

Important   Before you delete a field, confirm that you don’t need any of the data it contains.

8. To define options for the field, click Options, and specify the options you want in the Options 
for Field dialog box.
For more information, see “Setting options for fields” on page 67. 

9. Continue to define or change fields, or click OK to close the Manage Database dialog box.

To Do this in the Options for Field dialog box
Automatically enter values into 
the field

Click the Auto-Enter tab, select the options, then click OK. For more 
information, see “Defining automatic data entry” on page 68.

Make sure data is entered into 
the field correctly

Click the Validation tab, select the options, then click OK. See “Defining field 
validation” on page 69.
Important   To avoid confusion when using dates in FileMaker Pro, set field 
validation options to make sure dates are always entered with four-digit years.

Make the field repeating Click the Storage tab, then select Maximum number of repetitions. Type 
the number of repetitions, then click OK. For more information, see Help.

Select options for indexing the 
field

Click the Storage tab, select the options, then click OK.

Make the field use one value for 
all records in the file

Click the Storage tab, select Use global storage, then click OK.

Create a link between the 
“parent” data field and the 
Furigana “child” field, so that 
when you input Kanji characters 
into the “parent” field, the 
corresponding Kana reading 
appears in the Furigana “child” 
field

Click the Furigana tab, select Use Furigana Field, the Furigana field, and 
the Kana reading input format, then click OK.
Note   This option is available for text fields only, and if your operating system 
is configured to support Japanese text.
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Creating and changing fields in Table View
1. With the database open, in Browse mode, click Table View  in the layout bar.

2. Create new fields or change existing fields.

For information on working with records in Table View (for example, adding, deleting, and sorting 
records), see “Working with records in Table View” on page 30. For information about displaying 
data in Table View (for example, reordering columns and setting column widths), see “Displaying 
data in Table View” on page 29.

Creating calculation fields
1. To create a calculation field, follow steps 1–5 in “Creating and changing fields in the Manage 

Database dialog box” on page 61.

2. Choose Calculation as the field’s type, then click Create.

3. In the Specify Calculation dialog box, if necessary, for Evaluate this calculation from the 
context of, choose a table from the list.
Setting the context for a calculation is only necessary when you’re creating a calculation field in 
a source table that has two or more occurrences in the relationships graph. The source table is 
the table defined in the Tables tab of the Manage Database dialog box. The choice you make 
may affect the calculation results, particularly if your calculation will include fields in related tables.

To Do this in Table View
Create a field To create the first field, click Create Field in the first column heading. To create 

additional fields, click + in the column heading, or click in the right margin.

Change a field name Double-click the column heading for the field you want to rename, then type 
the new name. For more information, see “About naming fields” on page 57.

Choose a field type Right-click the column heading, choose Field > Field Type, and choose a 
field type. For more information about field types, see “About choosing a field 
type” on page 58.
Important   Changing the field type can permanently and irretrievably erase 
data.

Set field options Right-click the column heading, then choose Field > Field Options. For more 
information, see “Setting options for fields” on page 67.

Delete a field Right-click the column heading, then choose Field > Delete Field.
Important   Before you delete a field, confirm that you don’t need any of the 
data it contains.

Display more fields or hide fields Click Modify in the layout bar and use the options in the Modify Table View 
dialog box. Or, right-click a column heading, then choose Field > Hide Field 
to hide the selected field. 
To display a hidden field in Table View, right-click the + column heading, then 
choose a field from the list of existing fields.
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4. Build a formula for your calculation.
Click where you want the item to appear in the formula box, then do the following. You can also 
type the formula into the box.

Procedures for working with formulas and a reference to all FileMaker Pro functions (organized 
alphabetically or by category) are available in Help.

5. Select calculation options for the field.

To add a  Do this
Reference to a field In the field list, double-click a field name.

To display field names from another table, choose a table from the table list.

Mathematical or text operator In the keypad in the dialog box, click an operator. (Quotation marks and 
parentheses are copied to the formula as a pair, with the insertion point 
blinking in the middle).

Comparison or logical operator, 
or an exponent

 For Operators, choose an operator from the list.

Constant value Type the value. A constant can be text, number, date, or time. Use date 
constants with the functions Date and GetAsDate, time constants with the 
functions Time and GetAsTime, and timestamp constants with the functions 
Timestamp and GetAsTimestamp.
Text constants can be up to 29998 characters long.

Function In the functions list, double-click a function (a predefined, named formula that 
performs a specific calculation and returns a single, specific value). In the 
formula box, replace the placeholder parameter with a value or expression.

Choose field references 

Formula box

Select comparison and logical operators

Select 
functions

Choose a formula 
result type

Choose indexing and 
storage options 

Make the calculated field repeating

Choose a table from the list

Calculate only if at least one 
field in the formula has a value

Select mathematical and 
text operators

Choose the way 
functions are listed 
in the dialog box

Choose the table from which the 
calculation will be evaluated

Click to display online Help on 
defining calculations
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6. To select indexing and global storage options for the field, click Storage Options, select 
options in the Storage Options dialog box, then click OK.

7. Click OK to close the Specify Calculation dialog box.

8. Continue to define fields, or click OK.

Note   If your FileMaker Pro file accesses data from external ODBC data sources, you can add 
supplemental fields to specify calculations using external data. For more information, see “Using 
supplemental fields” on page 67.

For more information about creating or changing calculation fields or the use of context in 
calculations, see Help.

Creating summary fields
Use summary fields to calculate values such as subtotals, averages, and grand totals across 
multiple records. For example, a summary field can display in a report the grand total of all sales 
in the month of May. 
Use the New Layout/Report assistant to create a report with grouped data (data in a summary 
field). See “Creating layouts and reports” on page 73. 

Tip   You can use Table View in Browse mode to quickly create a dynamic report that groups your 
data by a field, displays subtotals for a field, or creates subtotals for each group of data. For more 
information, see Help.

The value in a summary field can change depending on where you place the field on a layout, how 
many records are in the found set, whether the records are sorted, and which mode you’re using.
If you’re modifying a layout that contains a summary field, you must know about layout parts to get 
the results you want (see “Working with layout parts” on page 99).

1. To create a summary field, follow steps 1–5 in “Creating and changing fields in the Manage 
Database dialog box” on page 61. 

2. Choose Summary as the field’s type, then click Create.

To Do this
Set the field type of the result Choose a data type for Calculation result is <value>. Choose the correct 

type for the result you want. See “About choosing a field type” on page 58. 

Make a calculated field 
repeating

Select Number of repetitions, then type the number of repetitions (up to 
32,000).

Prevent calculation if all 
referenced fields are empty

Select Do not evaluate if all referenced fields are empty.
When enabled, FileMaker Pro does not evaluate a calculation if all fields used 
by the calculation are empty.
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3. In the Options for Summary Field dialog box, select a summary type, then select the name of 
the field you want to group by.

 

4. Select an option, if applicable, for the summary type.
Options change according to the summary type you select in the previous step.

Select this type of 
summary To summarize values in a field in the found set of records by
Total of Calculating the total of values in the field.

Average of Calculating the average of values in the field.

Count of Counting the number of records that contain a value for the field. For example, if a 
field contains 100 values (one value for each record), the result of the count is 100.

Minimum Finding the lowest number, or the earliest date, time, or timestamp for a field.

Maximum Finding the highest number, or the latest date, time, or timestamp for a field.

Standard Deviation of Finding how widely the values in a field differ from each other. This option 
calculates the standard deviation from the mean of the values in a field. (The 
formula is n-1 weighted, following the normal standard deviation.)

Fraction of Total of Calculating the ratio of the value in the field to the total of all the values in that field. 
For example, find what fraction of total sales can be attributed to each salesperson.

List of Creating a return-delimited list of non-blank values in a field.

For this summary type Select To
Total of Running total Show the cumulative total for the current and 

all previous records. To restart the running 
total for each sorted group, also select 
Restart summary for each sorted group. 
Then, from the fields list, select the field that 
the sort will be restarted from.

Average of Weighted average. In the list of 
fields that appears, select the field 
that contains the weight factor

Determine the average in one field based on a 
value in another field that’s used as a weight 
factor.

Count of Running count Show the cumulative count of the current and 
all previous records. To restart the running 
count for each sorted group, also select 
Restart summary for each sorted group. 
Then, from the fields list, select the field that 
the sort will be restarted from.

Choose a 
summary type Choose the field 

you want to 
group by

Select an option 
for the summary 

type

Select an option for summarizing repetitionsRestart the 
total or count
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5. Select an option, if applicable, for summarizing a repeating field.

6. Click OK.

7. Continue to define fields, or click OK.

Keep the following points in mind:
1 When you create a report in the New Layout/Report assistant, fields that are in summary parts 

display the part-specific style, not the default theme style.
1 If you have used the Field tool to add a field to a summary part and the text is difficult to see, 

use the Inspector or the Format Painter to copy the style you want from another field. 
1 If your FileMaker Pro file accesses data from external ODBC data sources, you can add 

supplemental fields to specify summary fields for external data. For more information, see the 
next section.

Using supplemental fields
If your FileMaker Pro file accesses data from external ODBC data sources, you can use 
supplemental fields to display unstored calculation and summary results using ODBC data. 
Because you can’t use FileMaker Pro to change the schema of an external ODBC database, 
supplemental fields are the only fields you can add to external tables.
For information about how to access and work with SQL data interactively, see “Working with external 
data sources” on page 136. For more information about using supplemental fields, see Help.

Setting options for fields
You can set field options when you define a field, or at a later time. You can set options for:
1 entering default data into a field
1 checking data against validation requirements
1 making a repeating field
1 creating an index
1 storing container data externally
1 storing a global value
1 Furigana fields (Japanese language fields only)

Standard Deviation of by population Calculate population standard deviation, 
where the formula is n-weighted.

Fraction of Total of Subtotaled. In the list of fields that 
appears, select a field to group by. 
(When you return to Browse mode, 
sort by this field to calculate the value 
correctly.)

Calculate a fraction of the total based only on 
a group of records.

Select To
All together Calculate a single summary value for all repetitions in the field.

Individually Calculate a summary value for each repetition.

For this summary type Select To
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Some field options help ensure the accuracy and consistency of your data. For example, if you 
type Frnc instead of France into the Country field, you won’t find that record when you later search 
for all customers from France. To be sure that all country names are entered correctly, you can 
define a value list containing the names, then select the Member of value list validation option 
for the Country field. When you enter data into the field, the data must match a value in the list.
You can set field options while you’re working in Table View, Form View, or List View.
For more information on value lists, see “Setting up checkbox sets and other controls on a layout” 
on page 91. To set options for summary fields, see “Creating summary fields” on page 65. To set 
storage options for container fields, see Help.

Defining automatic data entry
To automatically enter a default value into a field for each record:

1. With the database open, do one of these:
1 If you’re working in Table View, right-click the field name, then choose Field > Field 

Options. Then skip to step 5.
1 Choose File menu > Manage > Database.

2. In the Manage Database dialog box, click the Fields tab.

3. If your file contains more than one table, select the appropriate table from the Table list.

4. In the fields list, double-click a field that you want to define.

5. In the Options for Field dialog box, click the Auto-Enter tab and select options. (The available 
options depend on the field type.)

To Do this
Enter a date, time, timestamp, user name, or 
account name when the record is created or 
modified

Select Creation or Modification, then choose an option from 
the list.

Assign a sequential number to the field in 
each record

Select Serial number. Select On creation to assign the number 
when a record is created. Select On commit to assign the 
number when the record is committed. For next value, type a 
starting value (for example, 1001), then type the number to 
increment by.

Enter the value from the previously accessed 
record

Select Value from last visited record.

Enter data you specify Select Data, then type up to 255 characters. 

Enter the result of a calculation in the field Select Calculated value, define the formula in the Specify 
Calculation dialog box, then click OK. For more information 
about the Specify Calculation dialog box, see “Creating 
calculation fields” on page 63.
Select Do not replace existing value of field (if any) to 
prevent overwriting data already present.

Enter a value that’s copied from a field in the 
same or a different table or file

Select Looked-up value, define the lookup, then click OK. See 
“Creating lookups” on page 121.

Prevent users from changing an automatically 
entered value

Select Prohibit modification of value during data entry. 

Turn off automatically entered data Clear all selected checkboxes.
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6. Click OK to close the Options for Field dialog box, or click another tab to set additional field 
options.

Defining field validation
You can select field validation options to ensure that data is entered into the field correctly. 
FileMaker Pro displays a message if you enter data incorrectly.

Important   To avoid confusion when using dates in FileMaker Pro, set date field validation 
options to make sure dates are always entered with four-digit years.

1. With the database open, do one of these:
1 If you’re working in Table View, right-click the field name, then choose Field Options. Then 

skip to step 5.
1 Choose File menu > Manage > Database.

2. In the Manage Database dialog box, click the Fields tab.

3. If your file contains more than one table, select the appropriate table from the Table list.

4. In the fields list, double-click a field you want to define.

5. In the Options for Field dialog box, click the Validation tab.

6. Specify how FileMaker Pro handles an invalid entry.
For Validation options for this field, select Always for ongoing field validation, or Only 
during data entry to limit validation to instances when data is being entered. Deselect Allow 
user to override during data entry if you want to prevent users from entering invalid data.

7. Select validation options for the field.

To require that the entered value Select 
Contains only numbers Strict data type, then choose Numeric Only from the 

list

Is a date containing numeric values for the month and 
day, and four digits for the year (for example, 5/12/2014)

Strict data type, then choose 4-Digit Year Date from 
the list

Select options for 
entering default 
data in the field

Click Auto-Enter 
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8. To display a custom message when the data doesn’t meet the validation requirements, select 
Display custom message if validation fails, then type up to 255 characters.

9. Click OK to close the Options for Field dialog box, or click another tab to set additional field 
options.

For more information, see Help.

Is a time containing numeric values for hours and 
minutes between 00:00 and 23:59 (seconds are optional)

Strict data type, then choose Time of Day from the list

Is not blank Not empty

Does not duplicate a value found in this field in other 
records

Unique value

Matches another value in the same field in any other 
record

Existing value

Matches a value in a specified value list Member of value list, then choose an existing value 
list or define a new one 

Is within a specific range of letters, numbers, dates, or 
times

In range, then type the beginning and ending values

Matches the result of a calculation Validated by calculation, then enter a calculation in the 
Specify Calculation dialog box. Select or clear Validate 
only if field has been modified. Then click OK.
The result must be Boolean—true or false. The result is 
true when the result is any number except zero; any 
other result (zero, no data, or non-numeric data) is false.
For more information about the Specify Calculation 
dialog box, see “Creating calculation fields” on page 63.

Does not exceed the specified number of characters Maximum number of characters, then type the 
maximum number of characters allowed

Does not exceed a specified file size (for container field) Maximum number of kilobytes, then enter the 
number of kilobytes. This setting limits the size of a file 
that’s embedded in a container field or stored 
externally. This setting has no effect on files that are 
stored by reference in a container field.

To require that the entered value Select 

Select validation 
options for the field

Click Validation 

This option 
appears only for 
container fields
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About indexing and storage options
FileMaker Pro provides options for indexing fields and for storing the results of calculations. You 
can:
1 Create an index, which is a list of the values stored in a field. An index greatly speeds searches, 

but takes up space on your disk. You can index text, number, date, time, and timestamp fields. 
You can also index calculation fields if the results are text, numbers, dates, times, or timestamps.

1 Store the result of a calculation field in your database, or you can tell FileMaker Pro to perform 
the calculation only when needed (unstored). Storing the result is faster but takes up more 
space on the disk. You can specify storage options for text, number, date, time, timestamp, and 
calculation fields.

1 Set any field (except summary fields) to share one value across all records in a file if you select 
Use global storage in the Storage tab of the Options for Field dialog box. Fields defined with 
global storage are also referred to as global fields.

1 Store data for a container field in a location that’s external to the file, such as in a different folder 
or directory on the local or a host computer.

.

Click Storage

Select the 
storage option for 

the field

Storage options for all field types except container fields 
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The options in the Storage tab change for a container field.

For more information about setting field options, see Help.

Creating database tables 
Use database tables to organize and group your data by a common characteristic or principle. 
Your database can contain as many tables as you need to organize your data.
In addition to storing data, FileMaker Pro uses tables to describe relationships in the relationships 
graph, and establish the context for layouts and some calculations. In FileMaker Pro, context is 
the starting point from which calculations and scripts are begun and from which a relationship is 
evaluated in the relationships graph. 
When you create a new file, FileMaker Pro automatically creates the first table and the first layout. 
The table and the layout are given the same name as the file. 

You create additional tables in the Manage Database dialog box.

1. With the database open, choose File menu > Manage > Database.

2. In the Manage Database dialog box, click the Tables tab.

Select storage 
options for a 

container field

Storage options for container fields

Type a name 
for the table
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3. In the Table Name box, type a name for the table, then click Create.
The table can be renamed or deleted. Tables you add to a file are automatically displayed in 
the relationships graph.

4. Continue to define tables, or click the Fields tab to define fields.

For information about relationships, tables, and the relationships graph, see chapter 4, “Working 
with related tables and files.”

Creating layouts and reports
FileMaker Pro layouts determine how information is organized for viewing, printing, reporting, 
finding, and entering data. Layouts don’t store your data—they just display it. Layouts are 
sometimes called reports, especially when printed. 
You can create as many layouts as you need for a file (for example, layouts for entering data, 
reporting summaries, or printing mailing labels). You can change a layout’s design without 
affecting the data or other layouts for the file. Layouts can include certain fields and exclude 
others. When you change the data in a field (in Browse mode), the changes are reflected in the 
same field for the same record on all the layouts in the file.

When you create a database file (without using one of the Starter Solution template files included 
with FileMaker Pro), FileMaker Pro automatically creates a layout for the initial table in the file, and 
for each newly added table that contains fields.

Fields: use for entering 
and displaying data

Layout pop-up menu

Mode pop-up menu Buttons: use to automate 
frequent tasks

Layout text: use for titles, 
column headings, field 

labels, instructions, and 
form letters

Parts: use headers, 
footers, the body, and 
summaries to divide a 

layout into special 
purpose areas



Chapter 3  |  Creating databases 74

You create additional layouts by switching to Layout mode and using the New Layout/Report 
assistant, which guides you through creating a layout according to options you choose. Use the 
different layout types for various purposes, like displaying a data entry screen or printing a totaled 
sales report or mailing labels. You can customize each layout by using the design tools that are 
available in Layout mode.

Important   FileMaker Pro considers the selected printer, and print or page setup information 
when it calculates margins and other measurements on the layout. Printer and print settings 
depend on the printer and system software you’re using. Refer to your printer and system 
documentation for more information. 

Keep the following points in mind:
1 If you intend to print the new layout in landscape orientation or on a special paper size, in 

Browse or Layout mode, choose File menu > Print Setup (Windows) or File menu > 
Page Setup (OS X), confirm the orientation and paper settings, then click OK. Modified Print 
Setup and Page Setup settings affect all other layouts in the current file, so you may need to 
change these settings later to print other layouts properly.

1 You can easily manage the layouts and layout folders in your database using the Manage 
Layouts dialog box. For example, add, delete, and duplicate layouts and folders, open multiple 
layouts, and change the order in which layouts and folders appear in the Layout pop-up menu. 
For more information, see Help.

To create a layout:

1. In Layout mode, click New Layout/Report in the status toolbar. 
Or, in Browse mode, choose File menu > Manage > Layouts, and click New.
You see the New Layout/Report assistant, which helps you create the type of layout you want. 
As you make your choices, additional options are presented to you. For some types of layouts, 
such as labels, envelopes, and reports, you see additional panels.

2. If the file has multiple tables, for Show records from, choose the table from which you want 
records displayed in this layout. 

3. For Layout Name, give the layout a name.

4. Choose the type of layout you want to create.
For a description of each layout type, see “About layout types,” below.

5. Depending on the layout type you choose, additional options may become available.

To Do this
See an onscreen Help topic that explains the 
choices in the current panel

Windows: Press F1 (Windows) or Command-? OS X).
If the layout you’re creating has additional panels (such as 
for labels, envelopes, or reports), you can also click  
(Windows) or  (OS X) to get information about those 
panels.

Accept the settings in the panel and continue to the 
next panel (available for labels, envelopes, and 
reports layouts)

Click Continue or Next.
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6. When you have finished making your choices, click Finish to create the layout.

7. For layouts designed for computers or touch devices, add fields to the layout. 
See “Creating and changing fields” on page 57. 

Keep the following points in mind:
1 You can use the tools and commands in Layout mode to further customize the layout. See 

“Working with objects on a layout” on page 81 and “Working with fields on a layout” on page 89.
1 If you click Finish in the first panel of the New Layout/Report assistant without choosing a 

layout type, FileMaker Pro creates a blank layout. A blank layout contains no fields; you add the 
fields you want in Layout mode. A blank layout is a good starting point for complex layouts (for 
example, a data entry screen or form letter).

1 Each layout that you create is assigned a layout theme. If the new layout is the same type 
(Computer, Touch Device, or Printer) as the current layout, the same theme is assigned to the 
new layout; if the new layout is a different type, the appropriate default theme is assigned.

About layout types
You can use the New Layout/Report assistant to create several types of layouts, which are 
described below. 
For more information about creating layouts and reports, see Help.

Computer

Computer layouts are designed to display within the dimensions of most laptop and desktop 
computer screens. After you choose Computer, you choose the view in which you want to display 
the layout (Form View, List View, or Table View), or you can create a report (see “Report,” below). 
After you finish the assistant, you add the fields and any layout objects and embellishments you 
want to the layout.
The default theme for Computer layouts is Enlightened.

Touch Device

Touch Device layouts are designed to display on touch-compatible input devices, including the 
iPad, iPad mini, iPhone 3.5-inch, iPhone 4-inch, or a device with dimensions that you customize 
after you finish the assistant. After you choose Touch Device, you choose the view in which you 
want to display the layout. You can also choose the orientation—portrait or landscape—for the 
layout. After you finish the assistant, you add the fields and any layout objects and embellishments 
you want to the layout.
The default theme for Touch Device layouts is Enlightened Touch.

Accept the settings in the panel but go back to the 
previous panel (available for labels, envelopes, 
and reports layouts)

Click Back.

Close the assistant without saving any of your 
choices

Click Cancel.

To Do this
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Printer

Printer layouts are designed for printing data on labels (horizontal or vertical), envelopes, and in 
reports. The Printer layout choices are described below.
The default theme for Printer layouts is Enlightened Print.

Labels

Use a Labels layout to arrange fields you select to print on one of the predefined standard label 
sizes. (FileMaker Pro includes the dimensions of a large number of standard label types.) If the 
label type you want isn't available, you can specify custom label dimensions. 
You can only print (or preview) data; you cannot add information. (Use another layout type for data 
entry or finding data.)
 

For more information about creating a Labels layout and printing labels, see “Printing labels and 
envelopes” on page 46.

Vertical Labels

With the Vertical Labels layout, Asian and full-width characters are rotated so that labels can be 
used vertically.
For more information about vertical writing, see “Formatting fields and text for vertical writing” on 
page 98.

Labels in Layout mode

Labels in Preview mode
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Envelopes

Use an Envelopes layout to print the fields you select, arranged to print on a standard “Number 
10” business envelope. You can only print (or preview) data; you can't add information. (Use 
another layout type for data entry or finding data.)

For more information about creating an Envelopes layout and printing on envelopes, see “Printing 
labels and envelopes” on page 46.

Report

The New Layout/Report assistant lets you define varied report formats. You can create a Report 
layout with simple rows and columns of data (formerly a predefined layout type known as the List 
view layout), or a complex report with data grouped by specified values and including subtotals 
and grand totals.
You can also group records by sorting data by selected fields. You can then subtotal, or 
subsummarize, data in these groups (for example, group sales data by region, then subtotal sales 
for each region).
When you create a Report layout in the assistant, you can then choose to:

1 include subtotals and grand totals in the report.
1 add header and footer parts with static text (like your company's name), dynamic text (like 

the page number or current date), or a graphic (like your company logo).
1 group records by sorting; you can then subtotal or subsummarize data in the groups (for 

example, group sales data by region, then subtotal sales for each region).
1 save information in a script to rerun the report (for example, switch to the report layout and 

sort the data).
You can modify any of these options after you finish the assistant. 
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Working with layout themes
Use FileMaker Pro themes to enhance the appearance of a layout or report and to give all your 
layouts a consistent look. A theme affects characteristics of the layout, including the background 
color, field borders and fill, and text attributes in and outside of fields. A theme does not control the 
placement or behavior of fields or objects. You can change the theme of an existing layout in 
Layout mode. 

To change the theme of a layout: 

1. Display the layout you want to change.

2. In Layout mode, choose Layouts menu > Change Theme, or click  in the layout bar.

3. Select themes in the Layout themes list to display a preview of each theme.
1 To apply a theme from this file, select a theme in the Layout themes list to display a preview 

of each theme.
1 To apply a theme from another FileMaker Pro file, click Import Themes, choose the file 

containing the theme(s) you want to import, and click Open. Select one or more themes in 
the Import Themes dialog box, and click OK. Then select a theme in the Layout themes list.

4. Click OK to apply the selected theme to the current layout.

Keep the following points in mind:
1 When you change a layout’s theme, FileMaker Pro applies the attributes of the new theme to 

all objects on the layout except the following:
1 The font and font size remain from the original layout or theme.
1 Buttons created using versions of FileMaker Pro earlier than version 12 retain their original 

formatting.
1 Objects on the layout background that are filled with an image, or a layout background that 

is filled with an image, retain the image.
1 You might need to resize layout parts and layout objects after a theme is applied for the layout 

to display properly.
1 If you want the layout to look similar to layouts created with versions earlier than 

FileMaker Pro 12, under Basic, choose the Classic theme.
1 If you’re creating a layout to be used with FileMaker Go, choose one of the Touch themes.
1 If you’re creating a layout to be printed, choose one of the Print themes.
1 The styles of layout objects, layout parts, and the layout background are controlled by the 

layout’s theme. If the predesigned themes do not display the styles you want, you can create 
and apply a custom theme. See “Working with layout object, part, and background styles” on 
page 101.
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Setting up a layout to print records in columns
You can set up a layout to print (or preview) records in columns, for example, for a directory of 
names and addresses. When you set up records to print in columns, all the field values (and 
labels, if specified) for one record are printed together in a block (much like on a label), then all 
the values for the next record are printed together, and so on. You only see multiple columns in 
Layout and Preview modes and when you print (not in Browse mode or Find mode). 
You can choose to arrange columns across the page or down the page.

Setting up columns in a layout 
1. Choose a printer, and print or page setup options.

FileMaker Pro considers the selected printer, and print or page setup information when it 
calculates margins and other measurements on the layout.

2. In Layout mode, create a layout or choose a layout from the Layout pop-up menu.
It’s easiest to start with a Blank layout or a layout with no objects in the body part.

3. Choose Layouts menu > Layout Setup.

4. In the Layout Setup dialog box, click the Printing tab, select Print in <value> columns, select 
options for the columns, then click OK.

5. On the layout, you see vertical lines indicating columns. 

To Do this
Specify the number of columns For Print in <value> columns, type a number between 1 and 99.

Arrange records to flow across the page first 
(left to right, a row at a time)

Select Across first. 
Use this option for reports like labels, to use the fewest number 
of rows and preserve label stock.

Arrange records to flow down the page first 
(top to bottom, a column at a time)

Select Down first.
Use this option for reports like directories, where you read from 
top to bottom, column by column.

Down first

1

2

3

4

5

6

7

8

1

3

5

7

2

4

6

8

Across first
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6. Place or arrange fields and other layout objects so they are contained within the sample column 
on the left.
Use merge fields or fields or objects with sliding enabled to fit more data into the width of a 
column. With either of these two features, fields can extend into the gray area of the second 
column, and blank space in fields is eliminated when you view or print data. 

Changing the width of columns
The initial width of each column is calculated based on the paper size, orientation, and any 
margins you have set. To change the width of columns, do one of the following:

If you change the number of columns, FileMaker Pro adjusts the width of the columns to fit within 
the width of the paper size you have defined, not including fixed margins. You may need to 
readjust fields to fit within the sample column.
For more information about setting up a layout to print records, see Help.

To Do this
Interactively adjust the width of 
the columns

Drag the right column boundary (the vertical dashed line at the right edge of the 
sample column). If you widen the column, you see a medium-gray area that 
indicates a “gutter” area that won’t print.

Precisely measure and adjust the 
width of the columns

Click Inspector  in the layout bar. Click Position. Position the pointer over 
the right column boundary, hold down the mouse button (be careful not to drag 
the column width), and read the column Width value in the Size area. 

Manually resize column 
widths by dragging 

Sample column
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Working with objects on a layout
An object is a discrete element—a field, text, a graphic object (such as an oval or imported 
picture), a button, a portal (for displaying rows of related records), a tab control or slide control, a 
popover button and its popover, a chart, or a web viewer—that you can select, move, resize, 
delete, copy, format, or otherwise change. Place objects on a layout to enhance its design. 
For each type of object you work with, you use specific tools from the status toolbar.

Note   If you don’t see the status toolbar at the top of the document window, the status toolbar might 
be hidden. Make sure you’re in Layout mode, then click the status toolbar control button  at the 
bottom-left corner of the document window (or choose View menu > Status Toolbar).

Organizing data with panel controls and popovers
Tab controls, slide controls, and popovers are useful ways of organizing data. For example, you 
could create tab panels for various categories of products. 
1 To create a tab control, in Layout mode, choose Insert menu > Tab Control or click the Tab 

Control tool. 

Status toolbar in Layout mode (Windows)

Status toolbar in Layout mode (OS X)

Tab control

Click a tab to display another tab panel

Tab panel

Tab control in Browse mode

Tab Control tool
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1 To create a slide control, in Layout mode, choose Insert menu > Slide Control or click the 
Slide Control tool. 

1 To create a popover, in Layout mode, choose Insert menu > Popover Button or click the 
Popover Button tool. 

For more information about creating tab controls, slide controls, and popovers, see Help.

Slide control

Click a dot to display another slide panel

Slide panel

Slide control in Browse mode

Slide Control tool

PopoverPopover button—click 
to open the popover

Popover button and popover in Browse mode

Popover Button tool
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Using the Inspector to format objects
In Layout mode, you can use the Inspector to view and modify the settings for objects. Each tab 
focuses on a different aspect of formatting. Hold your pointer over options in each tab to see a 
description of what they do.

To open the Inspector:
1 Click Inspector  in the layout bar.
1 Choose View menu > Inspector.

You can open multiple Inspector windows to make it easier to work on a layout. For example, 
display the Data tab of an Inspector window and the Appearance tab of another Inspector window 
to have access to the options on each tab. To open another Inspector window, choose View 
menu > New Inspector.
For more information about using the Inspector, see Help.

Click the tabs to format 
different aspects of an object

Enter settings for an object’s 
position on the layout

Anchor the object to the top, 
bottom, left, or right side of the 

window (in Browse or Find mode) 
or the left or right (in Preview mode 

or when printing)

Select settings for an object’s 
relative position, and for 
resizing an object

Select settings for 
printing and previewing 

objects

Select settings for working with 
the grid
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Using the Inspector to position objects
Use the Inspector to precisely position or size objects on a layout. Or you can set objects to 
automatically resize or move horizontally or vertically when the FileMaker Pro window is resized. 
Horizontal settings also apply to Preview mode and printing when the page size is wider than the 
size of the layout being viewed or printed.
When layout objects are set to resize, they maintain a constant distance from the object to which 
they are anchored. This allows objects to move, expand, or contract when the FileMaker Pro 
window is resized.
Anchor points are either the layout margin or the container margin in which an object resides. By 
default, objects are anchored on both the top and left side of the layout or page.

Precisely positioning or sizing objects

1. In Layout mode, select one or more objects.
For more information, see “Selecting objects” on page 88.

2. Click Inspector  in the layout bar, then click Position.

3. In the Position area, type a new value into one of the fields.

4. Type a new value in one of the following fields.

If you can't type a value, that field doesn't make sense for the selected object (for example, a 
horizontal line doesn't have a height), or the selection is locked.

5. Press Enter or Tab, or click outside the Inspector to apply the changes.

Note   To change the unit of measure, do one of the following:

1 Right-click a ruler and choose a unit of measure from the shortcut menu.
1 Click the upper-left corner of the document where the horizontal and vertical rulers meet.
1 In the Inspector, click the unit of measure, which appears next to many options.

Field Indicates
Name The name of the selected object (optional). You can assign names to objects and grouped 

objects. 
Some script steps and functions use these names to specify which object to act upon. For 
more information, see Help.

Left The distance from the left edge of the selection to the left edge of the layout.

Top The distance from the top of the selection to the top of the layout.

Right The distance from the right edge of the selection to the left edge of the layout.

Bottom The distance from the bottom of the selection to the top of the layout.

Width The object's width.

Height The object's height.
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Allowing objects to resize or move on the layout

When layout objects are set to resize, they maintain a constant distance from the object to which 
they are anchored. This allows objects to move, expand, or contract when the FileMaker Pro 
window is resized.
Anchor points are either the layout margin or the container margin in which an object resides. By 
default, objects are anchored on both the top and left sides of the layout or page.

To allow objects to resize or move when the FileMaker Pro window is resized:

1. In Layout mode, select one or more objects on the layout. 
For more information, see “Selecting objects” on page 88.

2. Click Inspector  in the layout bar, then click Position.

3. In the Autosizing area, select the line that indicates the side of the object that you want 
anchored to the layout or container. 

Note   Objects located in panel containers, popovers, or portals on layouts (such as fields located 
on a tab panel) do not inherit resize settings from the panel container, popover, or portal they are 
in. 

Important   Multiple objects positioned side-by-side or stacked vertically and anchored to both left 
and right margins or both top and bottom margins move or resize relative to the window or 
container margin, not each other. Therefore, adjacent objects will not maintain a relative distance 
from one another and may overlap when the window is resized.

For more information about setting objects to resize, see Help.

Using tools to precisely position objects
FileMaker Pro provides several tools to help you precisely create, size, reshape, move, and 
position objects in Layout mode.

Note   To show or hide page breaks in Layout mode, choose View menu > Page Breaks.

Rulers

Showing the rulers displays a horizontal and vertical ruler along the edge of a layout. Guide lines 
on each ruler track the position of the pointer as you move the pointer on the layout. 
1 To show the rulers, in Layout mode, choose View menu > Rulers.
1 To hide the rulers, choose View menu > Rulers again.

Select the line for the 
side of the object you 
want anchored



Chapter 3  |  Creating databases 86

Grid

Showing the grid displays a series of nonprinting intersecting horizontal and vertical lines. The grid 
aligns objects you create, resize, move, or position. Objects “snap to” the grid to help you create 
and edit objects more precisely. Gridlines adjust when you change the unit of measure.

To show or hide the grid, do one of these:
1 In the Inspector, click the Position tab. In the Grid area, select or deselect Show grid.
1 Choose View menu > Grid > Show Grid. To hide the grid, choose Show Grid again.

Guides

Guides help you align objects within the same layout and across multiple layouts.

To Do this
Create a vertical guide Drag out from the vertical ruler. (If the ruler isn’t displayed, select View menu > 

Rulers.)

Create a horizontal guide Drag down from the horizontal ruler. (If the ruler isn’t displayed, select View 
menu > Rulers.)

Move a guide Drag the guide to the new position.
If a guide is locked, you must unlock it before you can move it.

Use guides in other layouts 
you create or edit

Right-click the guide, then choose Share Guide with All Layouts. A guide 
shared with other layouts is a different color from one that’s used only for the 
current layout.
To use a shared guide only with the current layout, right-click the guide, then 
choose Share Guide with All Layouts again. 

Lock a guide Right-click the guide, then choose Lock Guide. A locked guide is a different 
color from an unlocked guide.
To unlock a guide, choose Lock Guide again. 

Remove a guide Drag a horizontal guide back to the horizontal ruler, or a vertical guide back to 
the vertical ruler.
Or, right-click the guide, then choose Remove Guide.

Show or hide the guides To show guides, choose View menu > Guides > Show Guides. To hide guides, 
choose Show Guides again.

Turn the “snap-to” effect on or 
off

Choose View menu > Guides > Snap to Guides. To turn it off, choose Snap to 
Guides again. 
Objects snap to guides even when the guides are hidden.
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Dynamic guides

When you drag objects to move, resize, or position them on a layout, dynamic guides appear near 
or on the objects to help you create and edit them more precisely. Dynamic guides also “snap-to” 
the upper and lower boundaries and the centers of objects as you move, resize, or position them.
 

Dynamic guides also appear when you use the keyboard to move objects, but they do not “snap-
to” objects when you move them this way.

To use dynamic guides:
1 To turn on dynamic guides, in Layout mode, choose View menu > Dynamic Guides.
1 To turn off dynamic guides, choose View menu > Dynamic Guides again.

Screen stencils 

You can display guides that help you design layouts optimally for iPad, iPhone, and common 
desktop resolutions. You can also create screen stencils with custom dimensions.
To display a screen stencil, click the arrow on Screen Stencil  in the layout bar, then choose 
a size from the list. You can display more than one screen stencil at a time on the same layout. To 
create a screen stencil, choose Custom Size from the menu. 

Dynamic guides 

Guides
Screen 
stencil

Rulers
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Selecting objects
To work with an object on a layout, select it in Layout mode. You see small squares, or handles, 
surrounding the selected object.

Note   If an object’s selection handles display as  , the object is locked.

To select an object, click the selection tool  in the status toolbar. The pointer becomes an arrow 
pointer. Then do one of the following.

For more information about working with objects on a layout, see Help.

To In Layout mode, do this
Select one object With the arrow pointer, click the object. (If the object is transparent, click its border.)

Select several objects 
at once

Drag the arrow pointer to make a selection box that includes the objects. The selection 
box does not have to completely surround the objects. To avoid including partially selected 
objects, press Ctrl (Windows) or 2 (OS X) as you drag.
Or, press Shift as you click each object individually. 

Select all objects on the 
layout

Choose Edit menu > Select All.

Select all objects of the 
same type (for 
example, all text 
objects or all 
rectangles) 

Click the tool for the type of object to select, then choose Edit menu > Select All. This 
method does not select buttons.
Or, with the arrow pointer, click a field, press Shift (Windows) or Option (OS X), and 
choose Edit menu > Select All (Windows) or Select Same (OS X).

Select all fields With the arrow pointer, click a field, press Shift (Windows) or Option (OS X), and choose 
Edit menu > Select All (Windows) or Select Same (OS X).

Select a portal With the arrow pointer, click the border of the portal, or any other area within the portal that 
doesn’t contain a field or object.

Select tab controls or 
slide controls, tab 
panels or slide panels, 
and objects on tab 
panels or slide panels

See Help for information on creating and working with tab controls and slide controls.

Select popover 
buttons, popovers, and 
objects on popovers

See Help for information on creating and working with popover buttons and popovers.

Deselect selected 
objects

Click a blank area of the layout or any tool in the status toolbar. Or, press Shift and click 
selected objects.

Handles surround a selected object
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Working with fields on a layout
After you’ve added fields to a database, you can place the fields on a layout, remove fields you 
don’t want displayed, determine control settings for data entered in fields, and determine the 
format in which you want data displayed. 
Fields on a layout are objects, which you can select, move, resize, and reshape. In Layout mode, 
each field displays its field name, formatted with its attributes for font, size, style, alignment, line 
spacing, and color. All fields except container fields display text baselines to indicate where the 
data appears in Browse mode and to help you align fields with each other. 

Note   As long as you haven’t deleted a field from the database, even if the field doesn’t appear 
on a layout, it still exists in the database and its data can be used in calculations and summaries.

Placing and removing fields on a layout
You can place a field anywhere on any layout, as many times as you want. (You can place only 
fields that you’ve defined. See “Creating and changing fields” on page 57.)

You get different results by placing the same field in different locations on the layout. For example:
1 Add the same summary field to a subsummary part to calculate totals for each group of sorted 

records, and to a grand summary part to get totals for all the records in a table.
1 Add a field to the header or footer part to repeat data from the first record or the last record on the 

page as a header or footer. (For example, add a Last Name field to the header in a directory.)
1 Add the same related field directly on a layout to see the field’s value in the first related record, 

or inside a portal to see values from more than one related record. (A portal is a layout object 
that displays records from related tables.)

Fields display 
field names

Text baseline

Field label
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Placing a field on a layout

1. In Layout mode, choose the layout you want to work with from the Layout pop-up menu.

2. Do one of the following:
1 Drag a field from the Field tool  in the status toolbar to the position you want it on the 

layout. As you drag the field onto the layout, you see a border and text baselines to help you 
align the field with other objects on the layout. Release the mouse button when the field is 
where you want it. 

 

1 To add and resize a field, click the Field/Control tool  in the status toolbar. Drag the 
crosshair to draw the field.

1 To display field data in a drop-down list, pop-up menu, checkbox set, radio button set, or 
drop-down calendar, click the arrow next to the Field/Control tool  (Windows) or click 
and hold the Field/Control tool  (OS X), then select the type of field or control to add to 
the layout. Drag the crosshair to draw the field. To format and choose a value list for the field, 
see “Setting up checkbox sets and other controls on a layout” on page 91.

Note   If you're placing a related field in a portal, position it in the first row of the portal. Make 
sure each field in the portal is from the same related table from which the portal is set up to 
display records. For more information, see Help.

3. In the Specify Field dialog box, select the field to place. 

To choose a field in another table, choose the table from the table list above the list of fields. 
Then select a field from the fields list. Or choose Manage Database in the table list, or click  
to create a relationship or table (see “Creating relationships” on page 118). 

4. To include the field name as text on the layout, select Create label.

5. Click OK.
You see the field name in the field on the layout unless you have chosen to display sample data 
from the current record (by choosing View menu > Show > Sample Data). Fields from related 
tables appear as ::Field Name (preceded by two colons).

Replacing a field with another field

In Layout mode, double-click the field, then select another field name in the Specify Field dialog 
box and click OK.

Select the 
field to add

Select to use the field 
name as the field label 

To place a field from 
another table, choose 

the table

Click to display the 
Manage Database 
dialog box
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Removing a field from a layout

In Layout mode, click the field to select it, then press Backspace or Delete, or choose Edit menu > 
Clear. Removing a field from a layout does not delete the field or its data from your database. 

Setting up checkbox sets and other controls on a layout
You can format fields to display as drop-down lists, pop-up menus, checkboxes, radio buttons, and 
drop-down calendars. You can also format fields to auto-complete by suggesting possible 
matches as the user types data in the field. All of these options aid in data entry.

To set up a field to display a pop-up menu, checkbox set, or other control:

1. In Layout mode, select the field.
1 If the field isn’t already on the layout, see “Placing and removing fields on a layout” on page 89.
1 If the field hasn’t been defined yet, choose File menu > Manage > Database to define a new 

field.

2. Click Inspector  in the layout bar, then click Data.

3. In the Field area, choose the Control Style you want: 
1 Edit box
1 Drop-down list
1 Pop-up menu
1 Checkbox set
1 Radio button set
1 Drop-down calendar

For example, use a radio button set to display a value list of frequently used text, number, date, 
or time values. During data entry, users can choose from the defined values rather than type 
the values.

When you choose different control styles, you see different options in the Inspector.

4. Choose the value list you want from the Values from list.
To create a value list, click  next to the Values from list.

Value list attached to Category field

Choose from a list of 
values during data entry
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5. Choose options for the value list, if desired. 
If you selected Drop-down list for the Control Style, you can select Include arrow to show 
and hide list if you want to format the field as a combo box. An arrow control appears in the 
edit box. Users click the arrow or press Esc to show or hide the drop-down list.
To allow users to enter values other than those defined by the value list, select Allow editing 
of value list or Allow entry of other values. 
To set up fields to suggest possible matches as the user types data in the field, select Auto-
complete using existing values or Auto-complete using value list.

6. To display data from a different field, click  next to Display data from.
In the Specify Field dialog box, select the field to display data from. To include the field name 
as text on the layout, select Create label. Click OK.

7. Save the layout.

For more information on creating value lists and setting control style options, see Help.

Deciding where to place related fields 
You can place related fields directly on layouts or in portals.
1 Directly on layouts: Place related fields directly on a layout to display data from the first related 

record, even when there are more than one related records that matches the criteria of the 
relationship. (The first related record that’s displayed is determined by whether the relationship 
specifies a sort order. For more information, see “Creating relationships” on page 118.) 

1 In portals: Place related fields within a portal on a layout to display data from all related records 
that match the criteria of the relationship. For examples of when to place related fields in portals, 
see Help.

Note   Before placing related fields on a layout, you should understand the concepts presented in 
chapter 4, “Working with related tables and files.”

About merge fields 
Use merge fields to combine field data and text in documents like form letters, labels, envelopes, 
or contracts. You create merge fields in text blocks, which allows you to use static text and field 
data together.

Merge fields shrink or expand to fit the amount of text in the field for each record. For example:
1 When the merge field <<First Name>> is between the text Dear and a colon, (as in Dear 

<<First Name>>:), FileMaker Pro displays Dear Charles: in Browse mode or Preview mode if 
the First Name field contains Charles.

1 When a merge field is on a line by itself (such as an empty Address Line 2 field in a mailing 
label), FileMaker Pro removes the blank line from the text block. 

FileMaker Pro uses merge fields to create Labels and Envelope layouts. 

Note   You can also use a merge variable to display data. For more information, see Help.
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Formatting field data on a layout
Use FileMaker Pro field formats to control how data appears on a layout. The formats you specify 
don’t change the data as it’s stored in the database, and you can specify different formats each 
time you place a field on a layout (whether it’s on the same layout or a different layout). For 
example, if you enter –5123 into a number field, you can format it in one place to display as 
–$5,123.00 and in another place as <5123>.

Note   If you don’t specify formats, FileMaker Pro displays numbers, dates, and times based on 
the system formats set in the Clock, Language, and Region control panel (Windows) or the 
Language & Text pane in System Preferences (OS X) when the file was created.

Specifying text formats for fields

In Layout mode, you can specify a set of text character attributes for each field. All the characters 
in that instance of the field (including all repetitions of repeating fields) share the same font, size, 
style, color, line spacing, tab, and paragraph settings. 

Note   You can also format characters in text fields in Browse mode (for example, italicize or 
underline a word for emphasis). Unlike text formatting specified in Layout mode, this formatting is 
stored with the data, and you see it in any layout that displays that field. 

1. In Layout mode, select one or more fields.

2. Click Inspector  in the layout bar, then click Appearance.
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3. Select the formats you want to use.
Use the Text area to format the style, size, font, or color of the text or make text highlighted, 
bold, italic, or underlined. Use the Paragraph area to set paragraph alignment, indenting, and 
line spacing for fields. Use the Tabs section to position and align tab stops, and create a leader 
character to fill the width of the tab indention.

4. Press Enter or Tab, or click outside the Inspector to apply the changes.

For more information about specifying text formats for fields, see Help.

Specify font, style, size, 
and colorHighlight text

Set vertical and 
horizontal alignment, 

line spacing, and 
paragraph indents

Set tab position 
and alignment

Type a character to fill 
across to the tab

Specify options for 
text baselines Align text with radio 

buttons and checkboxes
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Specifying formats for fields containing numbers

You can control how FileMaker Pro displays the values in number fields, calculation fields with 
numeric results, and summary fields.

1. In Layout mode, select one or more fields that display numeric values.

2. Click Inspector  in the layout bar, then click Data.

3. In the Data Formatting area, click Number .

4. Select the number format you want to use from the Format list, then select additional formats 
for the number field.
The options that appear depend on the format you choose.

5. Press Enter or Tab, or click outside the Inspector to apply the changes.

For more information about specifying formats for fields containing numbers, see Help.

Specifying formats for date fields

You can control how FileMaker Pro displays the values in date fields, and calculation fields with 
date results. 

Important   No matter how you format a date field in Layout mode, whenever you click or tab into 
the field in Browse mode, FileMaker Pro displays the date with a four-digit year. FileMaker 
recommends that you always enter dates with four-digit years. If you enter dates with two-digit 
years, they are converted to four-digit year dates. For more information, see “Conversion of dates 
with two-digit years” in Help.

1. In Layout mode, select one or more date fields or calculation fields with a date result.

2. Click Inspector  in the layout bar, then click Data.

3. In the Data Formatting area, click Date .

Choose options for Boolean or 
decimal numbers, currency, 
and percent

Set options for displaying different 
Japanese numeral types

Set options for 
currency and 

negative values

Display numbers 
using the current 

system formats
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4. Select the date format you want to use from the Format list, then select additional formats for 
the date field.

Note   To format dates using the current system format for dates, for Format, choose Short 
system date or Long system date. 

5. Press Enter or Tab, or click outside the Inspector to apply the changes.

For more information about specifying formats for date fields, see Help.

Specifying formats for time fields

You can control how FileMaker Pro displays time values in fields.

1. In Layout mode, select one or more time fields, or calculation fields with a time result.

2. Click Inspector  in the layout bar, then click Data.

3. In the Data Formatting area, click Time .

4. Select the time format you want to use from the Format list, then select additional formats for 
the time field.
If you want to format the seconds component to display fractional seconds, continue with the 
next step. If you don’t want to format the seconds component, skip to step 6.

Choose options for 
day, month, date, 
year, and separator 
characters

Choose options 
for displaying 

Japanese dates
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5. Click Number  in the Data Formatting area, then select the formatting options you want.
Only two options affect the display of the seconds component: Fixed number of decimal 
digits and Decimal (to the right of Separators). The remaining options have no effect.

Note   To format times using the current system format for times, for Format, choose Short 
system time or Long system time. 

6. Press Enter or Tab, or click outside the Inspector to apply the changes.

For more information about specifying formats for time fields, see Help.

Specifying formats for timestamp fields

You can control how FileMaker Pro displays timestamp values in fields. You format a timestamp 
field by separately formatting its three components: date, time (excluding the seconds portion), 
and seconds (including fractional seconds).

1. In Layout mode, select one or more timestamp fields, or calculation fields with a timestamp result.

2. Click Inspector  in the layout bar, then click Data.

3. To format the date component, in the Data Formatting area, click Date , then select the 
formatting options you want.

4. To format the time component (except the seconds portion), in the Data Formatting area, click 
Time , then select the formatting options you want.

Choose options for 
displaying 

Japanese times

Choose to display times as 
entered, in a 
predetermined format, or in 
a format you specify
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5. To format the seconds and fractional seconds component, in the Data Formatting area, click 
Number , then select the formatting options you want.
Only two options affect the display of the seconds component: Fixed number of decimal 
digits and Decimal (to the right of Separators). The remaining options have no effect.

6. Press Enter or Tab, or click outside the Inspector to apply the changes.

Note   You must specify formats for both date and time components before any formatting will be 
applied. If you select As entered for either Date or Time, then the data in the timestamp field 
appears the way it is entered.

For more information about specifying formats for timestamp fields, see Help.

Specifying formats for container fields

You can control how FileMaker Pro displays images and file icons in container fields.

Note   The following instructions also apply to formatting graphic objects that you insert onto a layout.

1. In Layout mode, select one or more container fields or inserted graphics.

2. Click Inspector  in the layout bar, then click Data.

3. In the Data Formatting area, click Graphic , then select the formats you want to use.
  

For more information about specifying formats for container fields, see Help.

Formatting fields and text for vertical writing

If your operating system is configured to support Japanese text entry, you can format field objects 
and text objects that display Japanese text in vertical writing format. In vertical writing, characters 
are displayed and read from top to bottom, with successive columns displayed vertically from right 
to left. This is useful when printing addresses on labels. 
When you select one or more fields, then choose Format menu > Orientation > Sideways 
(Asian text only), the characters are rotated 90 degrees counter-clockwise within the field. The 
field itself is not rotated. To rotate the selected fields, choose Arrange menu > Rotate.

Choose how to align the graphic 
horizontally within the field

Choose how to fit the 
graphic in the frame

Choose how to align the graphic 
vertically within the field

Choose how you want photos and 
interactive media displayed 
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Depending on how you want the text to print, you may want to change the page orientation of the 
layout. To do so, choose File menu > Print Setup (Windows) or Page Setup (OS X), and change 
the page orientation to landscape or portrait. 
For more information about formatting fields and text for vertical writing, see Help.

Allowing or preventing entry into fields
You can allow or prevent entry into a field. For example, you can restrict entry into a field 
containing a serialized number, so the field can’t be modified. You can set separate Browse mode 
and Find mode data entry options, which would allow you to permit finding serialized numbers 
even though they can’t be entered. 

If you allow entry into a field, you can also control whether the entire contents of the field is 
selected when you click or tab into the field in Browse mode or Find mode. Otherwise, 
FileMaker Pro places the insertion point after the last character in the field.

1. In Layout mode, select one or more fields.

2. Click Inspector  in the layout bar, then click Data.

3. In the Behavior area, for Field entry, select the following options:

For more information about working with fields on a layout, see Help.

Working with layout parts
FileMaker Pro layouts are divided into layout parts, sections of the layout that determine how data 
in a field is treated and displayed. By using parts, you can control how FileMaker Pro prints data, 
for example:
1 once for each record
1 only at the top of each page
1 only before or after groups of sorted records (for example, to include a subtotal for each group 

of records)

Each layout must have at least one part. Layout parts can contain fields, portals, buttons, text, 
charts, and other objects. In Layout mode, gray horizontal lines mark the division between layout 
parts (part boundaries), and the part labels appear in the left margin of the layout or directly in the 
part above the part boundary. 
Parts are assigned styles that are defined by the theme of the layout. You can use the Inspector 
to customize part styles.

To Do this
Prevent entry into a field in Browse mode Clear Browse mode.

Prevent entry into a field in Find mode Clear Find mode.

Select the entire field's contents when the field is entered Choose Select entire contents on entry.
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The New Layout/Report assistant automatically creates the appropriate layout parts depending on 
the choices you make. You can add, change, or delete layout parts after you finish the assistant 
as needed. (See “Creating layouts and reports” on page 73.)

About layout part types
The following table describes layout part types.

Layout part Description
Title header Appears only once at the top of the first screen or page and replaces the normal header (if one is 

specified). In reports, can be used to print a separate title page. You can have only one title header 
in a layout.

Header Appears at the top of every screen or page (unless you add a title header, which supersedes the 
header on the first page). Use for titles or column headings (in columnar reports). You can have only 
one header in a layout.

Body Each object you put in the body, including fields, text objects, and graphics, appears once for each 
record in the found set. You can have only one body in a layout.

Footer Appears at the bottom of every screen or page (unless you add a title footer). You can have only one 
footer in a layout.

Title footer Appears only once at the bottom of the first screen or page and replaces the normal footer (if one is 
specified). You can have only one title footer in a layout.

Body 

Header 

Subsummary 

Trailing Grand 
Summary

Footer 

Sales Report

A subsummary below the body summarizes 
data for each group of records sorted on the 

break field (Salesperson)

Trailing grand summary 

Footer Favorite Bakery Confidential June 2014

Salesperson Item Qty Extended Price
David Michaels FB3 1 $3.95
David Michaels FB4 1 $17.50
David Michaels FB1 2 $19.90
David Michaels FB5 3 $52.50

Total $93.85

Sophie Tang FB6 2 $39.00
Sophie Tang FB7 5 $77.50
Sophie Tang FB2 2 $45.00

Total $161.50

Grand Total $255.35
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To include summary data on a layout (for example, subtotals, grand totals, averages, counts, and 
so on), you place summary fields in summary layout parts (see “Creating summary fields” on 
page 65). Summary parts include grand summary and subsummary parts. 
1 A grand summary part usually contains one or more summary fields that display summary 

information (like totals) about all records being browsed.
1 A subsummary part usually contains one or more summary fields that display “subsummary” 

information (like subtotals) for a subset of records. The records are grouped (sorted) by values 
in another field, the break field. Whenever the value of the break field changes, the report 
“breaks” and FileMaker Pro inserts the subsummary part. Subsummary parts appear in Table 
View and List View when sorted by break fields, and update dynamically whenever data in the 
file is changed.

For more information about working with fields on a layout, see Help.

Working with layout object, part, and background styles
Each layout theme includes default styles for the objects and layout parts that you create while 
using that theme. Styles give objects and parts on a layout a consistent appearance. They also 
save you the time of reassigning formatting attributes each time you create a new object or part. 
A theme also includes a default style for the layout background.
Some themes include additional default styles for some objects. For objects that have multiple 
components, each component has a separate style. For example, portals have a Portal style, 
which formats the entire object, and a Portal: Rows style, which formats only the rows of the portal. 
You can modify default styles or design new styles and save them for use on the current layout. 
When you edit and save formatting attributes for styles that are applied to multiple objects or layout 
parts, your changes are applied to all objects and parts that use those styles on the current layout. 
You can also create new styles with custom names, which you can then apply to objects, layout 
parts, or the layout background on the current layout. Any styles you modify and save, or any 
custom styles that you create, apply only to the current layout. 
To use your custom styles on other layouts, save your styles to a theme. You can save custom 
styles to FileMaker Pro themes or you can create new custom themes. 
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1 Use the Styles tab in the Inspector to view and apply defined styles.

Name of the current theme

Styles saved to the 
current theme

Object type

Click to create or 
change styles
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1 Use the Appearance tab in the Inspector to create and modify styles and themes. 

A gray arrow indicates all styles have 
been saved to the theme

Set the fill, line, and corner 
radius style

Set effects for shadows and 
object padding

A red arrow indicates that style 
changes have been made but 
not yet saved at the layout levelObject type 

Object state 
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1 Use the Change Theme dialog box to apply default and custom themes to layouts in a file. 

1 Use the Manage Themes dialog box to see which themes are in use in a file, and to import 
themes from other files. 

For details about working with styles for layout objects, layout parts, and the layout background, 
and about saving styles to themes, see Help.

Select a theme 
from a category

You can import a 
theme from another 

FileMaker Pro file

Select an action to 
perform on the 

selected theme

Themes used in the 
current database

Number of layouts that 
use each theme
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Creating and editing charts
You can create various types of charts in FileMaker Pro to compare data graphically. Before you 
create a chart, think about the data comparison that you want to emphasize, then choose the 
FileMaker Pro chart type that will show the comparison clearly. 

Creating a chart
The following steps describe how to create a quick chart, which FileMaker Pro sets up for you 
based on the field(s) you’ve selected in Browse mode. When you create a quick chart, 
FileMaker Pro sets up the chart based on the selected fields, field type, the contents of the active 
field, and the sort order you specified. 

Note   You can also create charts in Layout mode. For more information about creating charts in 
Layout mode, see Help.

The following example describes how to create a chart that counts and compares the number of 
customers in each company that has an account with your business.

1. Open the file in which you want to add the chart, then switch to Table View.

Use To
Column chart (vertical) 
or bar chart (horizontal)

Compare increases to decreases, highest with lowest, how many, or how often. For 
example, show monthly sales for several products.

Stacked column chart 
(vertical) or stacked bar 
chart (horizontal)

Compare parts to the whole. For example, compare annual sales figures over several 
years.

Positive/negative 
column chart

Compare positive and negative values. For example, compare earnings to losses.

Pie chart Compare percentages of individual parts within the whole. For example, show the 
percentage of each product sold within total sales.

Line chart Show data that changes continuously over time, such as historical financial data.

Area chart Compare data that trends over time while emphasizing highs, lows, and movement 
between data points. For example, show sales totals or averages.

Scatter chart Plot x and y coordinates as individual values to reveal correlation patterns. For example, 
compare target wait time to actual wait time at a call center.

Bubble chart Compare individual data points in terms of size. For example, compare market share by 
charting the number of products sold, sales figures per product, and percentage of total 
sales in each data point.
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2. Sort the column containing data that you want to emphasize.
For example, to emphasize your customers’ companies, right-click the Company column and 
choose Sort Ascending. 

3. Choose the column containing the data that you want to compare.
For example, to compare the number of customers in each company, right-click the Last Name 
column and choose Chart > Chart Last Name by Company.
The Chart Setup dialog box appears with a preview of a column chart that shows the number 
of customers in each company.

4. You can choose settings in the Chart inspector on the right to modify the chart, and preview the 
result of your changes in the Chart Setup dialog box.

For more information about these and other options for charts, see Help.

To Do this
Add a title to the chart With the Chart options displayed, for Title, type or change 

the chart title, or click  to specify a title. For example, 
“Accounts by Company.”

Choose a chart type and specify the data series For Type, choose a chart type. For example, choose Pie.

Change data labels, show or hide tick marks and 
set tick mark scale (if applicable), and format data

Select additional chart options. For example, select Show 
Legend, Show values on chart, and Percentages.

Change the color scheme, legend, or fonts in the 
chart

Click Styles, then make your changes. For example, 
choose Shaded-3D for the chart style, Earth for the color 
scheme, and Arial boldface black for the font settings.

Specify the type of data the chart uses (records in 
the found set, delimited records, or related records)

Click Data Source, then choose a data source. For 
example, choose Current Found Set.

Chart preview

Specify the chart type 
and data series

Specify the records 
to chart

The preview updates as 
you change settings in the 

Chart inspector

Change the chart’s 
appearance
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5. Click Save as Layout, then Exit Layout.

Editing a chart
1. Choose the layout containing the chart from the Layout pop-up menu. 

2. Switch to Layout mode and double-click the chart.

3. In the Chart Setup dialog box, change settings in the Chart inspector.

4. Click Done to close the Chart Setup dialog box.

5. Click Save Layout, then Exit Layout.

For more information about creating and editing charts, see Help.

Chart in a layout in Browse mode
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Working with related tables and files

This chapter explains the basics of how to:
1 plan a relational database
1 create and edit relationships
1 create and edit lookups

FileMaker Pro uses related tables as the basis for relational databases and lookups. Relational 
databases allow you to work with data from other tables dynamically, so that when you change 
data in one place, your changes are reflected in all places where the related data appears. 
Lookups let you copy and paste data from one table to another; once looked-up data has been 
inserted, it does not change unless you edit it or tell FileMaker Pro to look it up again.

Use relational databases to:
1 See and work with data from another (or the current) table in its most up-to-date state. For 

example, display data in related fields when you need current data from a related table, such 
as the current price of an item. As data changes in the related records, you see those changes 
in the current table.

1 Set up and manage data efficiently and with flexibility. Instead of creating many database tables 
or files with duplicate values, you store single occurrences of values and use relationships to 
make those values available. You can then make changes to data in only one place, which 
eliminates data duplication and promotes data accuracy. 

1 Save disk space, because data is stored in only one place.

Use lookups to copy data from a related table and keep it as copied, even when the related data 
changes. For example, use a lookup to copy the price of an item at the time of purchase into an 
Invoices table. Even if the price in the related table changes, the price in the Invoices table stays 
the same.
FileMaker Pro can also access data stored in other FileMaker Pro files and external ODBC data 
sources, which allows you to combine data stored in your FileMaker Pro file with data from these 
external sources. You can work with data in SQL databases that share information through ODBC. 
You can also use supplemental fields in FileMaker Pro to perform calculation and summary 
operations on data stored in ODBC data sources. For more information about using FileMaker Pro 
with external data sources, see “Working with external data sources” on page 136.

Note   See Help for detailed, comprehensive information and step-by-step procedures about 
using FileMaker Pro. 
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About relationships
A relationship is a powerful method for organizing your data. Using a relationship, you can join 
data in one or more tables based on common field values, different field values, or a comparison 
of values in two or more fields.

After you create a relationship, you can do either of the following to display the data from the 
related table:
1 Design a relational database, which is one or more tables that, when used together, contain all 

the data you need for your work. Each occurrence of data is stored in only one table at a time, 
but can be accessed and displayed from any related table. You can change any occurrence of 
your related data, and the changes appear in all places where that related data is used.

1 Define a lookup to copy data from a related table into a field in the target table. The copied data 
is now stored in two places, just as if it were copied and pasted into a target field. Looked up 
data is current at the time it is copied, but once copied it remains static unless it is re-looked up 
or the lookup is triggered again.

12Customer ID

TangLast Name

12Customer ID

TangLast Name

12Customer ID

TangLast Name

Lookups copy data from the related table into the current table

In relational databases, data from the related table is only 
displayed in the current table, not copied

12Customer ID

TangLast Name

Current table Related table

Current table Related table
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For example, a database for a bakery might have these tables: a Products table, which stores 
information about bakery products and their current prices; a Customers table, which stores 
customer information such as customer names and contact information; an Invoices table, which 
keeps a record of each order; and a LineItems table, which stores sales data for each line of the 
invoice, including the item being sold and the price at which it is sold. Because invoices are a mix 
of dynamic and static data, you use both relational databases and lookups to display your data. 
Records from the LineItems table are displayed dynamically, in a portal on the Invoices layout, but 
the actual sales price of each line item is entered using a lookup, so the invoice totals remain 
historically accurate, even if prices change at some future date.

You create a relational database by defining a relationship between two fields, called match fields. 
These fields can be in different tables or they can be in the same table (a self-join). You are able 
to access related data when the value in the match field(s) on one side of the relationship 
compares successfully with a value in the match field(s) on the other side of the relationship, 
according to the criteria you establish in the relationship.
After you have created a relationship, you can use fields from the related table just as you would use 
any fields in the current table: to display data on a layout, as part of a calculation formula, in a script, 
as a match field for another relationship, and so on. You can work with the data in the related fields 
in all modes (if you have access privileges) when you work with records in the current table.
When you display related data in a portal, values from all related records are displayed. When the 
related field isn’t in a portal, the value from the first related record is displayed.
For more information about relationships, see Help.

Invoices table

003Invoice ID

16-Oct-2012Date

3Customer ID

FB7
Unit Price$

Fruitcake $15.50
FB2 Chocolate Cake $22.50

Williams

$38.00TotalCustomers table

3

WilliamsLast Name

408-555-3456Phone

Product ID Product Name
FB7 Fruitcake
FB2 Chocolate Cake

Products table

FB7Product ID

FruitcakeProduct Name

Bakery
ID Location
B20

Ships From
France Paris

B46 Italy Roma

Records from the 
LineItems table 

displayed in a portal

Customer ID

Last Name

Product ID Product Name
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Relational database terminology
Before you begin working with relational databases and lookups, you should understand the 
following terms. These terms are explained in the sections that follow. 

Term Description
Current table For relational databases, the table that you are currently working in.

For lookups, the table that the data is copied to.

External table A table outside of the current file, in another file.

Lookup target field 
(for lookups only) 

The field in a table that you want data copied to during a lookup.

Lookup source field 
(for lookups only) 

The field in the related table that contains the data you want copied during a lookup.

Match field A field in the current table and a field in a related table that each contains values used to 
access matching records. (A match field is sometimes called a key field.) For each 
relationship, you select one or more match fields in each table.
For relational databases, values in match fields must match each other in some way for a 
relationship to be established between the files. See “About match fields for relationships” on 
page 112.
For lookups, values in match fields do not have to be equal to match.

Portal A layout object that displays records from related tables. Portals display data from related 
fields in rows, one record in each row. 

Related field A field in one table that is related to a field in another table (or to a different field within the 
same table). If a relationship has been created between two tables (even through another 
table), data in fields in one table can be accessed from the other table.

Related record A record in the related table whose match field (according to the relationship used) contains 
a value that matches the value in the match field of another table.

Related table For relational databases, the table that contains the data you want to access and work with in 
the current table.
For lookups, the table that contains the data to copy.
A table can be related to itself. This is called a self-join.

Relational 
operators

In the relationships graph, the symbols that define the match criteria between one or more pairs 
of fields in two tables. These include: equal (=), not equal (≠), greater than (>), greater than or 
equal to (≥), less than (<), less than or equal to (≤), and all rows, or cartesian product (X).

Relationship Relationships provide access to data from one table to another. Relationships can join one 
record in one table to one record in another table, one record to many other records, or all 
records in one table to all records in another table, depending on the criteria you specify when 
you create the relationship in the relationships graph. (A relationship is sometimes called a 
link or a join expression.)

Relationships 
graph

In the Relationships tab of the Manage Database dialog box, you can see the occurrences of 
tables both in the current file and from any external, related database files. In this relationships 
graph, you join tables and change relationships between fields in different tables.
When you create a new table, a visual representation, or occurrence, of the table appears in 
the relationships graph. You can specify multiple occurrences (with unique names) of the 
same table in order to work with complex relationships in the graph.

Source file The file from which you add a table to the relationships graph.

Source table The table upon which one or more tables in the relationships graph are based. The source 
table is the table defined in the Tables tab of the Manage Database dialog box.
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About the relationships graph
When you work with tables in the relationships graph, you organize your view of your data. Tables 
shown in the relationships graph can be located in the current FileMaker Pro file, in an external 
FileMaker Pro file, or in an external ODBC data source.
Each table occurrence in the relationships graph represents a separate view into your data. When 
you join two tables, you are leveraging the two existing views to create a third view. As you add 
tables to your relationships, each successive table represents an additional set of criteria that must 
be met before related data can be accessed in that relationship.
You can create a relationship between any two tables in the relationships graph, but the relationship 
must not create a cycle, or closed loop between tables. That is, each series of relationships must 
have a starting table and an ending table, and those tables must be different tables.
Because each relationship represents an additional set of criteria, you must be aware of your 
context within the relationships graph. Context is the point in the graph from which a relationship 
is evaluated. Because the graph is never a cycle, each point along the graph offers a different 
perspective into your data.
Because FileMaker Pro does not permit you to create cycles within the relationships graph, any 
attempt to create a cycle causes FileMaker Pro to generate a new, uniquely named table 
occurrence. A new occurrence functions like any other occurrence in the graph and allows you to 
continue with your new relationship.
For more information about the relationships graph, see Help.

About match fields for relationships
When you create a relationship between tables, you choose one or more fields in each table as 
match fields. Match fields usually have common values. In a typical relationship, a record in one 
table will be related to records in another table that share a common match field value. 
For example, a Customers table and an Invoices table can each use the field Customer ID to 
uniquely identify each customer and purchase. If the two tables are related using Customer ID as 
the match field, a record in the Customers table can display a portal showing each invoice with a 
matching Customer ID, and in the Invoices table, each invoice with the same Customer ID can 
display consistent customer data.
The match fields used in a relationship can have different names. Match fields can be any field 
type except container or summary. 

Types of relationships
When you join two tables using a relationship, you establish criteria that FileMaker Pro uses to 
display or access related records.
Your criteria can be simple, such as matching a field in Table A with a field in Table B, or more 
complex. A more complex relationship definition will usually return a narrower set of related 
records. Examples of complex relationships include using multiple match fields on one or both 
sides of the relationship, comparing match fields using non-equal relational operators, or using 
calculated match fields.
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Single-criteria relationships

In a single-criteria relationship, data in one field is matched to data in another field.
For example, a record in either table is related to any record in the other table when the values 
TextFieldA and TextFieldB are the same.

Use a single-criteria relationship when you want to relate two tables based on a single common 
value, such as a serial number or an ID number. For example, a database has two tables: 
Customers, which stores names and addresses, and Contacts, which stores phone numbers, 
types of phone numbers (such as work, home, fax, and so on), and email addresses. The data is 
split between two tables because a single customer can have multiple phone numbers and email 
addresses. 
The tables have the following fields:

The Customer ID field is the match field in the relationship between the two tables. In the 
Customers table, the Customer ID field is set to auto-enter a serial number, giving each record in 
the Customers table a unique ID number. In the Contacts table, the Customer ID is a simple 
number field.

Table Field name Comment
Customers Customer ID Number field, auto-enter serial number; this will be the match 

field in the Customers table 

First Name Text field

Last Name Text field

Address1 Text field

City Text field

State Text field

Country Text field

Contacts Phone Number Text field

Phone Type Text field

Email Address Text field

Email Type Text field

Customer ID Number field; this will be the match field in the Contacts table 

Match field Match field
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Because the relationship is defined to allow the creation of related records in the Contacts table, 
the Customer ID number from a Customers record will be automatically inserted in the Customer 
ID field in the Contacts table in each new related record. This allows many records in the Contacts 
table to be related to a single record in the Customers table. 
You can then add a portal to the Contacts table on the Customer layout. When you enter a phone 
number or an email address in an empty portal row in the Customers table, FileMaker Pro creates 
a related record for that phone number or email address in the Contacts table.

Multi-criteria relationships

In a multi-criteria relationship, you increase the number of match fields, which increases the 
criteria that FileMaker Pro evaluates before successfully joining related records. In a multi-criteria 
relationship, FileMaker Pro compares the values from each match field on each side of the 
relationship in the order in which the fields appear. This is called an AND comparison; to match 
successfully, every match field must find a corresponding value in the other table.

In this relationship, both TextFieldA and NumberFieldA are match fields to TableB. A record in 
TableA with a TextFieldA value of Blue and a NumberFieldA value of 123 will only match those 
records in TableB where both TextFieldB and NumberFieldB have values of Blue and 123, 
respectively. If TextFieldA and TextFieldB have matching values, but NumberFieldA and 
NumberFieldB do not, no related records are returned by the relationship.
Use a multi-criteria relationship when you want to relate two tables based on more than one 
common value, such as a customer ID and a date.
For example, a catering equipment rental database has three tables: Equipment, a static table that 
stores equipment rental inventory; Customers, which stores customer names and addresses; and 
Catering Line Items, which stores a record of each equipment rental, including the equipment ID, 
the customer ID, and the event date. The purpose of this database is to track equipment rentals 
and display all rentals by a selected customer on a selected date.

Match field Match field

Match field Match field
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In this relationship, both Customer ID and Event Date are match fields to the Catering Line Items 
table. A record in the Customers table with a Customer ID value of 1000 and a Event Date value 
of 10/10/2014 will only match those records in the Catering Line Items table where both fields 
Customer ID and Event Date have values of 1000 and 10/10/2014, respectively. If Customer ID 
fields in both tables have matching values, but Event Date fields in both tables do not, no related 
records are returned by the relationship.
Although the database uses three tables, the multi-criteria relationship is between the Customers 
and Catering Line Items tables. These tables have the following fields:

Because the relationship is defined to allow the creation of related records in the Catering Line 
Items table, you will be able to enter catering information in an empty portal row, and 
FileMaker Pro will automatically create a related record for that catered event.

Relationships using comparative operators

In a comparative relationship, you use one or more of the following operators to compare match 
field values in the two related tables. The relationship returns related records when the 
comparison evaluates successfully, according to the criteria you establish. 

Table Field name Comment
Customers Customer ID Number field, auto-enter serial number; one of the match fields to the 

Catering Line Items table

Event Date Date field; the other match field to the Catering Line Items table

Catering Line Items Customer ID Number field; one of the match fields to the Customers table

Event Date Date field; the other match field to the Customers table

Equipment ID Number field

Relational 
operator Matches these records
= Values in match fields are equal

≠ Values in match fields are unequal

< Values in the left match field are less than values in the right match field

≤ Values in the left match field are less than or equal to values in the right match field

> Values in the left match field are greater than values in the right match field

Match fieldsMatch fields

Select to allow creation of related 
records in Catering Line Items table
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In this example, the Promotion Date fields in the Sales Promotions table and the Customers table 
are match fields. If a record in the Sales Promotions table has a Promotion Date value of 
12/11/2014, all the records in the Customers table with a Promotion Date value of 12/10/2014 or 
earlier are related to it. In the Customers table, if a record has a Promotion Date value of 
12/11/2014, all records in the Sales Promotions table with Promotion Date values of 12/12/2014 
or later are related to it.

Relationships that return a range of records

A relationship that returns a range of records is similar to a multi-criteria relationship, except that 
you use comparative operators to find records that are greater than one of your criteria and less 
than your other criteria. This type of relationship is commonly used to return records that fall 
between a range of dates or serial numbers.
For example, from within Table E you want to view all the records in Table F that have Date Field 
F values that are greater than Starting Date E values and less than Ending Date E.

This relationship returns those records from Table F that have a Date Field F value that is later 
than Starting Date E and earlier than Ending Date E.

≥ Values in the left match field are greater than or equal to values in the right match field

x All records in the left table are matched to all records in the right table, regardless of the values 
in the match fields

Relational 
operator Matches these records

Greater than relational operator

Match field Match field

Indicates that several different 
relational operators are used in 

this relationship

Match fields Match field

This relationship uses the 
greater than and less than 

relational operators
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For example:

Another example:

Self-joining relationships

A self-join is a relationship in which both match fields are defined in the same table. Define a self-
join to create relationships between records in the same table. Use a self-join in a portal on a 
layout of the current table to display a subset of data that is in the current table, such as all the 
employees of each manager.
When you define a self-joining relationship in the relationships graph, FileMaker Pro generates a 
second occurrence of the table upon which you are basing the self-join. FileMaker Pro does this 
to prevent the relationships graph from forming a cycle, which would make it impossible to 
evaluate the relationship.

This relationship returns related records in Table G when the value in Text Field G1 is the same 
as the value in Text Field G2.
For more information about the types of relationships, see Help.

Planning a relational database
For information about planning a relational database, see “Planning a database” on page 51.

Working with the relationships graph
Use the relationships graph to create, change, and view the relationships in your database file. 
The relationships graph lets you duplicate tables and relationships, resize and align tables, and 
add text notes. You can highlight tables that are connected to the selected table via a 1-away 
relationship, and you can highlight tables that have the same source table as the currently 
selected table. For more information, see Help.

If fields Contain values These related records are returned from Table F
Starting Date E 11/01/2014 11/14/2014 

11/27/2014
Ending Date E 12/01/2014

If fields Contain values These related records are returned from Table F
Starting Date E 12/01/2014 12/02/2014 

12/15/2014 
12/17/2014 
12/26/2014

Ending Date E 01/01/2015

Self-joining relationship

Match field Match field
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By default, the relationships graph displays all of the tables in your current database file. You can 
add tables from other FileMaker Pro files or external ODBC data sources, add more than one 
occurrence of the same table to the graph, or remove tables from the graph using the buttons at 
the bottom of the graph.

Note   When the table is from an external ODBC data source, the name of the table is typeset in 
italics in the relationships graph. To display information about the external data source, move the 
pointer over the arrow to the left of the table name.

Creating relationships
To create a relationship:

1. With the database open, choose File menu > Manage > Database. 

2. In the Manage Database dialog box, click the Relationships tab.

3. In the relationships graph, locate the two tables you will be using for this relationship. 
They can appear anywhere on the graph but they must be present on the graph in order to 
create the relationship. For self-joining relationships, locate the single table; FileMaker Pro will 
create the second table occurrence for you.

4. Click a field in one of the tables and drag to the corresponding match field in the other table.
Or, you can click  to open the Edit Relationship dialog box and create a relationship. 

5. Repeat step 4 for each match field you intend to use in this relationship.
For more information about match fields, see “About match fields for relationships” on 
page 112.

6. Click OK to save your changes and close the relationships graph.

Add a table

Create a relationship

Edit a selected object

Delete selected 
objects

Enlarge or reduce the 
view of the graph

Change the alignment 
of selected objects

Move the pointer to the 
arrow icon to display 

the names of the 
source table and 

source file

Click once to collapse 
all but the match fields. 
Click again to collapse 
all but the table name. 
Click again to return the 
table to its original size

Show page breaks

Display the Print Setup 
(Windows) or Page 
Setup (OS X) dialog box

Change the color of 
selected objects

Add a text note to the 
graph

Duplicate selected 
objects

Show 1-away tables or tables 
with the same source

Click to display or 
collapse a text note

Match fields are 
shown in 

italics in their tables

The relationships graph
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Changing relationships
After you have created a relationship, you can add or change match fields, change relational 
operators, and set options for creating, deleting, and sorting related records.

To change a relationship:

1. With the database open, choose File menu > Manage > Database. 

2. In the Manage Database dialog box, click the Relationships tab. 

3. In the relationships graph, locate the relationship to edit, and double-click the indicator line 
between the related tables to open the Edit Relationship dialog box.
Or, you can select the relationship in the graph and click  to open the Edit Relationship 
dialog box.

4. Edit tables and match fields for the relationship. 

To Do this
Change a match field Select the new match field and click Change.

Add a match field Select the new match field and click Add.

Change the relational 
operator

Select a new relational operator from the list and click Change.
See “Relationships using comparative operators” on page 115.

Duplicate a pair of 
relationship criteria 

Select the paired criteria from the list in the middle part of the dialog box and click 
Duplicate.

Delete a pair of relationship 
criteria

Select the paired criteria from the list in the middle part of the dialog box and click 
Delete. 

Select options for the 
tables in the relationship

Select the relational 
operator
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5. Select options for the relationship.

6. Click OK.

For more information about creating and editing relationships, see Help.

Summarizing data in portals
You can summarize data that’s in a related field displayed in a portal. The portal can contain 
records from a related table or from the same table (a self-join). 

To summarize data in portals:

1. Create a calculation field in the table in which you want the total to be displayed. 

2. For the calculation field, define a formula that includes an aggregate function for the type of 
summary calculation you want to perform. 
For example, if you are in the Invoices table and want to define a calculation to total the related 
values in the Price field of the LineItems table, use the formula Sum(LineItems::Price).

3. Place the calculation field on a layout of the table in which it is defined.
See “Placing and removing fields on a layout” on page 89.

Filtering records in portals
By filtering portal records, you can display different sets of records in a portal. 

1. Double-click the portal.

2. In the Portal Setup dialog box, select Filter portal records.

To Select
Add a related record (to the related table) 
whenever you enter data into a related field 
in a record of the current table. (See 
“Adding and duplicating records” on 
page 25.) 

Allow creation of related records in this table via this 
relationship. 
When this option is selected, entering data in a related field that has 
no corresponding related record creates a related record based on 
the match field in the current table.

Delete matching records (in the related 
table) whenever you delete a matching 
record in the current table. (See “Deleting 
records” on page 27.) 

Delete related records in this table when a record is deleted in 
the other table.
This option deletes related records even when you’re browsing a 
layout that doesn’t display the related records.

Sort related records. Sort records. Then, in the left list in the Sort Records dialog box, 
double-click the fields to sort. To change the order in which fields are 
sorted, drag fields in the right list into the order you want. Select 
other options, then click OK. 
Selecting this option does not affect the sort order in the related file.
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3. In the Specify Calculation dialog box, define a calculation that determines which portal records 
will be displayed.
For example, if you are working in an Invoices layout, in a portal that shows product records 
from a LineItems table, and want to display just the products with quantities greater than 1, use 
the formula If(LineItems::Quantity < 1; 0; 1).

4. Click OK.

Important   The results of summary fields, calculations, and find requests are based on the full set 
of related records, not just the records in a portal that are filtered. For example, if a portal is 
displaying a filtered subset of records, and a Total of summary field outside the portal summarizes 
these records, the summary field will total all related records, not just the displayed records.

For more information about filtering records in portals, see Help.

About lookups
A lookup copies data from another table into a field in the current table. After data is copied, it 
becomes part of the current table (and remains in the table from which it was copied). Data copied 
to the current table does not change automatically when the data in the other table changes, 
unless the data in the match field of the current table changes.
To establish a connection between tables for a lookup, you create a relationship. Then you define 
a lookup to copy data from a field in the related table into a field in the current table.
When you type a value in the match field of the current table, FileMaker Pro uses the relationship to 
access the first record in the related table whose match field contains a matching value. Next, it 
copies the value from the lookup source field into the lookup target field, where the value is stored. 
After a value is copied into the lookup target field, you can edit, replace, or delete it like any other 
value (because the lookup value belongs to the current table). You can also update data in the 
current table to match data that changes in the related table.

Creating lookups
To create a lookup:

1. Create a relationship for the lookup between the match field of the current table and the match 
field of the related table. See “Creating relationships” on page 118.

2. With the database open, choose File menu > Manage > Database. 

3. In the Manage Database dialog box, click the Fields tab. 

C235

Name

42.83.91.04Phone

ParisCity

C100

Name

555-3849Phone

VancouverCity

Current table

C200Customer ID

SmithName

Records in related table

Relationship

Lookup target field Lookup source field

C200Customer ID

SmithName

555-1234Phone

New YorkCity

Customer ID

Customer ID
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4. If your database contains more than one table, select the appropriate table from the Table list.

5. Select a text, number, date, time, timestamp, or container field from the list of existing fields, or 
define a new one.

6. Click Options (or double-click the field name). 

7. In the Options for Field dialog box, click the Auto-Enter tab, then select Looked-up value. 

8. In the Lookup for Field dialog box, choose the table the lookup will start with, and the table from 
which the value will be copied. 

9. Select the field from which the lookup value will be copied.

10. Select options for the lookup.

11. Click OK.

12. Repeat steps 5–11 for each additional field for which you want to define a lookup.

Select To specify
Starting with table The table the lookup will use as its starting point in the relationships graph

Lookup from related table The related table from which the related data will be looked up

To Do this
Specify an action when values in the 
match fields do not match exactly 

For If no exact match, then, select an option to copy no value, copy 
the next lower or next higher value that’s in the lookup source field, or 
enter a fixed value to be used instead

Prevent null (empty) data in the lookup 
source field from being copied to the 
lookup target field 

Select Don’t copy contents if empty. (Clear this option to allow empty 
data to be copied.)

Select an option for 
non-equal data in 
match fields

Select the lookup 
source field

Select the lookup’s 
starting point 

When selected, prevents null data 
from being copied

Choose the related 
table for the lookup
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Editing lookups
To edit a lookup:

1. With the database open, choose File menu > Manage > Database. 

2. Click the Fields tab. 

3. If your database contains more than one table, select the appropriate table from the Table list.

4. Double-click the lookup target field. 

5. In the Options for Field dialog box, click the Auto-Enter tab. 

6. Be sure Looked-up value is selected and click Specify.
To stop or suspend using a lookup, clear Looked-up value.

7. Make your changes.

8. Click OK.

For more information about creating and editing lookups, see Help.



Chapter 5  
Sharing and exchanging data

This chapter explains the basics of how you can share FileMaker Pro databases:
1 FileMaker Network sharing: You can share FileMaker Pro databases on your network, which 

allows multiple FileMaker Pro and FileMaker Go users to access and use the same database 
file simultaneously.

1 Importing and exporting data: You can exchange information between FileMaker Pro and 
other applications by importing and exporting data. For example, you can import data that is in 
another database or spreadsheet program, or export address data in order to create 
personalized form letters with a word processing program.

1 Recurring import: You can set up a FileMaker Pro file to automatically update data imported 
from another application, such as Microsoft Excel.

1 Accessing data from external data sources: You can access information stored in other 
FileMaker Pro files and external SQL databases that use ODBC technology to share data. This 
allows you to work with information stored in external databases and combine external data with 
information stored in your file. When you access data from an ODBC database, you can use 
supplemental fields in your FileMaker Pro file to perform calculations and summary operations 
on the data without changing the schema of the external file.

1 Publishing FileMaker Pro layouts: If you have FileMaker Server, you can use 
FileMaker WebDirect to quickly and easily publish layouts from your FileMaker Pro databases 
in a web browser. 

Note   See Help for detailed, comprehensive information and step-by-step procedures about 
using FileMaker Pro. See FileMaker WebDirect Guide for information about publishing databases 
on the web.

Sharing databases on a network
If your computer is connected to a network, you and other Windows and OS X FileMaker Pro and 
FileMaker Go users can use the same database file simultaneously. 
FileMaker Pro Network sharing supports the sharing of files with up to 5 concurrent users (not 
including the host). FileMaker Go clients are included in the limit of 5 users. To support more users 
and web publishing technologies such as XML, PHP, and FileMaker WebDirect, use 
FileMaker Server.

Important   Your FileMaker Pro licensing agreement requires that you pay for a license for each 
separate computer on which the FileMaker Pro application is installed or run. The software license 
may not be shared or used concurrently on different computers. Please read the software license 
for complete terms and conditions.
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The first person to open a shared file is the host. Any user who opens a shared file after the host 
is a client.

Once a shared file is open, the host and clients have access to the same information, and all 
changes to the file appear in each user’s window. 
Modifications to the data made by any user are saved in the shared file. The shared file is saved 
on the disk where the file resides.
Sort orders, find requests, import and export field orders, and print setups are specific to each user.

Enabling file sharing and hosting files
Because many FileMaker Pro commands are processed on the host machine, you will see better 
performance if you host your shared files from the fastest available computer. The file you’re hosting 
must be on the hard disk of your computer. Remotely hosting a file stored on another computer or 
server is not supported, as it might compromise data integrity and will result in poor performance. 

To turn on network file sharing for all open files: 

1. Open the FileMaker Pro file(s) you want to share.

Note   To enable or change a file’s sharing status, you must open it with an account that has 
Manage Extended Privileges access privileges. For more information, see “Accounts, privilege 
sets, and extended privileges” on page 138.

2. Choose File menu > Sharing > Share with FileMaker Clients.

The host opens the file

Clients open connections to the shared file
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3. In the FileMaker Network Settings dialog box, for Network Sharing, click On.
In the TCP/IP Address box, you see the TCP/IP address of your system. 

4. Select the file(s) to be hosted from the list of Currently open files.

5. Set the level of network access for the file(s). 

6. Click OK. 
The open files are now hosted.

Important   You must keep your shared file(s) open to make them available to clients. 

To Select
Provide access to all FileMaker Pro and 
FileMaker Go users on your network 

All users.

Limit network access to users based on their 
privilege set

Specify users by privilege set, then click Specify.
In the “Specify users by privilege set” dialog box, select the 
privilege sets you want to have network access.

Prevent any access via FileMaker networking No users.

Click to enable 
network sharing

Select level of 
network access for 
the selected file(s)
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Opening shared files as a client
FileMaker Pro databases shared via TCP/IP can be opened remotely using the list of local hosts, the 
IP address of the host machine, or the DNS name of the host machine (if one has been defined). 

To open a shared file as a client:

1. Choose File menu > Open Remote.

2. In the Open Remote File dialog box, select View for a list of hosts.

3. To see the available files from a host, select the host. In the Available Files list, select the file 
you want to open. 

Tip   To narrow the list of available files, type a few characters in the Filter text box. Only 
filenames containing the characters you type are displayed in the list.

Or, for Network File Path, type the network path; for example:
For IPv4: fmnet:/<host IP address>/<filename>
For IPv6: fmnet:/[<host IPv6 address>]/<filename>

4. Click Open.
You might be required to enter an account name, password, and domain name (Windows only), 
depending on how file sharing is configured on the host. 
If the network is very busy, the file might not be listed. To check the network for a longer period 
of time, hold down the Ctrl key (Windows) or Option key (OS X) as you click an item. 

For information about marking remote files as favorites and accessing favorite files, see Help.

Note   When a file you are opening is hosted, you may see an icon in the lower-left corner of the 
FileMaker Pro window. This icon indicates the security level of the connection to the host. A  
icon means the connection is encrypted (SSL). A  icon means the connection is encrypted 
(SSL) and verified with a certificate. For more information, see your database administrator. 

Choose To display
Favorite Hosts Hosts you previously added as favorites

Local Hosts FileMaker Pro hosts on your TCP/IP subnet

Hosts Listed by LDAP FileMaker Pro hosts available through the specified LDAP server
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Limitations on changes to shared files

Although it is possible for multiple users to make changes in the same shared file at the same time, 
there are limits to the types of simultaneous changes that are permitted. The following table 
describes the types of changes you can and cannot make to shared files.

Opening shared databases remotely using a URL
The FileMaker Pro installer registers FMP as an internet protocol. This enables you to open a 
shared database using a URL. You can also run a script in the shared file using a URL.
Clients can use a browser to access shared databases by entering the URL of the shared file on 
the host machine in a browser’s address area. 

To identify the URL for the shared database on the host machine and send it to a client user:

1. In the shared file on the host machine, choose File menu > Send > Link to Database.
FileMaker Pro opens an email message in your default email application that contains the URL 
for the current database, plus client connection requirements.

2. Address the email message to the client user, then send the message. 

To open a shared database on a client machine using a URL:

1. Launch a web browser on the intended client machine. 

Database change Limitation
Data in layouts and records Two people can’t edit the same record at the same time.

Data in records from external 
ODBC data sources

Two people can edit the same record at the same time.
If two users edit the same record simultaneously, FileMaker Pro posts an alert when 
either user attempts to commit changes. The alert provides a user with a choice, 
allowing changes to be committed (overwriting any changes the other user might 
have made), returning to the record without committing changes, or reverting the 
record to the state it was when the editing session began.

Layouts and layout elements Two people can’t modify the same layout at the same time.

Value lists Two people can’t modify or define the same value list at the same time.
One person can edit a value list while another person is using it in Browse mode or 
Find mode.

Scripts Two people can’t modify or define the same script at the same time.
One person can edit a script while another person is using it.

Tables, fields, relationships 
(database schema)

Two people can’t modify any of these elements at one time.

Data sources Two people can’t modify or define the same data source at the same time. 
One person can edit a data source reference while another person is using the 
external file.

Accounts and privileges Two people can’t modify or define accounts and privileges at the same time.
One person can create or modify an account and privileges while another person is 
using it. 
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2. Enter the URL of the host machine into the browser’s address area using the format:
fmp://[[account:password@]netaddress]/databasename

Optional parameters are indicated by square brackets (“[ ]”).

3. Press Enter (Windows) or Return (OS X).

Examples

fmp://My%20Addresses
fmp://192.168.10.0/My%20Addresses.fmp12
fmp://[2001:0DB8:85A3:08D3:1319:8A2E:0370:7334]/My%20Addresses.fmp12
fmp://MyAccount:MyPassword@192.168.10.0/My%20Addresses.fmp12

Closing a hosted file
Before a shared file can be closed by a host, all clients must close the file. FileMaker Pro allows 
you to prompt networked clients to close the shared file when you do one of the following: close 
the file, change the sharing conditions for the file, exit FileMaker Pro, or perform a task that 
requires all clients to close the file. If a client does not respond to your request to close a shared 
file within 30 seconds, FileMaker Pro will attempt to close the shared file on the client’s machine.

To close a hosted file:

1. On the computer hosting the file, choose File menu > Close.

2. If any clients have the shared file open, you see a dialog box listing those clients. Click Ask to 
send a message to these clients requesting that they close the file.

3. Clients see a dialog box requesting that they close the file. 

For more information about sharing files over a network, see Help.

Sharing files with FileMaker Go clients
FileMaker Go lets you work with FileMaker Pro databases on an iPad, iPhone, or iPod touch. You 
work with data interactively: when you change data on an iOS device, the data is updated on the 
host computer, and vice versa.
Build databases using FileMaker Pro. Share them using FileMaker Pro or FileMaker Server. Then 
use FileMaker Go to work with the data on a device. To tailor databases for use with FileMaker Go, 
see FileMaker Go Development Guide, available at http://www.filemaker.com/documentation.

Uploading files to FileMaker Server
You can use FileMaker Pro to transfer database files to FileMaker Server. Before you can upload 
files, you must have the account name and password for the server administrator or for a group 
administrator that has the privilege to perform actions on databases. For more information about 
uploading files to FileMaker Server, see FileMaker Server Help.

If FileMaker Pro
Clients click Cancel Waits for those clients to close the file

Clients click Close Now Closes the shared file on the client’s computer

Clients do nothing Attempts to close the file after 30 seconds, if it can be closed safely
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Importing and exporting data
You can exchange information between FileMaker Pro and other applications by importing and 
exporting data. You can: 
1 import data into an existing FileMaker Pro file, either into a new table or into an existing table
1 convert data from other applications to new FileMaker Pro files
1 export data for use in other applications

Saving and sending data in other formats
You can save FileMaker Pro data as a Microsoft Excel worksheet or a PDF file, allowing you to 
give your record data to users who don’t have FileMaker Pro.
FileMaker Pro lets you email the Excel worksheet or PDF file when you save it. You can also 
create scripts to save records as Excel or PDF.
In order to save files as Excel, you need the Allow Exporting Access privilege. To save files as PDF, 
you need the Allow Printing Access privilege.

Note   The saved file will only include fields that are on the layout when you perform the save. If 
you want to include other fields (for example, fields on tab panels that are not in front), use the 
Export Records command instead of Save/Send Records As.

Sending email messages based on record data
You can use FileMaker Pro to send one message, or multiple messages, to one or more 
recipients. Generated email is sent using your default email application or directly through SMTP 
(Simple Mail Transfer Protocol, a set of criteria for sending and receiving email). You can enter 
values, or use values from fields or calculations. You can also create scripts to send email. 

Supported import/export file formats
Every application stores its data files in its own file type or file format. Most applications can also 
exchange information in certain other formats. 
FileMaker Pro can import and/or export files in these formats, followed by their filename 
extensions: Microsoft Excel (.xlsx), tab-separated text (.tab, .txt), comma-separated values (.csv, 
.txt), FileMaker Pro 12 (.fmp12), Merge (.mer), HTML table (.htm), and XML (.xml). You can also 
import Bento data into FileMaker Pro. If you’re exchanging data with another program, check the 
documentation that came with that program to determine a common intermediary file format that 
both FileMaker Pro and the other program support. 
Most file formats support data conversion only and do not import or export formatting such as font, 
size, style, and color.
For information about supported file formats for importing and exporting, see Help.

Setting up recurring imports
You can set up a FileMaker Pro file to automatically update data imported from another 
application, such as Microsoft Excel. A recurring import occurs automatically the first time you view 
the layout containing the data from the external file. Later, you can run a script to update data.

Keep the following points in mind:
1 Data imported via recurring import is read-only in FileMaker Pro. 
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1 When you set up recurring imports, FileMaker Pro creates a new table for the imported data and 
a new layout to display the data. You can customize the layout in Layout mode later, if you wish.

1 To set up recurring imports, you must open a file with an account that is assigned the Full Access 
privilege set. For information about privilege sets, see “Creating accounts” on page 145.

To set up recurring imports:

1. Create a new file, or open the file in which you want to set up recurring imports. See “Creating 
a FileMaker Pro file” on page 55 or “Opening files” on page 16.

2. In Browse mode, choose File menu > Import Records > File.

3. For Files of type (Windows) or Show (OS X), select the type of file you want to import, then 
locate and select the file containing data to import.

4. Select Set up as automatic recurring import, then click Open.
The path of the file you selected appears in the Recurring Import Setup dialog box.

5. To skip importing column headings, select Don’t import first record (Contains field names).

6. Accept the default layout name or type a new name for the layout that FileMaker Pro will create 
to display the imported data.

7. Accept the default script name or type a new name for the script you can use for updating data 
manually.

8. Click OK.

9. If you are importing data from an Excel file, you can import data by worksheet or by named range.

10. The new layout appears in Browse mode in Table View. You can update data, add an empty 
record to the file, or add a new field to the layout.

For more information about setting up recurring imports, see Help.

To Do this
Import data by worksheet Select Display worksheets, select the worksheet you want 

to import, then click Continue.

Import data by named range, one worksheet or 
named range per layout

Select Display named ranges, select the named range you 
want to import, then click Continue.

To Do this
Update data Click the script button at the top of the new layout.

Add an empty record to the file (appears as a 
blank row at the bottom of the table)

Click + at the bottom of the table.

Add a new field to the layout (appears as a blank 
column on the right in the table)

Click + in the table heading.
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ODBC and JDBC
You can exchange FileMaker Pro data with ODBC- and JDBC-compliant applications. For 
example, you can chart FileMaker Pro data in Microsoft Excel. 

Methods of importing data into an existing file 
When you import data into an existing file, you can:
1 add new records to an existing table
1 create a new table from imported data
1 update existing records in an existing table
1 update matching records in an existing table

Important   The import options that update existing records and update matching records both 
overwrite existing data during the import process and cannot be undone. To safeguard your data, 
choose File menu > Save a Copy As to make a backup of the file before you perform an import 
that updates records.

The file you import records from is the source. The file you import records to is the target. 

About adding records 
When you add records, you import all records from the source file to the target file or table. A new 
record is created in the target file for each importable record in the source file.

About updating existing records 
With this option, you replace data in your file with data from the source file. For each field you 
import into, data from the first importable record (or row of data) in the source file overwrites fields 
in the first record in the target file. Data from the second importable record (or row of data) in the 
source file overwrites fields in the second record in the target file, and so on. When you replace 
data, FileMaker Pro doesn’t examine or compare the data in the files. 
You can choose whether to replace or not replace data on a field-by-field basis.
Records in the target file are replaced with the same number of records from the source file. If 
there are more importable records in the source file, data from the extra records in the source file 
will not be imported unless you also choose Add remaining data as new records. If there are 
more records in the target file, data in the extra records in the target file will not be replaced.

What do you want to do? How do you do it? See
Use FileMaker Pro as a data 
source/share FileMaker Pro data

1. ODBC and JDBC
2. SQL queries

FileMaker ODBC and JDBC 
Guide and FileMaker SQL 
Reference

Use FileMaker Pro as an ODBC 
client/access ODBC data

1. Interactively via the relationships graph
2. One-time, static via ODBC import (or 
File menu > Open), also Import Records 
script step, Execute SQL script step

“Working with external data 
sources” on page 136 and Help
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About updating matching records 
You can update matching records and fields in your target file with data from another file. For 
example, you might have a copy of a database on your desktop computer and another copy on your 
laptop computer. You can update the file in your office with the changes you make on the road.
You determine which records in the source file update which records in the target file by choosing 
one or more match fields in each file. If data in the match field(s) of a record in the target file 
matches data in the match field(s) of a record in the source file, the record in the target file will be 
updated with data from the source file.
Match fields must uniquely identify each entity in your database. For example, in a database of 
people, you could use one match field such as Employee Number, or multiple match fields such 
as Last Name, First Name, and Phone Number. Using Last Name alone might identify more 
than one person, so it isn’t a good match field to use by itself. 
You also specify the fields you want to import. The contents of all fields you select to import, in all 
matching records, will overwrite data in the target file, even if the field in the source file is blank.
When the target file contains a found set, only the found records are updated. (If the source file is 
another FileMaker Pro file, you can also import only from a found set.)
The following example shows how a record in a target file appears before and after being updated 
by a matching record in a source file.

About the importing process
The basic steps for importing records are:

1. Make a backup copy of the target file you’re importing into.

2. If the source file is a FileMaker Pro file, perform a find so that the found set in the current window 
contains only the records you want to import.

3. Open the target file, and if it has multiple tables, select a layout that shows records from the 
table you want to import data into.
The layout doesn’t have to display all the fields in the table. You will be able to specify the fields 
that you want to import to in the Import Field Mapping dialog box.

4. If you’re updating existing or matching records, make sure the found set in the target file 
contains only the records you want to change or update.

(OS X) or –> (Windows) indicates to import the field

–>

–
–>
–>
–>
–

–>
–

(OS X) or = (Windows) indicates a match field

123-456-7890

Source file

John
Q
Smith
456 New Rd.
Newtown
USA

123-456-7890

Target file

John

Smith
123 Main St.
Anytown
USA
3/3/2015
408-555-6789

123-456-7890

After updating

John
Q
Smith
456 New Rd.
Newtown
USA
3/3/2015

Before updating matching records

Target file
=

(OS X) or – (Windows) indicates not to import the field



Chapter 5  |  Sharing and exchanging data 134

5. Choose File menu > Import Records > File, and choose the name of the file that contains the 
data you want to import (the source file).

6. In the Import Field Mapping dialog box, if necessary, select a table from the Source list.

7. Accept the table shown in the Target list, or select New Table to create a table with the same 
schema as the source table.

8. Select the type of import to perform. See “Methods of importing data into an existing file” on 
page 132.

9. Map the fields in the source file to the fields in the target file. 

Converting a data file to a new FileMaker Pro file
You can convert a data file from another application into a new FileMaker Pro file. The converted 
file will contain:
1 The data from the file or source you convert 
1 Two layouts for displaying the data
1 Converted field names if they are available in the file or source you convert. Otherwise, field 

names are generic: f1, f2, f3, and so on.
1 Converted field types if they are available in the file or source you convert. Otherwise, all fields 

are text fields.

To import data into a new file:

1. In the source application, save the data you want to import in a file type that FileMaker Pro 
supports. See “Supported import/export file formats” on page 130.

2. Choose File menu > Open.

3. In the Open File dialog box, for Files of type (Windows) or Show (OS X), specify the type of 
file, choose the file to convert, then click Open.

4. If you see the First Row Option dialog box, choose whether the first row of data contains field 
names or the first record of data, then click OK.

Fields in the 
source file

Fields in the 
target file

Arrows show that data will 
import into the fields at right

Select an import action

Select a table to 
import from

 indicates match fields 

Import to the current 
table or a new table
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5. If you’re converting a Microsoft Excel spreadsheet and the Specify Excel Data dialog box 
appears, choose a worksheet or named range from the workbook file, then click OK.

6. In the Create a New File Named dialog box, type a name for the new file, choose a location, 
then click Save.
FileMaker Pro converts the data to a FileMaker Pro file and displays the file.

For more information about importing data, see Help.

About the exporting process
You can export FileMaker Pro data to a new file, then open it in another application.

The basic steps for exporting records are:

1. Open the FileMaker Pro file and display a layout that shows the records you want to export.

2. Find and sort the records to export. See “Finding records” on page 31 and “Sorting records” on 
page 43.

3. Choose File menu > Export Records.

4. In the Export Records to File dialog box, type a name and choose a location for the exported 
file, and choose a file type.

5. In the Specify Field Order for Export dialog box, select how you want FileMaker Pro to export 
the data.

6. If necessary, choose the character set you want the exported file to use. 

7. Select whether or not to apply the current layout’s formatting to the exported data. 

For more information about exporting data, see Help.

To export Choose
A field on the current layout Current Layout (LayoutName) from the table list, then double-click a field in 

the list

A field in the current layout’s 
table

Current Table (TableName) from the table list, then double-click a field in the list

Select fields 
from this list

Select whether or not to 
apply formatting 

FileMaker Pro exports 
these fields

To export related fields, select 
the related table from the list
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Working with external data sources
You can define data sources in a FileMaker Pro file to access data from:
1 other FileMaker Pro files
1 SQL databases that use ODBC technology for sharing information

When you define data sources in FileMaker Pro files, current data from external databases is displayed 
in your files. You can use FileMaker Pro to add, edit, delete, search, and sort data in the external files.
The following procedures provide an overview of how to access data in external FileMaker Pro 
files or external ODBC data sources. For detailed information on accessing external data sources, 
see Help.

Working with external FileMaker Pro files

To set up a file to access data from another FileMaker Pro file: 
1 Add tables from other FileMaker Pro data sources to the relationships graph in the current 

FileMaker Pro file.
1 Add fields to layouts to display data from the other FileMaker Pro file. 

Working with ODBC data sources

To set up a file to access data in supported ODBC data sources:
1 Install and configure an ODBC driver for the external data sources you want to access.
1 On the computer that hosts the current FileMaker Pro file, define a system Data Source Name 

(DSN) for each ODBC data source you want to access.
1 Set options for the ODBC data sources you want to access (for example, whether users are 

prompted for a user name and password).
1 Add one or more tables from the ODBC data source to the relationships graph in the current 

FileMaker Pro file.
1 Add fields to layouts in the FileMaker Pro file to display external data.
1 Optionally, add supplemental fields to external tables and layouts to display calculation and 

summary results based on data stored in external ODBC data sources.

Publishing databases on the web
If you have FileMaker Server, you can use FileMaker WebDirect to quickly and easily publish 
layouts from your database on the web. You don’t need to install additional software—anyone with 
compatible web browser software and access to the Internet or an intranet can connect to your 
FileMaker WebDirect solution to view, edit, sort, or search records, if you give them access 
privileges. With FileMaker WebDirect, data in the web browser updates automatically as 
FileMaker Server pushes data to the web browser. 
For more information, see FileMaker WebDirect Guide.



Chapter 6  
Protecting databases

This chapter describes the basics of how to restrict what users can see and do in a FileMaker Pro 
file. You’ll learn about:
1 planning security for a file
1 viewing and creating user accounts and passwords
1 viewing and creating privilege sets
1 viewing extended privileges
1 authorizing other files to access your files 
1 taking measures to secure your database solution, and your operating system, network, and 

hardware
1 backing up databases and other files
1 installing, running, and upgrading antivirus software

Note   See Help for detailed, comprehensive information and step-by-step procedures about 
using FileMaker Pro.

Although your operating system includes file security features, you should use FileMaker Pro 
access privileges as the fundamental way to control access to and protect the security of your 
database files.
For information about how security settings in older databases convert to the current version of 
FileMaker Pro, see “Converting databases from FileMaker Pro 11 and earlier” on page 154 and Help. 

Protecting databases with accounts and privilege sets
You can limit what users can see and do in a database file. You can restrict:
1 Data access: Make particular records or fields from individual tables view-only, or hide them 

completely.
1 Layout access: Prevent users from modifying layouts in Layout mode.
1 Access to value lists and scripts: Prevent users from accessing and modifying value lists and 

scripts, and from running scripts. 
1 Access to file sharing: Individually enable file sharing via the FileMaker Network, ODBC and 

JDBC, and FileMaker WebDirect.
1 Outputting data: Prevent users from printing or exporting data.
1 Menu access: Make only a limited set of menu commands available.
You restrict what users do in a file by requiring them to enter an account name and password when 
they attempt to open a file. The account name and password they enter determines which privilege 
set will be used and the privilege set limits what they can do in a file. For more information about 
accounts and privilege sets, see the following section.
You can define privileges in a shared file while clients are using it. Any privilege changes that affect 
a current client do not take effect until the client closes and reopens the file.
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The privileges that you set up apply to a single file only and all database tables within that file. If 
your database solution consists of multiple files that you want to protect, you may want to combine 
all of these files into one multi-table file. Then you can define privileges in only a single file to 
manage access to the entire database solution. If you don’t want to combine the files into one file, 
then you should define privileges in each file that contains items you want to protect.

Important   If you create a relationship in one file that references a table in another file, you cannot 
manage access privileges for the related table in the first file. The privileges defined in the other 
file control access to that table.

Accounts, privilege sets, and extended privileges
This section describes FileMaker Pro accounts, privilege sets, and extended privileges. 
For more information on sharing data, see chapter 5, “Sharing and exchanging data.” 

Accounts

Accounts authenticate users who are attempting to open a protected file. Each account specifies 
an account name and usually a password. Any user that cannot specify valid account information 
won’t be able to open a protected file.
Each database file contains two predefined accounts: Admin and Guest. For more information, 
see “About the predefined accounts” on page 140.

You may want to create an account for every individual who accesses a file, or you may want to 
create a small number of accounts that are shared among many individuals, such as a “Marketing” 
account and a “Sales” account.
1 Create accounts for individuals when it is necessary to verify the identities of particular users 

and you want to manage access at an individual level.
1 Create shared accounts when you want fewer accounts to maintain and you are less concerned 

about managing individual access to the database file.

If you host files on FileMaker Server, you can create External Server accounts that obtain 
authentication information from an authentication server such as an Apple Open Directory or 
Windows Domain. For more information, see “Creating accounts that authenticate via an 
external server” on page 146.

Privilege sets

A privilege set specifies a level of access to a database file. Each database file contains three 
predefined privilege sets for common types of access levels: Full Access, Data Entry Only, and 
Read-Only Access. When you create a privilege set, there are many options available that you 
can use to limit database access, such as which layouts are viewable, which menus are available, 
and whether printing is permitted. Privilege sets can also restrict access to records or fields from 
particular tables within a file. Each account is assigned a privilege set, which determines the level 
of access when someone opens a file using that account.
You can create as many privilege sets as you need to define the types of access you want to permit 
to a file. For more information about privilege sets, see “About the predefined privilege sets” on 
page 140.
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Extended privileges

Extended privileges determine the data sharing options that are permitted by a privilege set, such 
as whether a privilege set permits users to open a shared file or view a database in a web browser.
The following table lists the default extended privileges that are available. (FileMaker as well as 
third-party developers may define additional extended privileges to manage access for other 
software products designed to work with FileMaker Pro or FileMaker Server.)

Note   FileMaker Pro no longer supports the fmiwp extended privilege. However, opening 
database files created in versions of FileMaker Pro earlier than version 13 that use the fmiwp 
extended privilege does not remove the extended privilege from the privilege sets it is assigned to. 

When a user attempts to open or access a protected file using one of the above methods, the user 
will be prompted to provide account information. If the privilege set for the account does not permit 
the type of extended privilege access the user is requesting, the user will get an error indicating 
that they cannot access the file.
All extended privileges except fmreauthenticate10 are disabled by default, even in the Full Access 
privilege set.
Enabling extended privileges only makes it allowable for certain privilege sets to access shared 
data. To actually access the shared data, you must also set up sharing for the type of access that 
you want. For more information on extended privileges, see “Viewing extended privileges” on 
page 148.

Keep the following points in mind:
1 If you are hosting a FileMaker Pro database, the database must include at least one of the access 

extended privileges. If you upload a database to FileMaker Server and if no sharing is enabled, 
the Database Server enables fmapp for the Full Access privilege set when the database is 
opened. If you enable only the fmwebdirect extended privilege for sharing via 
FileMaker WebDirect and don’t enable fmapp, then users can’t access the file with FileMaker Pro.

1 Keywords for extended privileges that begin with “fm” are reserved by FileMaker.

Keyword Extended privilege Determines if a privilege permits
fmwebdirect Access via 

FileMaker WebDirect
Accessing a database file from a web browser via 
FileMaker WebDirect.

fmxdbc Access via ODBC/JDBC Accessing a database file from another application via 
ODBC or JDBC.

fmapp Access via FileMaker Network 
and Server Side Scripting

Opening a networked shared file (either a file hosted by 
FileMaker Pro or FileMaker Server).

fmreauthenticate10 Require re-authentication after 
the specified minutes in 
sleep/background - Go only

Accessing a file in FileMaker Go without having to re-login 
after file hibernation or after using a different app. The 
default time is 10 minutes; maximum time is 10080 minutes 
(one week) (FileMaker Go only).

fmxml Access via XML Web 
Publishing - FMS only

Accessing a database file from a web browser or other 
application via XML web publishing (FileMaker Server only).

fmphp Access via PHP Web 
Publishing - FMS only

Accessing a database file from a web browser or other 
application via PHP web publishing (FileMaker Server only).
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About the predefined accounts
Each database file contains two predefined accounts: Admin and Guest.

Admin account

The Admin account is assigned the Full Access privilege set, which permits access to everything 
in a file. The Admin account is not assigned a password. In files for which privileges are not set 
up, the file options are set up to automatically log in to the file using the Admin account.
The Admin account is fully editable. You can rename it, assign it a password, or make the account 
inactive. You can even delete the Admin account; however, you must assign the Full Access 
privilege set to at least one other active account.

Important   Don’t forget the account name and password that is assigned to the Full Access 
privilege set. If necessary, write it down and store it in a secure place. If you lose or forget this 
account name and password, you may not be able to access the file.

Guest account

The Guest account permits users to open a file without specifying any account information. The 
Guest account is not assigned a password. By default, the Guest account is assigned the Read-
Only Access privilege set, but you can assign any privilege set you want to the Guest account.
Initially, the Guest account is inactive, which disables the guest option in the password dialog box 
and prohibits users from opening files as a guest. You can enable the Guest account to permit 
guest access.
The Guest account is not fully editable. You cannot delete the Guest account, change the Guest 
account name, or assign it a password.

About the predefined privilege sets
Every new database file contains three predefined privilege sets.
1 Full Access: permits accessing and changing everything in the file
1 Data Entry Only: permits viewing and entering of data only
1 Read-Only Access: permits viewing but not changing data

Note   The Read-Only Access privilege set permits write access to all global fields. To create a 
privilege set in which global fields and all record data are view-only, you can duplicate the Read-
Only Access privilege set and change Records from Custom privileges to View only in all 
tables.

You cannot change or delete these predefined privilege sets, except to enable or disable extended 
privileges for them. You can either use them as is, or duplicate them and then modify the duplicate 
copies.
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The following table summarizes the properties of these privilege sets.

You must have Allow Printing privileges to save records as a PDF file. You must have Allow 
Exporting privileges to export records as a Microsoft Excel worksheet. For more information about 
saving records as PDF or Excel files, see “Saving and sending data in other formats” on page 130.

Note   The Full Access privilege set is the only one that permits access to the Manage Database 
and Manage External Data Sources dialog boxes in order to modify fields, tables, relationships, 
and data sources. It is also the only privilege set that permits changing accounts and privileges. 
Because you cannot enable these privileges in any other privilege set, any user that wants to 
make database definition changes or privileges changes must open the file with an account that 
is assigned the Full Access privilege set.

At least one active, FileMaker authenticated account in each file must be assigned the Full Access 
privilege set. An error message will appear if you edit accounts so that no active account is 
assigned the Full Access privilege set.

Planning security for a file
A new FileMaker Pro file is initially unprotected. Whenever the file opens, it automatically logs in 
the user with the Admin account, which is assigned the Full Access privilege set.
1 If you simply want to keep someone else from opening a database file on your computer, you 

can password-protect the file. For more information, see “Password-protecting a file” on 
page 143.

Privilege
Full Access  
privilege set

Data Entry Only 
privilege set

Read-Only 
Access 
privilege set

Records (in all tables) create, edit, delete create, edit, delete view only

Layouts all modifiable view only view only

Value lists all modifiable view only view only

Scripts all modifiable and 
executable

all executable only all executable only

Extended Privileges all off, except 
fmreauthenticate10

all off, except 
fmreauthenticate10

all off, except 
fmreauthenticate10

Allow printing on on on

Allow exporting on on on

Manage extended privileges on off off

Override data validation warnings on off off

Disconnect user from FileMaker Server 
when idle

off on on

Allow password modification on on on

Password change number of days off off off

Minimum password length off off off

Available menu commands All All All
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1 If you need to share a database file with others and provide varying levels of file access to 
different users, you need to plan the security for the file. Consider listing the types of users and 
their privileges: 

* You can provide limited access to some features, for example deleting records, by using record-
by-record privileges. For more information on record-by-record privileges, see Help.
You can additionally protect a file by requiring authorization of any file that attempts to access its 
tables, layouts, value lists, and scripts. For more information, see “Authorizing access to files” on 
page 148.

To plan the security for a shared file: 

1. Determine the privilege sets that you need for the file.
Make a list of the areas of the file that you want to protect, such as particular tables, fields, 
records, layouts, value lists, and scripts. Plan the number of privilege sets you need to enforce 
the varying levels of file access that you require.

2. Determine whether you need individual accounts for each user, or group accounts that multiple 
users can share.

3. Decide if you want to enable the Guest account, which permits users to open the file without 
specifying account information.

4. Create the privilege sets that you need in the file.

5. Determine if you need to enable any extended privileges for certain privilege sets.
Don’t enable extended privileges unless they’re needed.

6. Create the accounts you need in the file, and assign the appropriate privilege set to each account.
For more information, see the next section. If you’re using the Guest account, assign a privilege 
set to it as well. Otherwise, disable the Guest account.

7. Open the file using different accounts and test each privilege set that you created. Make sure 
the restrictions work the way you want, and make any needed corrections to your privilege sets.

8. Optionally limit other files from accessing the schema of your file by using the File Access tab. 
For more information, see “Authorizing access to files” on page 148.

Managers Marketing Sales HR Legal Guests

View records Yes Yes Yes Yes Yes Yes

Create records Yes Yes Yes Yes No No

Edit records Yes Yes Yes Yes No No

Delete records Yes Limited* Limited* Yes No No

Modify scripts Yes Limited* No Yes No No

Execute scripts Yes Yes Yes Yes Yes No

Modify value lists Yes No No No No No

Menus All Editing only Editing only All Minimum Minimum
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Password-protecting a file
If you have a non-shared database file on your computer and you want to prevent others from 
opening it, you can password-protect the file.
After password-protecting a file, you will be prompted to enter an account name and password 
every time you open the file. Anyone who does not know this account information will not be able 
to open the file.

To password-protect a file:

1. Make the following changes to the accounts in the file:
1 Edit the Admin account so that it has a different account name, a password, and uses the 

Full Access privilege set. 
1 Make sure the Guest account is inactive.
1 Delete any other accounts in the file or make them inactive.

2. If necessary, edit the Full Access privilege set to allow yourself any extended privileges you may 
want for yourself.
Don’t enable extended privileges unless they’re needed.

Suggestions for creating secure passwords

1 Secure passwords are typically eight or more characters in length, and include at least one 
numeric character.

1 Passwords are case-sensitive. For example, if you specify a password as zFootBallz2, 
FileMaker Pro will not accept zfootballz2. When you’re entering a password for an account, 
you may want to make sure the Caps Lock key on your keyboard is not inadvertently enabled.

1 If the file is shared via web publishing, account names and passwords can only use characters 
included in the ISO Latin-1 character set (except colons). To avoid characters that may be 
interpreted incorrectly over the web, you may want to limit account names and passwords to 
alphabetic and numeric characters only.

For more information about protecting FileMaker Pro databases, see Help.

Creating accounts and privilege sets
Accounts specify account names and (usually) passwords for a file. When a user opens a file that 
contains accounts, a dialog box prompts the user to enter account information. When a user opens 
a file with a correct account name and password, the privilege set assigned to that account 
determines what the user can do in that file.
Privilege sets specify levels of access to a database, such as which layouts are viewable, which 
menus are available, and whether printing is permitted.
To create and manage accounts and privilege sets for a file, you need to open the file with an 
account that is assigned the Full Access privilege set. 
You can create and modify accounts and privilege sets in a shared file while clients are using it. 
The account changes you make take effect immediately. However, the changes do not disrupt any 
current clients. For example, if you change the password for an account that is in use by one or 
more clients, their FileMaker Pro usage is not interrupted. However, they will need to enter the new 
password the next time they open the file.
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You can create as many accounts as you need. You can create individual accounts for each user, 
or a smaller number of accounts that users can share.

Viewing accounts and privilege sets
The Manage Security dialog box displays a list of all the accounts and privilege sets for a file.

To view the accounts and privilege sets for a file:

1. Open the database file.

2. Choose File menu > Manage > Security.
You see the accounts defined for this file. 

3. In the Manage Security dialog box, click the Privilege Sets tab.
You see the privilege sets defined for this file. 
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Creating accounts
You can create accounts for every individual who accesses a file, or create fewer accounts that 
are shared among many individuals, such as a “Marketing” account and a “Sales” account. You 
must assign a privilege set to each new account. 

To create an account:

1. Choose File menu > Manage > Security.

2. In the Accounts tab, click New.

3. In the Edit Account dialog box, for Account is authenticated via, choose FileMaker.

For information about accounts managed by an external server, see “Creating accounts that 
authenticate via an external server” on page 146.

4. Enter an account name and password for the account.

Tip   If you plan to create accounts for individual users, you may want to base each account 
name on the User Name defined in the Preferences dialog box. This User Name is the default 
account name that appears in the dialog box that prompts a user for an account name and 
password. The user won’t have to re-type the account name if it matches the User Name.

5. To force the account users to choose a new password the first time they log in, choose User 
must change password on next login.
In most cases, an account that is shared by multiple users should not force a password change 
upon first login. Instead, you should specify a password and provide it to the users that need it. 
Also, the privilege set for a shared account should not permit password changes because one 
user could change the password and lock out all other users who share the account.

6. For Account Status, choose whether you want the account to be active or inactive.
For example, you may want to keep the account inactive until you finish setting up its privilege 
set. Users cannot open a database using an inactive account name and password.

7. For Privilege Set, choose the privilege set you want to use with this account.
You can choose an existing privilege set, or choose New Privilege Set and create a new one. 
For more information, see “Creating privilege sets” on page 147.
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8. For Description, enter a description of the account (optional).

9. Click OK.

10. In the Manage Security dialog box, click OK. 

11. In the dialog box that appears, enter an account name and password that is assigned the Full 
Access privilege set, and click OK.

Creating accounts that authenticate via an external server
If you’re hosting FileMaker Pro database files with FileMaker Server and your organization uses 
centrally managed authentication for users and groups such as Apple Open Directory or a 
Windows Domain, you can set up accounts that authenticate users based on your authentication 
server. This allows you to use your existing authentication server to control access to databases 
without having to manage an independent list of accounts in each FileMaker Pro database file.

Note   Only database files hosted by FileMaker Server can authenticate users against an 
authentication server. Database files shared by FileMaker Pro won’t authenticate against an 
authentication server.

Important   When a database file contains one or more External Server accounts, make sure you 
use operating system security settings to limit direct access to the file. Otherwise, it might be 
possible for an unauthorized user to move the file to another system that replicates your 
authentication server environment and gain access to the file. For more information, see 
FileMaker Server Help.

To create an account that authenticates via an external server:

1. Choose File menu > Manage > Security.

2. In the Accounts tab, click New.

3. In the Edit Account dialog box, for Account is authenticated via, choose External Server.

4. For Group Name, enter the name of a group that is defined on an external authentication server.

5. For Account Status, choose whether you want the account to be active or inactive.

6. For Privilege Set, choose the privilege set you want to use with this account.
The privilege set assigned to the account determines what the externally authenticated group 
members can do in the database file. You can choose an existing privilege set, or choose New 
Privilege Set and create a new one. For more information, see the next section.

7. For Description, enter a description of the account (optional).

8. Click OK.

9. In the Manage Security dialog box, click OK. 

10. In the dialog box that appears, enter an account name and password that is assigned the Full 
Access privilege set, and click OK.
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Creating privilege sets
You can assign each privilege set to one or more accounts.

To create a privilege set:

1. Follow the steps above to display the privilege sets for a file. 

2. Click New.
The Edit Privilege Set dialog box appears. By default, each privilege set option is set to its most 
restrictive setting.

3. Enter a name and optional description for the privilege set.

4. Define the privileges for the privilege set.

5. Click OK.

After you create the privilege sets that you want, you need to create or edit accounts so that they 
use the appropriate privilege sets. For more information, see “Creating accounts” on page 145.
For more information about creating accounts and privilege sets, see Help.

About enabling record-level access
You can set individual record access for each table. For example, the privilege set can limit the 
ability to:
1 View, edit, create, or delete all or certain records within each table.
1 Access or modify certain fields within each table.

You can only set record access privileges for tables defined in the current file. If the file contains 
relationships to tables in other files that you want to protect, you need to create accounts and 
privilege sets in the other files to protect those tables.
For more information about using the Edit Privilege Set dialog box, see Help.
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Viewing extended privileges
Extended privileges determine the data sharing options that are permitted by a privilege set for a 
file. For example, if the file is shared, the Access via FileMaker Network extended privilege 
determines if the privilege set allows opening the shared file as a client. The Access via 
FileMaker WebDirect extended privilege determines whether the privilege set allows accessing 
the database from a web browser. 
There are six default extended privileges. For more information about them, see “Accounts, 
privilege sets, and extended privileges” on page 138.
You can view extended privileges in the Manage Security dialog box, as well as enable each 
extended privilege for selected privilege sets. All extended privileges except fmreauthenticate10 
are disabled by default, even in the Full Access privilege set.
It may be necessary to delete an extended privilege that is no longer required.

To view the extended privileges:

1. Open the database file.

2. Choose File menu > Manage > Security.

3. In the Manage Security dialog box, click the Extended Privileges tab. 

For more information about extended privileges, see Help.

Authorizing access to files
As part of your overall security plan, you can control whether other FileMaker Pro files are 
permitted to access the schema in a file (including its tables, layouts, scripts, and value lists) in 
your secured solution. When protection is enabled, any use of the protected file through a 
FileMaker data source will require authorization. Therefore, in a multi-file solution, you will need 
to authorize the other files.
For example, enabling protection prevents someone with an account in your file from creating 
another file that uses tables in your file but does not implement the same business logic (such as 
the same script triggers). The use of this alternative file can bypass your intended business logic 
(although record-level access would still be enforced). Turning on this option also prevents files 
that are not authorized from opening a protected file using the Open File script step.

Note   You must have the Full Access privilege set for any file that you want to protect and any file 
that you want to authorize.
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To authorize access to a file:

1. Open the file that you want to protect.

2. Choose File menu > Manage > Security, then click the File Access tab. 

3. To protect this file against unwanted access from other files, select Require full access 
privileges to create references to this file.

4. If any files that reference the protected file are currently open, you see an alert for each file, 
asking if you want to authorize the file. Click Yes.

5. If you want to authorize additional files that are not currently open, click Authorize. In the Open 
File dialog box, choose a local or remote file to authorize, and click Open.
You may be asked to enter the name and password of an account with Full Access privileges.

6. Click OK.

Keep the following points in mind:
1 A protected file retains its list of authorized files if the file is cloned or included in a runtime 

solution, so you don’t have to repeat the authorization process. However, if you duplicate or 
clone a protected file, each file will also have the same ID. If you use both files in the same multi-
file solution, you must reset the ID in one of the files so that each file has a unique ID. To reset 
the protected file’s unique ID, click Reset All, then click Yes. After resetting, you will need to 
reauthorize all files that are authorized to access the protected file and any protected files that 
file was authorized to access.

1 To set a file option that prevents a file from being opened with a version of FileMaker Pro, 
FileMaker Go, or FileMaker Server that’s earlier than the specified version, see Help.

For more information about authorizing access to files, see Help.
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Security measures
Be sure that your database files, host computers, workstations, and the networks that access 
them are safe from theft and corruption. To protect your data and equipment, you should 
implement the following five important security measures:
1 Enhance physical security
1 Enhance operating system security
1 Establish network security
1 Back up databases and other important files
1 Install, run, and upgrade antivirus software

For more information about securing FileMaker Pro files, see www.filemaker.com/support/security.

Enhancing physical security
Evaluate your computers to make sure they are physically secure:
1 The host computer should be a dedicated machine, anchored to a desk or immovable object 

with a lock. Secure the computer so that its hard drive cannot be removed. Restrict access to 
the computer by storing it in a locked room.

1 Secure the client workstations that access a database. Lock the computers down and restrict 
access by using a screensaver that requires a password.

1 Ensure the physical security of backup copies of files stored on portable media, such as tapes 
and CDs. 

Enhancing operating system security
Use the security features of your operating system to restrict access to important data. The 
network administrator should provide access only to individuals authorized to administer and 
maintain the system or the FileMaker databases. In addition, they should:
1 Track system user IDs and passwords. 
1 Restrict access to the FileMaker Pro application and file directories, servers, and web pages.
1 Review remote access settings for file sharing and FTP. 
1 Restrict file upload or download access.
1 Make sure all users have the latest, most secure versions of operating system software.
1 To streamline processes, you can enable external authentication, which uses accounts that 

have been configured in the Windows Domain Authentication or in Apple Open Directory. For 
more information, see Help.

1 Do not put FileMaker Pro files on file servers to share them. Use the built-in networking feature 
in FileMaker Pro and FileMaker Server. This prevents the files from being inappropriately 
copied or from introducing record locking and potential corruption issues when files are shared 
with inappropriate methods.
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Establishing network security 
Databases shared on an intranet or the Internet use the TCP/IP protocol. You may also use the 
TCP/IP protocol when you share databases peer-to-peer, or with FileMaker Server. Though 
TCP/IP is good for moving data and allowing clients to connect to your data, it was not designed 
with security as a primary objective. Unless you take precautions, it can provide uninvited access 
to your host computer, server software, databases, and perhaps to other client machines on your 
internal network. TCP/IP doesn't provide very much protection for data, so it is important to place 
barricades such as firewalls and SSL data encryption in the path of uninvited visitors.
1 The most common barricade method used is the firewall, which separates your network into two 

distinct environments: a public environment that is “outside the firewall,” and a private 
environment that is “behind the firewall.” Users outside of the firewall will only have access to 
those TCP/IP or hardware addresses that you expose. You can concentrate your security on 
those server machines that are exposed, while allowing machines behind the firewall to operate 
with fewer safeguards.

1 Using wireless networking devices, like the Apple AirPort Extreme and other 802.11n networking 
cards and base stations, can pose security challenges. These devices can broadcast your 
network traffic beyond the walls of your building, so it is extremely important to encrypt your 
wireless networking signals. Always use the maximum level of signal encryption available.

Backing up databases and other important files
Develop plans for restoring data, including alternate sites and systems to run business-critical 
information services. A current backup can help you recover from a situation where someone 
loses the administrator account information for a file, or from a situation where user error (and 
sometimes bad database design) causes data to be deleted or modified inappropriately.

Keep the following points in mind:
1 Host databases with FileMaker Server and create regularly-scheduled, automated backups.

Don’t use third-party backup software on hosted FileMaker Pro databases. First, use 
FileMaker Server to make a backup copy of your database, then run your third-party backup 
software on the copy. Backup software can damage open, hosted databases.
For example, make local backups of files at 6:00 am, 9:00 am, 12:00 noon, 3:00 pm, 6:00 pm, 
and 11:30 pm weekdays. At midnight, make an incremental backup of the entire system to the 
enterprise backup system. Finally, Friday night at midnight, perform a full system backup. Copy 
and store the backup tapes at a remote location. This way, if the server goes down for some 
reason other than catastrophic failure of multiple drives, the more recent backup of the data files 
can be used, meaning a maximum of 3 hours of lost data. If there is a catastrophic drive failure, 
then the previous evening’s tape can be used, minimizing the loss to one day’s data. Of course, 
these procedures can be tailored to your situation and data value. 

1 Make sure backup copies aren’t damaged or inaccessible. Verify that they are functioning properly 
before you need them. Run diagnostic tools on your hard drive and your backup files regularly.

1 Ensure that you can restore an entire set of files from backup copies.
1 Regularly export the data to protect against file corruption.
1 Protect the backup media itself. Store backups in a separate and fire-proof location. 
1 Assign backup administrators who can retrieve files, in case the network administrator is 

unavailable. 
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1 Plan for redundancy. If the power goes off, a universal power supply (UPS) should sustain 
power for at least 15 minutes, enabling you to safely close all files. If the power can’t be restored 
in a timely fashion, consider using a generator to supply power to servers. Also consider power 
sources for routers and firewalls. Will communication be a problem if your internet access is 
interrupted for 48 hours or longer? 

1 Consider how you will continue to provide services if an intruder takes down your database 
server and that server can’t be restored to its previous condition. 

1 Evaluate additional scenarios that could occur, and create a plan to respond to each one.

Also, network administrators should assess risks to data systems and business-critical functions. 
For example, consider:
1 Theft of data or theft of proprietary intellectual property. 
1 Disruption, theft, or damage to network infrastructure such as servers, networks, data storage, 

or data backup storage. Damage can be caused by password crackers or by other types of 
malicious sabotage and destruction. Most incidents originate from within the organization. 

1 Disruption or damage to the organization infrastructure such as building fires, environmental or 
biological hazards, floods, and so on. 

1 Disruption or damage to the public infrastructure, including electrical power, 
telecommunications (voice and data), transportation grids (roadways, buses, trains) caused by 
environmental conditions, or severe weather such as tornadoes or floods.

FileMaker Pro provides two mechanisms for handling databases that might be damaged: 
consistency checks and file recovery. Consistency checks occur automatically, if needed, when 
the file is opened. You can also choose to verify the consistency of a file that you suspect is 
damaged. You can also have FileMaker Pro attempt to recover a damaged file. For more 
information about checking consistency and recovering files, see Help.

Important   In the event of a server failure, such as an unexpected loss of power, hard drive 
failure, or software failure, use the backup files. Any system failure causing FileMaker Server to 
shut down inappropriately can result in corrupted files if cached data was not written to disk and 
the files were not closed properly. Even if the files re-open and go through a consistency check or 
recovery (initiated by either FileMaker Pro or you), corruption might be buried in the file. File 
recovery cannot guarantee that problems have been fixed.

Installing, running, and upgrading antivirus software
Because most computers have internet access, they are vulnerable to harm, such as from viruses 
being transmitted through email attachments. Make sure all employees run antivirus checking 
software regularly, and that they are aware of typical virus warning signs. Employees should scan 
all files before copying or downloading them to their computer, and they should never open 
unsolicited attachments, even if they’re from someone they know.
While antivirus software is essential in protecting your systems and data, some caution should be 
observed in how they are used on computers that host FileMaker Pro databases. 
Antivirus programs sometimes lock bytes within a file when they scan for viruses. These locks can 
cause the operating system to return an error when FileMaker Pro or FileMaker Server try to write 
data to the file, which sometimes causes the file to be flagged as damaged and closed.
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This situation also applies to files that FileMaker Server uses as backup targets. If the backup file is 
being scanned by antivirus software when a scheduled backup occurs, the destination file might be 
locked. This causes the backup process to fail, which may result in data loss. This same data loss 
issue applies when an open, non-shared FileMaker Pro database file is scanned by antivirus software.

When running antivirus software on computers that host FileMaker Pro databases, follow these 
recommendations:
1 Do not run virus protection software on open or hosted databases. First, close the databases, 

then run the virus protection software.
1 When you scan your computer for viruses, do not scan the Databases folder and subfolders or 

any folder that contains files that actively hosts files through FileMaker Server or FileMaker Pro. 
Instead, set your antivirus software to scan your database backup destination folder and make 
sure your antivirus scan schedule does not coincide with your FileMaker Server backup 
schedule. Wait until databases are completely backed up before scanning them.



Chapter 7  
Converting databases from FileMaker Pro 11  
and earlier

You must convert files created in FileMaker Pro 11 and earlier to the FileMaker Pro 12 format in 
order to use them with FileMaker Pro 13.

When you convert a file, FileMaker Pro creates a Conversion.log file, so you can view the 
conversion status and any problems that may have occurred during the conversion process.

Keep the following points in mind:
1 You can only convert files created in FileMaker Pro version 7.x, 8.x, 9.x, 10.x, or 11.x to the 

FileMaker Pro 12 format. After conversion, files will only be compatible with FileMaker Pro 12 
or later supported versions. To convert files earlier than FileMaker Pro 7, use the latest trial 
version of FileMaker Pro 11, which you can download at http://www.filemaker.com/downloads.

1 Manual corrections may be necessary. You might need to correct items in the converted file that 
did not convert properly. In some cases, you may need to correct items in the original file and 
then convert the file again. After you convert any file, you should review the Conversion.log file 
for items that may need to be corrected.

1 You should test the converted file. The Conversion.log file may not indicate every item in the 
file that needs to be corrected. Before you begin using a converted database solution, you 
should test it thoroughly to make sure every aspect has converted successfully. For example, 
make sure every script works as you expect, and that accounts and privilege sets provide the 
required file security.

Keep the following points in mind:
1 Although FileMaker Pro 12 and FileMaker Pro 13 use the same file format, using 

FileMaker Pro 12 to modify files that use features new in FileMaker Pro 13 is not 
recommended. 

1 See Help for comprehensive information and step-by-step procedures about converting 
FileMaker Pro files.

Conversion overview
When you convert files, FileMaker Pro 13 preserves the contents of your original files and creates 
new, converted files in FileMaker Pro 12 format. The content of the original files are not modified, 
and you can open them in a previous version of FileMaker Pro. Before you convert a 
FileMaker Pro database, you should plan the conversion carefully. 

You can convert a single file or convert multiple files at once:
1 Convert single files for standalone database files that don’t display related data from other files.
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1 Convert multiple files all at the same time to convert all the files in a relational database. There 
are several ways to select the files that you want to convert; you can drag and drop the files (or 
a folder containing the files) onto the FileMaker Pro 13 application icon, or you can select 
multiple files in the FileMaker Pro Open dialog box.

Note   When multiple files from separate folders are converted, all converted files are created in 
the same folder. The original files’ locations are not preserved. To make converting files easier, 
convert all the files from a multi-file relational database at the same time. After the conversion, you 
can move either set of files into a duplicate of your original file structure.

For more information about converting single and multiple files, see Help.

Solving basic conversion problems
Here are some suggestions for correcting problems that could occur during conversion.

FileMaker Pro 13 can’t open my file

If the file you want to convert is open in an earlier version of FileMaker Pro (for example, an 
Inventory.fp7 file is open in FileMaker Pro 11), close the file in the earlier version.

My file didn’t convert properly

1 If you are converting a copy of a file, make sure that the original file was closed before you 
copied it. Otherwise, the copy will not convert correctly.

1 Check the Conversion.log file located in the folder with the database you are attempting to convert.
1 Try recovering the file first using a previous version of FileMaker Pro and then convert the file again. 

I received a consistency check or auto-repair message when I opened my original file with that 
version of FileMaker Pro

Try recovering the original file using your version of FileMaker Pro. Then open the recovered file 
with that same version, close the file, and then try converting it with FileMaker Pro 13.

The converted file won’t accept my password

Passwords are case-sensitive in FileMaker Pro. Make sure you enter your password exactly as it 
was created in a previous version of FileMaker Pro. If you are not the owner of the file or the 
database administrator, consult your database administrator for password information.

I can’t open a snapshot link

You cannot open a snapshot link that was created using FileMaker Pro 11. You must convert the 
database from which the records were found and then re-create the snapshot link.

I can't edit a layout object that I copied from a FileMaker Pro 11 file

You cannot edit layout objects that were copied from files created with versions of FileMaker Pro 
earlier than FileMaker Pro 13. Either convert the file to FileMaker Pro 13 and edit the object, or re-
create the object in a new FileMaker Pro 13 file. 
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Data types
See also Field types
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Database solutions

See also Databases; Files
described   10



158

Databases
creating   55
described   14
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preference for creating new   56
printing   45
protecting   137
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Databases, relational. See Relational databases
Date fields

described   58
entering and editing values in   28
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See also Date fields
displaying calendars   91
entering data   28
finding   36
finding today’s   36
formatting   95
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lookups   121
passwords   143
privilege sets   147
summary fields   65
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Defining fields
in Field Picker dialog box   59
in Manage Database dialog box   61
in Table View   63

Deleting
data   28
field definitions   62
fields from a layout   91
find requests   41
related records   27, 120

Document preferences   50
Drag and drop fields onto layout   90
Drop-down calendar   91
Drop-down lists, displaying fields as   91
Duplicate records, finding   39
Duplicating

files   21
records   25, 30
related records   26
tables in the relationships graph   117

Dynamic guides, in Layout mode   87
Dynamic reports, creating in Table View   30, 65

E
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sending from FileMaker Pro   130
sending through SMTP   130
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Encrypted connection (SSL) to host   18, 127
Encryption. See Accounts; Privilege sets
Entering data

automatically   68
typing in fields   28
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Envelopes, printing   47
Excel format
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saving data as   130

Exchanging files
exporting   130, 135
importing   130
relational databases   108
with other applications   130

Exporting
See also Exchanging files
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file formats   130
formatting   135
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described   138
viewing   148
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External Server account   138, 146

F
False result   36, 58, 70, 95
Favorite files   18
Field behavior   27, 99
Field content match   35
Field definitions

copying   21
deleting   62

Field labels   90
Field names   57
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Field tool   90
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Field values
deleting   28
described   16
entering and editing   28
entering automatically   68
finding and replacing   42
prohibiting change   68

Field/Control tool   90
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Fields
adding in Table View   63
adding to a layout   89
creating and changing   57
creating in Manage Database dialog box   61
creating in Table View   63
defining   57
deleting definition   62
deleting from a layout   91
described   15
displaying   10, 73
empty or non-empty, finding   38
entry options   67, 91
formatting   93
formatting data   93
global   71
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indexing   71
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merge   92
naming   60, 61
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removing from a layout   91
restricting data entry   99
selecting   27, 88
stored and unstored results   71
text baselines   94
types   58
typing in   28
validation options   69

File formats, import/export   130
File options   50, 149
File paths   127
File references. See data sources
File sharing, enabling   125
FileMaker Go

and sharing files   124
designing layouts for using screen stencils   87
extended privileges for   139
layout themes for   78
privileges for   147

FileMaker Pro
documentation information   8
file format   130
product overview   10

FileMaker Pro Advanced   9
FileMaker Pro format   130
FileMaker Server

described   146
privileges for   139, 148
recommended use   124
uploading database files to   129

FileMaker WebDirect
described   12, 124, 136
privileges for   147

Filename extension, fmp12   18

Files
accounts   138
authorizing access for   148
authorizing access to protected files   12, 148
backing up   50
cloning   21
closing   20
converting   154
copying   20
creating   55
described   15
duplicating   21
encrypted connection (SSL) to host   18, 127
exporting to   135
hosted   18, 127
opening   16
opening across platforms   18
planning   51
privilege sets   138
protecting   137
remote   17
saving   20
saving as self-contained copies   21
shared

on web   136
planning security for   142

templates, described   55
Filtering records in portals   120
Find mode, described   22
Find requests

See also Finding records
adding new   39
broadening criteria   40
deleting   41
described   32
editing   41
mixing find and omit   40
multiple   39, 40
narrowing criteria   39
operators in   33, 37
order of   41
repeating   41
reverting   41

Finding and replacing field values
described   42
panel controls   43
popovers   43
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Finding records
See also Find requests, Quick finds
adding new request   39
all records   34
Boolean numbers   36
described   31
duplicate records   39
empty or non-empty fields   38
exact values   35
excluding records   40
invalid values   36
logical AND searches   39
logical OR searches   39
multiple criteria   39
omitting records   40
order of requests   41
partial or variable text   34
quick finds in Browse mode   31
ranges of information   37
related fields and records   38
saving and sending as snapshot link   12, 32
showing all records   34
symbols   35
today’s date   36

fmp12 filename extension   18
Footers, described   100
Form letters   92
Form View, described   23
Formatting

calculations   95
dates   95
export data   135
graphics   98
import data   130
layout objects   83
numbers   95
paragraphs   94
text   93
times   96
timestamps   97

Forms, viewing records as   22
Formulas, calculation fields   63
Found set

described   22, 32
saving and sending as snapshot link   12, 32
switching with omitted set   42

Four-digit years
in Date fields   28, 69
in Timestamp fields   28

Fraction of Total of, for summary fields   66
Full Access privilege set, described   140, 148
Functions   64

G
Getting Started tour   9
Global storage options   71
Grand summaries, described   101
Graphics, formatting fields for   98
Grid, in Layout mode   86

Groups. See Accounts; Privilege sets
Guest account   140
Guides, in Layout mode   86

H
Headers, described   100
Help, getting for FileMaker Pro   8
Hiding records   42
Highlighting text   94
Horizontal charts   105
Host

database on web   136
described   125
encrypted connection (SSL)   18, 127
FileMaker Server   124
performing tasks   128
saving files   125

HTML table format   130

I
Importing

adding new records   132
described   130
file formats supported   130
into existing files   132
into new tables   132
layout themes   78
recurring imports, described   130
source file or table   132, 134
target file   132
updating existing records   132
updating matching records   133

Indexing
fields   71
text field limitations   36

Inserting files into container fields   29
Inspector

described   81
formatting

field data   93
layout objects   83

opening   83
opening multiple   83
positioning layout objects   84

Intranet
See also Web
files shared on   136

Invalid values, finding   36

J
JDBC

field name considerations   57
privileges for   139, 147

Join expressions. See Relationships
Join fields. See Match fields
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K
Key fields. See Match fields

L
Labels

field   90
part   99
printing   47
vertical   76

Labels (mailing), printing   46
Labels layouts, described   76
Layout background, setting styles for   101
Layout bar   19, 22
Layout folders, managing   74
Layout mode

changing default when creating new database   56
creating charts in   105
described   22

Layout objects. See Objects
Layout parts

body   100
described   100
field labels   90
footer   100
grand summary   101
header   100
setting styles for   101
subsummary   101
title header and footer   100

Layout pop-up menu   19, 73
Layout themes

changing   56
described   78
importing   78

Layouts
adding fields   89
Blank   75
changing theme   78
changing width   56
charting data   105
columns

changing width   80
setup   79

creating   73
described   10, 73
Envelopes   77
fields

displaying   10, 73
dragging onto layout   90
merge   80
placing   89
placing related   92
removing   91
selecting   88

form view   22
Labels   76
List view   77
managing layouts and layout folders   74
Mode pop-up menu   22
popovers on   82
printing   45
Report   77
slide panels on   81
tab panels on   81
themes   78
tools   81
types   75
unit of measure   84
vertical labels   76

Leader, setting character for paragraphs   94
Limits

characters in fields   28
field names   57

Line charts, described   105
List of, for summary fields   66
List view layout, described   77
List View, described   23
Lists, viewing records as   22
Literal text searches   35
Locked objects   88
Locking, shared records   128
Logical

AND searches   39
OR searches   39

Lookups
changing   123
defining   121
described   108
lookup source field   111
lookup target field   111
stopping or suspending   123
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M
Macros. See Scripts
Mail merge, using merge fields   92
Mailing labels   76
Manage Database dialog box, creating and changing fields 

in   61
Managing layouts and layout folders   74
Margins, displaying in Preview mode   45
Match fields

See also Fields
described   111, 112
in import update   133

Matching records, updating   133
Mathematical operators   64
Maximum characters in fields   28
Maximum, for summary fields   66
Merge fields

described   47
placing on a layout   92

Merge format   130
Microsoft Excel format

importing and exporting   130
saving data as   130

Minimum, for summary fields   66
Mode pop-up menu   22, 73
Modifying fields in Table View   63
Mouse, configuring in System Preferences (OS X)   14
Moving

field to field   27
record to record   24

Multimedia files   58

N
Naming

fields   60, 61
tables   73

Network security guidelines   151
Networks

cross-platform   13, 124
FileMaker Server   124

New Layout/Report assistant, described   74
Non-shared files   143
Number fields

See also Fields
described   58
entering and editing values in   28
finding   36
formatting   95

Numbers
formatting   95
invalid   36

O
Objects, layout

aligning to other objects   83, 85
described   81
formatting   83
locked   88
positioning   84
selecting   88
setting auto resize options   85
setting styles for   101

ODBC
overview   131, 132
using FileMaker as client

described   136
supplemental fields   67

using FileMaker as data source
field name considerations   57
privileges for   139, 147

Omitting
fields during printing   92
records   40
related records   38, 41

Opening
files   16
multiple windows   19

Operators
comparison   64
in find requests   33, 37
mathematical   64
relational   111, 115, 119

Operators list   33
Options, file   50
OR searches   39

P
Page breaks

showing or hiding in Layout mode   85
showing or hiding in relationships graph   118
viewing in Preview mode   45

Page breaks, viewing in Preview mode   45
Page margins, viewing in Preview mode   45
Page numbers

in layout parts   77
viewing in Preview mode   45

Panels, slide panels and tab panels   81
Paragraphs, formatting   94
Parts. See Layout parts
Passwords

defining   143
protecting files with   143
related files, planning   55

PDF documentation   8
PDFs, saving data as   130
Photos, in container fields   58
Picture fields. See Container fields
Pie chart icon in status toolbar   33
Pie charts, described   105
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Planning
databases   51
file security   141
relational databases   51

Pointer tool. See Selection tool
Pointers to files. See Relationships
Popovers

described   82
finding and replacing field values   43
including in tab order   27

Pop-up menus, displaying fields as   91
Portals

See also Relational databases
adding records   26
deleting records   27
described   111, 114
filtering records in   120
omitting related records   41
placing related records   92
selecting   88
selecting records   24
summarizing data in   120

Positive/negative column charts   105
Preferences

application   50
described   50
file   50

Preview mode, described   22, 45
Previewing printing. See Printing
Previewing columns   79
Primary keys. See Match fields
Print area, viewing   45
Printing

Asian text   99
blank records   46
described   44
envelopes   46, 47
information about database   48
labels   46, 47
previewing   45
records   45
records in columns   79
scripts   48

Privilege sets
Data Entry Only   140
defining   147
described   138
Full Access   140, 148
predefined   140
Read-Only Access   140
viewing   144

Protecting files. See Accounts; Authorizing files; Privilege sets
Publishing databases on the web   136

Q
Quick charts, creating   30, 105

Quick finds
See also Finding records
badges in fields   32
configuring   32
described   31
enabling   32
performing   31

Quick Start Screen, described   16
Quotation marks in searches   34, 35

R
Radio buttons, displaying fields as   91
Ranges of information, finding   37
Read-Only Access privilege set, described   140
Recent files   18
Record locking   128
Records

active   24
adding   25, 30, 132
browsing

in a list   22
individual   22

copying   25, 30
deleting   30
deleting related   27
described   16, 17
displaying sorted related   120
duplicating   25, 30
exporting   135
filtering in portals   120
finding   31
hiding   42
locked   128
matching   133
moving through   24
omitting   40
printing in columns   79
selecting   24
sorting   35, 43

in Table View   30
related records   120

viewing as forms, lists, or tables   22
working with in Table View   30

Recurring imports
account for setting up   131
described   130

Related fields
See also Fields; Relational databases
calculations   64
described   111
on layouts   90
planning   54
summarizing data   120

Related files, restricting access   55
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Related records
See also Records; Relational databases
adding   26, 120
copying   26
deleting   27, 120
described   111
displaying in portals   92
duplicating   26
finding and omitting   38
placing in portals   92
sorting   120
summarizing data   120

Related tables
described   111
planning   51

Relational databases
described   15, 108
match fields

described   111
planning   112

planning   51, 117
portals   111
related tables

described   111
planning   51

terminology   111
Relational operators   111, 115, 119
Relationships

See also Relational databases
changing   119
comparative   115
creating   118
described   111
multi-criteria   114
planning   54
returning range of records   116
self-joining   117
single-criteria   113
types   112

Relationships graph
creating relationships   118
described   111, 112
text notes in   118

Repeating find requests   41
Report layout

described   77
with grouped data   77

Reports
See also Columnar list/report layout; Layouts; Subsumma-

ries
creating   73
previewing   45
records in columns   79
with grouped data

creating   77
printing   45

Restricting access. See Accounts; Privilege sets
Retrieving data from other files. See Exchanging files
Reverting find requests   41
Right-click to display context menu   14

Rights. See Accounts; Privilege sets
Rulers, showing and hiding   85

S
Saving

data automatically   20
files   20
found set as snapshot link   12
shared files   125
to Excel and PDF formats   130

Scatter charts   105
Screen stencils, in Layout mode   87
Script triggers   12, 49
Scripts

copying   21
described   12, 49
performing   49
printing   48

Searching. See Finding records
Secondary files. See Relational databases
Security, file

network guidelines   151
operating system guidelines   150
planning   141, 150

Selecting
fields   27, 88
objects   88
records   24

Selection tool   88
Self-contained copies of files   21
Self-joins

described   117
for summarizing data in portals   120

Server. See Host; FileMaker Server
Settings. See Preferences
Shared files

See also Networks
accounts   142
clients   125
host   125
limitations   124
on web   136
opening   17
privilege sets   142
saving   125
setting up privileges for   138

Shortcut menu, choosing from   14
Simple Mail Transfer Protocol (SMTP), sending email 

through   130
Single-page form layout. See Table View
Slide controls

described   81
finding and replacing field values   43
including in tab order   27

Slide panels, described   81
Slider, for moving through records   24
Snapshot links, saving and sending found set as   12, 32
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Solutions, database
See also Databases; Files
described   10

Sorting records
described   35, 43
in Table View   30
related   120

Sound files   58
Source file (relationships), described   111
Source table (relationships), described   111
Stacked bar charts   105
Stacked column charts   105
Standard Deviation of, for summary fields   66
Starter Solutions. See Templates
Status toolbar   22, 81
Stopping lookups   123
Storage options for container fields   68
Stored results   71
Strict data type   69
Strings, text. See Text, literal
Styles, setting for objects, parts, layout background   101
Subforms. See Portals
Subsummaries

See also Reports; Summary fields
creating reports   77
parts, described   101
printing   45

Subtotals. See Subsummaries; Summary fields
Summarizing data in related fields   120
Summary fields

Average of   66
Count of   66
creating   65
defining in Table View   65
described   58, 65
Fraction of Total of   66
List of   66
Maximum   66
Minimum   66
on layouts   101
options for   66
Standard Deviation of   66
Total of   66

Summary parts. See Subsummaries
Supplemental fields   67
Symbols

and field names   57
finding   35

System Preferences, configuring mouse (OS X)   14

T
Tab controls

described   81
finding and replacing field values   43
including in tab order   27

Tab order   27
Tab panels, described   81

Table format
See also Table View
described   22
viewing records as   22

Table View
See also Table format   29
adding records   30
changing column order and size   29
copying records   30
creating and changing fields in   63
creating dynamic reports   30, 65
creating quick charts   30
defining summary fields   65
deleting records   30
described   23
duplicating records   30
hiding or showing fields   63
sending email messages based on record data   30
sorting records   30
viewing data   29
working with records   30

Tables
defining   72
described   15
importing data into new   132
naming   73
table occurrences   112
viewing records as   22

Tabs
inserting in fields   28
setting position and alignment   94

Tab-separated text format   130
Templates

creating files   55
described   55

Text
See also Fields
aligning with checkboxes and radio buttons   94
attributes   93
changing color   94
fields   58
finding   35
formatting   93
highlighting   94
literal   34
rotating Asian text   98
selecting   88

Text baselines, specifying options for   94
Text fields

described   58
entering and editing values in   28

Text notes, in relationships graph   118
Themes, layout

changing   56, 78
described   78
importing   78

Time fields
described   58
entering and editing values in   28
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Times
finding   36
formatting   96
invalid   36

Timestamp fields
described   58
entering and editing values in   28
four-digit years   28

Timestamps, formatting   97
Title headers and footers, described   100
Today’s date, finding   36
Tools

Field tool   90
Field/Control tool   90
Popover Button tool   82
selection tool   88
Slide Control tool   82
status toolbar   22
Tab Control tool   81

Total of, for summary fields   66
Triggers, script   12, 49
True result   36, 58, 70, 95
Type-ahead feature   91

U
Unauthorized users. See Accounts; Privilege sets
Unit of measure, changing   84
Unstored results   71
Updating existing data during import   132
Uploading files to FileMaker Server   129

V
Validating field values   69
Value lists

defining   68
described   91
in shared files   128
sorting by   30

Values
See also Field values
finding duplicates   39
finding exact   35

Variables, symbols for   57
Vertical charts   105
Vertical Labels layout, described   76
Vertical writing   98
View as Form, described   22
View as List, described   22
View as Table, described   22
Viewing

accounts   144
extended privileges   148
page breaks and page numbers in Preview mode   45
print area   45
privilege sets   144
records as forms, lists, or tables   22

Virtual results   71

W
Web viewer   11
Web, and field name considerations   57
Wildcards in searches   34, 35
Windows

closing   20
opening multiple   19

Windows Domain   146

X
XML

importing and exporting to   130
privileges for   139, 147

XML format   130

Y
Y2K, year validation   69, 70
Years

four-digit in Date fields   28, 69
four-digit in Timestamp fields   28
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